Notices


Reply
Thread Tools
Posts: 5 | Thanked: 0 times | Joined on Aug 2010
#1
Hi,

My N900's great, but I'm struggling to use it as a word processor, which was the main reason I wanted it, due to the lack of a tab key.

When using Documents to Go, which is a very good product in most other respects, the additional character set (including tab) that can normally be brought up by pressing blue arrow and control doesn't work. The virtual keybaord doesn't contain tab either so that option has been removed.

Dataviz make themselves un-contactable and don't answer their support forum, so the only option remaining seems to be remapping one of the keys to tab.

I read this: http://wiki.maemo.org/Remapping_keyboard and a couple of threads on the topic but couldn't work out how to actually edit the file.

Is there a really simple step by step guide explaining how to do this somewhere? I don't know where to start and don't want to brick my Nokia.

Thanks,

MrTab
 
Posts: 118 | Thanked: 202 times | Joined on Aug 2010
#2
Check my post here:

It's not "step by step", but if you have a look at my rx-51 file there you can see how it's done fairly easily.

If you are using the normal English layout have a look at the bottom section starting with
Code:
partial hidden alphanumeric_keys
xkb_symbols "english_base" {
each key is assigned four values, from left to right:
standard key, shift+key, sym+key, shift+sym+key

E.g. your beloved Tab is realized by Sym+Space; check out the third column in this line:
Code:
key <SPCE>  { [     space,          at,             Tab,            bar ]}
Hope this helps.
 
Posts: 2,829 | Thanked: 1,459 times | Joined on Dec 2009 @ Finland
#3
Originally Posted by nephridium View Post
..each key is assigned four values, from left to right:
standard key, shift+key, sym+key, shift+sym+key
...
Hmm. This third doesn't work on my keyb. I have nordic/finnish layout.
 
Posts: 5 | Thanked: 0 times | Joined on Aug 2010
#4
Thanks nephridium,

I can't even get into it though, I tried installing Leafpad and Rootsh then typing
cp usr/share/x11/xkb/symbols/nokia_vndr/rx-51
as suggested on some hacking site but to no avail - it just comes up with the error cp:cannot stat 'leafpad': No such file or directory.

I'm sure I'm missing something but I just don't get it.
 
Posts: 118 | Thanked: 202 times | Joined on Aug 2010
#5
Argh, sorry, forgot to post the link to my post up there: http://talk.maemo.org/showpost.php?p=793872&postcount=7 . I was on the train and had to get off, so I just hit "submit" without double checking

Download the rx-51.zip file from there and unpack it. I'd say open it on your PC and look at the aforementioned section in the file for which lines you want to use in yours.

First back it up though:
cp /usr/share/X11/xkb/symbols/nokia_vndr/rx-51 /home/user
This copies the file to your home folder. The tutorial states that you shouldn't put the backup copy into the same folder (/usr/share/X11/xkb/symbols/) or you might need to reflash. Then enter
sudo leafpad /usr/share/X11/xkb/symbols/rx-51
into the console. You have to use sudo because the file is protected. Then find the section mentioned above, it's close to the bottom of the file. From there you can see what to change to get Tab and the other keys to work. Some keystrokes won't work with Shift though, so you need to try around a bit.

Sorry to hear Sym+Shift doesn't work on nordic layout, I've only tested with standard layout and was quite happy with it. Maybe it's possible to set the phone to use the standard layout and overwrite the standard key mappings with the nordic ones.

In any case before playing with config files like this one I would suggest to first make a backup of at least the root partition using backupmenu.

Last edited by nephridium; 2010-08-27 at 20:02.
 

The Following User Says Thank You to nephridium For This Useful Post:
Posts: 5 | Thanked: 0 times | Joined on Aug 2010
#6
Thanks Nephridium,

That worked brilliantly, I've now got tab, page up and down, home and end mapped onto the keyboard my N900 didn't get bricked and they work in everything... except Documents to Go!

As it seems the new keys work in all the other applications and DataViz don't believe in customer service maybe I'll just find another word processor.
 
Posts: 2,220 | Thanked: 3,778 times | Joined on Jun 2010 @ Florida
#7
Am I the only one who has tried to do this who also runs the experimental universal portrait keyboard ( http://talk.maemo.org/showthread.php?t=55371 )?

Does anyone who understands the way that keyboard works have any insight as to whether or not it might be interfering with this?

I've tried modifying the rx-51 file to make my spacebar use space, tab, at, at, saved, then ran "setxkbmap" and it told me "Error, can't load new keyboard configuration", or some such. I then proceeded to edit it back to normal, ran setxkbmap again, and got the same error. I tried a couple more different modifications of rx-51 to see if maybe changing any other values other than space+shift to Tab would make it work, thinking perhaps Maemo didn't recognize that the file had changed or something. Did some more fiddling with the space and the arrow key mappings. Kept getting the same error, so after a bunch of browsing of this forum and having found no one else reporting this, decided to over-write the modified file(s - I also edited the rx-44 to see if that would make anything happen) with the back-ups, and am leaving it alone for now.

But wondering if anyone has any insight into this.
 
Posts: 1,522 | Thanked: 390 times | Joined on Jul 2010 @ São Paulo, Brazil
#8
Is there a GUI for setting up the layout and ky combinations?
 
Posts: 49 | Thanked: 16 times | Joined on Feb 2011
#9
how to fix Error, can't load new keyboard configuration


all times ive tried to setup new layout with "setxkbmap" and it told me "Error, can't load new keyboard configuration",
 
endsormeans's Avatar
Posts: 2,284 | Thanked: 5,570 times | Joined on Feb 2013 @ From my Gabriola Island hermitage, near the Edge of the World
#10
I am surprised I never saw this thread before...
thanks for bringing it back from the great abyss of oblivion El Cid....

I don't think it is an instructional on keyboard for idiots ...though...

I came here hoping for pictures ...

Cartoon explanations...
Puppet demonstrations...
anything...
even "Highbrow" ...diagrams...

Nothing...
only "takakakaka" typing text big wordy-words...

So this is definitely a few tiers higher than "Idiot Grade" material...

I am sooooo disappointed ...

"Why oh why oh why must you turn this place into a House of Lies!!!!"
__________________
Lurker since 2007,
Member since 2013,
Certifiable since 1972

Rosa sum ergo spam sum....
I am pink, therefore I am spam


Owner of :
1-n770 (in retirement),
3-n800's and 3-n810's (still in daily use),
5-n900's ((3 are flawless, 1 has loose usb ( considering it for parts), 1 has no telephony (perfect for permanent set-up as mini-pc with one of my monitors))
1/2 - neo900 pre- "purchased" in 2013. Due for production ̶a̶n̶y̶ ̶m̶o̶m̶e̶n̶t̶ ̶n̶o̶w̶ . .
3-nexus 5's : 1 with ̶L̶i̶n̶e̶a̶g̶e̶ ̶O̶r̶e̶o̶ ̶8.̶1̶ P̷l̷a̷s̷m̷a̷ ̷M̷o̷b̷i̷l̷e̷ Lineage oreo 8.1 (intend maemo leste when ready) , 1 with ̶U̶b̶u̶n̶t̶u̶ ̶T̶o̶u̶c̶h̶ Bliss OS, 1 with ̶P̶l̶a̶s̶m̶a̶ ̶M̶o̶b̶i̶l̶e̶ Maru OS


PIMP MY N8X0
Idiot's Guide and a video walkthrough.
http://talk.maemo.org/showthread.php?t=94294
THE LOST GRONMAYER CATALOGS
http://talk.maemo.org/showthread.php...ight=gronmayer
N8X0 VIDEO ENCODING THE EASY WAY
http://talk.maemo.org/showthread.php...ght=mediacoder
242gb ON N800
http://talk.maemo.org/showthread.php?t=90634
THE PAIN-FREE MAEMO DEVELOPMENT LIVE DISTRO-ISO FOR THE NOOB TO THE PRO
http://talk.maemo.org/showthread.php?t=95567
AFFORDABLE MASS PRODUCTION FOR MAEMO PARTS
http://talk.maemo.org/showthread.php?t=93325
 

The Following User Says Thank You to endsormeans For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 00:03.