Notices


Reply
Thread Tools
Posts: 82 | Thanked: 406 times | Joined on May 2016
#91
Originally Posted by bomo View Post
As also tmi said that V3 is currently very hard to find, I want to ask you directly: Is the only problem of V5 and (V6? or V7?) that you are not sure whether your port works there or are you sure that further adaptions are needed due to hardware changes in these revisions?
I'm sure futher adaptations are needed for V5 (sound doesn't work, only through Bluetooth). No idea about V7 (the golden one), since no one had it here before.
 

The Following 4 Users Say Thank You to TheKit For This Useful Post:
Posts: 7 | Thanked: 13 times | Joined on Jan 2017
#92
Hi,

I just received a V820W, sadly the Version 5.

However, Sailfish OS intallation went smoothly, needed two tries for the update to 2.0.5.4 but now it's running. Audio does not work, neither does bluetooth (cannot be enabled).

Had some trouble to get into WiFi at the beginning as I could not see the scanning results - it seemed I could not scroll down in the Result window, possibly a graphics issue. Managed to get it working using connmanctl.

Two things I noticed on the installer: First, it does install to NAND, not to the SDCard (probably my mistake, I did not understood that in the description). So bye-bye to Windows and Android :-)

Second, the installer creates a 10 GB partition though the device has 32 GB which renders the 20 GB useless. Maybe I try to reinstall Windows 10 on it or make it a seperate /home partition.

Thanks to all the porters!
 

The Following 4 Users Say Thank You to tmichel For This Useful Post:
Posts: 119 | Thanked: 237 times | Joined on Nov 2014
#93
I'd guess the 10GB partition could be resized with gparted.
Here are instructions for installing Linux Mint on the tablet featuring also the makings of a bootable USB flashdrive (including gparted).
 

The Following 2 Users Say Thank You to tmi For This Useful Post:
Posts: 82 | Thanked: 406 times | Joined on May 2016
#94
Originally Posted by tmichel View Post
Hi,

I just received a V820W, sadly the Version 5.

However, Sailfish OS intallation went smoothly, needed two tries for the update to 2.0.5.4 but now it's running. Audio does not work, neither does bluetooth (cannot be enabled).
Could you try rebooting and then enabling Bluetooth by single tap in settings? There is some race-condition with rkfill and hciattach.

On a side note, I see there is a newer and (probably) easier to get Onda V80 SE with the same SoC, but hard to say how different is it.
 

The Following 2 Users Say Thank You to TheKit For This Useful Post:
Posts: 7 | Thanked: 13 times | Joined on Jan 2017
#95
[QUOTE=TheKit;1521772]Could you try rebooting and then enabling Bluetooth by single tap in settings? There is some race-condition with rkfill and hciattach.

Hi,same problem, Bluetooth icon is just blinking. While BT is of, I get lots off errors in the journal:


Jan 11 13:01:58 Sailfish kernel: RTL871X: IsBtDisabled=0, IsBtControlLps=0
Jan 11 13:01:58 Sailfish kernel: RTL871X: (+)Tx = 0, Rx = 0
Jan 11 13:01:58 Sailfish kernel: RTL871X: CurIGValue=41, EntryMinUndecoratedSmoothedPWDB = 36
Jan 11 13:01:59 Sailfish kernel: Bluetooth: Controller acked invalid packet
Jan 11 13:01:59 Sailfish kernel: Bluetooth: Controller acked invalid packet
Jan 11 13:01:59 Sailfish kernel: Bluetooth: Controller acked invalid packet
Jan 11 13:01:59 Sailfish kernel: Bluetooth: Controller acked invalid packet
Jan 11 13:01:59 Sailfish kernel: Bluetooth: Controller acked invalid packet
Jan 11 13:01:59 Sailfish kernel: Bluetooth: Controller acked invalid packet
Jan 11 13:01:59 Sailfish kernel: Bluetooth: Controller acked invalid packet
Jan 11 13:01:59 Sailfish kernel: Bluetooth: Controller acked invalid packet
Jan 11 13:01:59 Sailfish kernel: Bluetooth: Controller acked invalid packet
Jan 11 13:01:59 Sailfish kernel: Bluetooth: Controller acked invalid packet
Jan 11 13:01:59 Sailfish kernel: Bluetooth: Controller acked invalid packet
Jan 11 13:01:59 Sailfish kernel: Bluetooth: Controller acked invalid packet
Jan 11 13:01:59 Sailfish kernel: Bluetooth: Controller acked invalid packet


Trying to switch it on results in:

Jan 11 13:02:02 Sailfish bluetooth_rfkill_event[394]: main(bluetooth_rfkill_event.c:1136): BT power driver blocked
Jan 11 13:02:02 Sailfish bluetooth_rfkill_event[394]: free_hci(bluetooth_rfkill_event.c:785): No brcm_patchram_plus process to be found
Jan 11 13:02:02 Sailfish bluetooth_rfkill_event[394]: main(bluetooth_rfkill_event.c:1138): BT disabled
Jan 11 13:02:02 Sailfish kernel: RTL871X: IsBtDisabled=0, IsBtControlLps=0
Jan 11 13:02:02 Sailfish kernel: RTL871X: (+)Tx = 0, Rx = 0
Jan 11 13:02:02 Sailfish kernel: RTL871X: CurIGValue=41, EntryMinUndecoratedSmoothedPWDB = 37
Jan 11 13:02:04 Sailfish kernel: RTL871X: IsBtDisabled=0, IsBtControlLps=0
Jan 11 13:02:04 Sailfish kernel: RTL871X: (+)Tx = 0, Rx = 0
Jan 11 13:02:04 Sailfish kernel: RTL871X: CurIGValue=41, EntryMinUndecoratedSmoothedPWDB = 39
Jan 11 13:02:06 Sailfish kernel: RTL871X: IsBtDisabled=0, IsBtControlLps=0
Jan 11 13:02:06 Sailfish kernel: RTL871X: (+)Tx = 1, Rx = 1
Jan 11 13:02:06 Sailfish kernel: RTL871X: CurIGValue=41, EntryMinUndecoratedSmoothedPWDB = 36
Jan 11 13:02:08 Sailfish kernel: RTL871X: IsBtDisabled=0, IsBtControlLps=0
Jan 11 13:02:08 Sailfish kernel: RTL871X: (+)Tx = 0, Rx = 0
Jan 11 13:02:08 Sailfish kernel: RTL871X: CurIGValue=41, EntryMinUndecoratedSmoothedPWDB = 36
Jan 11 13:02:10 Sailfish kernel: RTL871X: YJ: rtl8723b_fill_default_txdesc(): ARP Data: userate=1, datarate=0x0

These arrors com multiple times.
 

The Following User Says Thank You to tmichel For This Useful Post:
Posts: 13 | Thanked: 39 times | Joined on Dec 2016
#96
Originally Posted by TheKit View Post
On a side note, I see there is a newer and (probably) easier to get Onda V80 SE with the same SoC, but hard to say how different is it.
Thanks for the hint, can you elaborate what else, besides the SoC is important with respect to using the current port / portability in general? I (naively) assumed that the drivers can be taken from Android and used via libhybris.
 

The Following User Says Thank You to bomo For This Useful Post:
Posts: 82 | Thanked: 406 times | Joined on May 2016
#97
Originally Posted by bomo View Post
Thanks for the hint, can you elaborate what else, besides the SoC is important with respect to using the current port / portability in general? I (naively) assumed that the drivers can be taken from Android and used via libhybris.
There are two kinds of drivers: kernel drivers and libs in userspace. The second kind can be used via libhybris. Kernel drivers are supposed to be open-source due to license of Linux kernel, but Chinese manufacturers don't care about GPL.

Android kernel binary can't be used directly for SailfishOS (kernel needs recompiling with different options). So without having kernel tree source code the only option is using kernel source tree from different device and fixing the differences (different components or different pinouts, for example) by reverse-engineering stock kernel.
 

The Following 4 Users Say Thank You to TheKit For This Useful Post:
Posts: 64 | Thanked: 64 times | Joined on Apr 2012 @ Austria
#98
yes, i asked for an installer to nand instead of sdcard. i made a new partition with the remaining space and mounted it under a folder i created in /home/nemo/ (i always mix up /home/user/MyDocs/ and /home/nemo/ i hope that is right)
Originally Posted by tmichel View Post
Hi,

I just received a V820W, sadly the Version 5.

However, Sailfish OS intallation went smoothly, needed two tries for the update to 2.0.5.4 but now it's running. Audio does not work, neither does bluetooth (cannot be enabled).

Had some trouble to get into WiFi at the beginning as I could not see the scanning results - it seemed I could not scroll down in the Result window, possibly a graphics issue. Managed to get it working using connmanctl.

Two things I noticed on the installer: First, it does install to NAND, not to the SDCard (probably my mistake, I did not understood that in the description). So bye-bye to Windows and Android :-)

Second, the installer creates a 10 GB partition though the device has 32 GB which renders the 20 GB useless. Maybe I try to reinstall Windows 10 on it or make it a seperate /home partition.

Thanks to all the porters!
 

The Following User Says Thank You to smatkovi For This Useful Post:
Posts: 64 | Thanked: 64 times | Joined on Apr 2012 @ Austria
#99
did anyone of you manage to get play services working?
 

The Following User Says Thank You to smatkovi For This Useful Post:
Posts: 7 | Thanked: 13 times | Joined on Jan 2017
#100
Originally Posted by smatkovi View Post
did anyone of you manage to get play services working?
Hi,

it works just fine. I followed the instructions on TJC for the Jolla tablet if I remember correctly.
 

The Following 2 Users Say Thank You to tmichel For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 13:02.