Notices


Reply
Thread Tools
Posts: 146 | Thanked: 39 times | Joined on May 2010
#211
The second uploaded version of hydra 7.2 is not working ( like in the PM StefanL) i had the same error like spuddy101. I install back the first version uploaded by stefanl on post 201.
 
Posts: 855 | Thanked: 1,674 times | Joined on Apr 2010 @ Aleppo ,Syria
#212
hmm it seems it's grabbed by debian repository (binary or source)

if you have libss1 installed then do :

ln -s /usr/lib/libss.so.1.0.0 /usr/lib/libssl1.so.1.0.0

not sure as i have hydra installed on easy-debian
 
StefanL's Avatar
Posts: 298 | Thanked: 341 times | Joined on Aug 2010 @ This world :)
#213
Originally Posted by karam View Post
hmm it seems it's grabbed by debian repository (binary or source)

if you have libss1 installed then do :

ln -s /usr/lib/libss.so.1.0.0 /usr/lib/libssl1.so.1.0.0

not sure as i have hydra installed on easy-debian
My N900 is my development environment so I do not have a fresh one to test the programs on; obviously on my set-up all the dependencies are satisfied since it compiled.

Try the following to fix missing dependencies
Code:
sudo apt-get install libssh libmysqlclient libpq libssl pkg-config libgtk2.0
Just try each of the packages after the install separately until you find the one that fixes the dependency. Report back here to let us know what works.
__________________
My phone evolution: Nokia 7610 (RIP), N82 (RIP), BB9000 (RIP), N900, BB9760 (RIP), N8, BB9900, N9 64GB
Working : Python Gorillas (Maemo5) Faircrack0.50 Update (Maemo5)
Not so much : WPScrack (Maemo5)
 

The Following User Says Thank You to StefanL For This Useful Post:
Posts: 33 | Thanked: 4 times | Joined on Dec 2010
#214
hi StefanL,i download your attached on #207.
but it must install some lib.
when i execute below command,hydra can work.
1,apt-get install libidn11 libpq5 libssh2-1 libcrypt
2,ln -s /usr/lib/libss.so.1.0.0 /usr/lib/libssl.so.1.0.0
3,ln -s /usr/lib/libssh2.so.1 /usr/lib/libssh.so.4
4,ln -s /usr/lib/libcrypto.so.0.9.8 /usr/lib/libcrypto.so.1.0.0

i used valid login/password pairs test it on My N900's sshd and telnet server.but hydra can't suggest valid !

Nokia-N900:~# hydra -l root -p qazwsx 127.0.0.1 ssh
Hydra v7.2 (c)2012 by van Hauser/THC & David Maciejak - for legal purposes only

Hydra (http://www.thc.org/thc-hydra) starting at 2012-02-28 12:47:21
[DATA] 1 task, 1 server, 1 login try (l:1/p:1), ~1 try per task
[DATA] attacking service ssh on port 22
hydra: symbol lookup error: hydra: undefined symbol: ssh_new
[STATUS] attack finished for 127.0.0.1 (waiting for children to finish)
1 of 1 target successfuly completed, 0 valid passwords found
Hydra (http://www.thc.org/thc-hydra) finished at 2012-02-28 12:47:21

Nokia-N900:~# hydra -l root -p qazwsx 127.0.0.1 telnet -vv
Hydra v7.2 (c)2012 by van Hauser/THC & David Maciejak - for legal purposes only

Hydra (http://www.thc.org/thc-hydra) starting at 2012-02-28 12:49:11
[WARNING] telnet is by its nature unreliable to analyze reliable, if possible better choose FTP or SSH if available
[VERBOSE] More tasks defined than login/pass pairs exist. Tasks reduced to 1.
[DATA] 1 task, 1 server, 1 login try (l:1/p:1), ~1 try per task
[DATA] attacking service telnet on port 23
[VERBOSE] Resolving addresses ... done
[STATUS] attack finished for 127.0.0.1 (waiting for children to finish)
1 of 1 target successfuly completed, 0 valid passwords found
Hydra (http://www.thc.org/thc-hydra) finished at 2012-02-28 12:49:11
 
Posts: 146 | Thanked: 39 times | Joined on May 2010
#215
sudo apt-get install libidn11

sudo apt-get install libssh libmysqlclient libpq libssl pkg-config libgtk2.0

ln -s /usr/lib/libss.so.1.0.0 /usr/lib/libssl1.so.1.0.0

but still not working last hydra from post 207


i try
1,apt-get install libidn11 libpq5 libssh2-1 libcrypt
2,ln -s /usr/lib/libss.so.1.0.0 /usr/lib/libssl.so.1.0.0
3,ln -s /usr/lib/libssh2.so.1 /usr/lib/libssh.so.4
4,ln -s /usr/lib/libcrypto.so.0.9.8 /usr/lib/libcrypto.so.1.0.0

still no luck
Attached Images
  

Last edited by q6600; 2012-02-28 at 08:52.
 
Posts: 93 | Thanked: 18 times | Joined on Oct 2011 @ Coimbatore, India
#216
@karam
Great efforts are put by you!
I am new to pentesting. Can you help me how to use these pentesting tools? Any tutorials for usage? Any videos? Pl help.
 
Posts: 93 | Thanked: 18 times | Joined on Oct 2011 @ Coimbatore, India
#217
I am a windows user...

Last edited by bharathkumarst; 2012-02-28 at 17:37.
 
StefanL's Avatar
Posts: 298 | Thanked: 341 times | Joined on Aug 2010 @ This world :)
#218
Originally Posted by q6600 View Post
sudo apt-get install libidn11

sudo apt-get install libssh libmysqlclient libpq libssl pkg-config libgtk2.0

ln -s /usr/lib/libss.so.1.0.0 /usr/lib/libssl1.so.1.0.0

but still not working last hydra from post 207


i try
1,apt-get install libidn11 libpq5 libssh2-1 libcrypt
2,ln -s /usr/lib/libss.so.1.0.0 /usr/lib/libssl.so.1.0.0
3,ln -s /usr/lib/libssh2.so.1 /usr/lib/libssh.so.4
4,ln -s /usr/lib/libcrypto.so.0.9.8 /usr/lib/libcrypto.so.1.0.0

still no luck
Ok, I need to change my development environment. I had compiled the openssl 1.0.0.e library from the website and was testing it on my device, but official maemo one is 0.9.8. Sorry about the f@ck up. Will post a new compiled version soon. For those who are interested run the following in x-term
Code:
ldd hydra
and you will see which libraries are compiled into it. libssl and libcrypto are there twice. Will post more specifics on the required dependencies with the next version as well.
__________________
My phone evolution: Nokia 7610 (RIP), N82 (RIP), BB9000 (RIP), N900, BB9760 (RIP), N8, BB9900, N9 64GB
Working : Python Gorillas (Maemo5) Faircrack0.50 Update (Maemo5)
Not so much : WPScrack (Maemo5)

Last edited by StefanL; 2012-02-28 at 22:21.
 

The Following 2 Users Say Thank You to StefanL For This Useful Post:
Posts: 146 | Thanked: 39 times | Joined on May 2010
#219
Any help for you guys
Attached Images
 
 
StefanL's Avatar
Posts: 298 | Thanked: 341 times | Joined on Aug 2010 @ This world :)
#220
Originally Posted by q6600 View Post
Any help for you guys
Looks like that is not my latest compiled version, all you have in there is the openssl libraries (libcrypto and libssl). All the other libraries should already be on the system (check /usr/lib). To get the openssl libraries try this
Code:
sudo apt-get install openssl
.
__________________
My phone evolution: Nokia 7610 (RIP), N82 (RIP), BB9000 (RIP), N900, BB9760 (RIP), N8, BB9900, N9 64GB
Working : Python Gorillas (Maemo5) Faircrack0.50 Update (Maemo5)
Not so much : WPScrack (Maemo5)
 
Reply

Tags
dangerous, hacker edition, i iz hax0r, karam2hacker, noobs-cant-read

Thread Tools

 
Forum Jump


All times are GMT. The time now is 18:32.