Thread Tools
Posts: 7 | Thanked: 2 times | Joined on Aug 2010 @ Glasgow, Scotland
Thanks JonWW, looks like something else is wrong!

On opening the back cover I see:

21:14:15.893: bme property battery.voltage.current = 3877 (0xf25)
21:14:15.949: bme property battery.reporting.current = 821 (0x335)
21:14:45.582: platform_kb_lock property button.state.value = false
21:14:45.697: platform_kb_lock condition ButtonPressed = cover
21:14:45.699: platform_kb_lock property button.state.value = false
21:14:45.795: platform_kb_lock condition ButtonPressed = cover
No corresponding "true" values when I replace the cover, though. Should that be the case?

The card still doesn't appear in the file manager after using gconftool-2.

@JonWW: Thanks, but getting similar output:

mkfs.vfat 2.11 (12 Mar 2005)
/dev/mmcblk1p1: No such file or directory
I suspect my SD card is faulty after all...

Last edited by owenglasgow; 2011-04-14 at 20:19.

The Following User Says Thank You to owenglasgow For This Useful Post:
JonWW's Avatar
Posts: 623 | Thanked: 289 times | Joined on Jan 2010 @ UK
lshal -m outputs
Open backcover with MMC
platform_mmci_omap_hs_0_mmc_host property button.state.value = false
platform_mmci_omap_hs_0_mmc_host condition ButtonPressed = cover
platform_mmci_omap_hs_0_mmc_host_mmc_card_rca54613 removed
volume_uuid_B019_9D68 removed
platform_mmci_omap_hs_0_mmc_host_mmc_card_rca54613_storage_mmc_sd_mmc removed
Close backcover with MMC
platform_mmci_omap_hs_0_mmc_host property button.state.value = true
platform_mmci_omap_hs_0_mmc_host condition ButtonPressed = cover
platform_mmci_omap_hs_0_mmc_host_mmc_card_rca54613 added
platform_mmci_omap_hs_0_mmc_host_mmc_card_rca54613_storage_mmc_sd_mmc added
volume_uuid_B019_9D68 added
volume_uuid_B019_9D68 property volume.mount_point = '/media/mmc1'
volume_uuid_B019_9D68 property volume.is_mounted = true
Open backcover without MMC
platform_mmci_omap_hs_0_mmc_host property button.state.value = false
platform_mmci_omap_hs_0_mmc_host condition ButtonPressed = cover
Close backcover without MMC
platform_mmci_omap_hs_0_mmc_host property button.state.value = true
platform_mmci_omap_hs_0_mmc_host condition ButtonPressed = cover
From your output I would say you have lost the tiny magnet from the back cover as hal isn't reporting the removal/replacement of the back cover.

Having just re-checked the gconftool commands, they work fine with the backcover on but don't work when the cover is off. I found these long ago and thought they worked, maybe they did in PR1.2
Sorry about that.

If I were you I'd get on ebay and buy a new backcover.

The Following 2 Users Say Thank You to JonWW For This Useful Post:
Posts: 1 | Thanked: 0 times | Joined on Mar 2012
Originally Posted by JonWW View Post
Check that the tiny magnet hasn't come off the inside of the back cover, this is what normaly happens.

If you don't know where to look, does the camera work? or in XTerm type
lshal -m
and open the back cover without pressing to many buttons, you should see some mmc stuff appear on the screen.


Try entering these commands in XTerm, you might have to be root

Make the card appear in the file manager:
gconftool-2 -s -t bool /system/osso/af/internal-mmc-device-present true
gconftool-2 -s -t bool /system/osso/af/mmc-cover-open false
gconftool-2 -s -t bool /system/osso/af/internal-mmc-cover-open false
gconftool-2 -s -t bool /system/osso/af/mmc-device-present true
and disappear:

i wrote this code on xterminal.. nd i can nw easily view my memory card in the file manager.. but i want to know why my n900 was nt able to detect the card earlier?? why wrting this code was necessary?
gconftool-2 -s -t bool /system/osso/af/internal-mmc-device-present false
gconftool-2 -s -t bool /system/osso/af/mmc-cover-open true
gconftool-2 -s -t bool /system/osso/af/internal-mmc-cover-open true
gconftool-2 -s -t bool /system/osso/af/mmc-device-present false
If that doesn't work something else is wrong!
when i wrote the appear code in the xterminal i was able to c the memory card in the filemanager.. but i want to know y my n900 didnt detect the mmc earlier...?

Last edited by david007; 2012-03-22 at 11:32. Reason: editing
Posts: 12 | Thanked: 1 time | Joined on Jan 2010
It seems that the kernel code checking the back cover and disabling the mmc is here:

Does someone more knowledgable than me can give a hint if there is a kernel boot parameter or some other way to fake the kernel into assuming the cover is closed?

On one of my n900s the sensor is broken (magnet still there, gconf hack does not work).
pichlo's Avatar
Posts: 5,662 | Thanked: 17,671 times | Joined on Sep 2012 @ UK
I fixed mine with a tiny (about 2x3 mm) cut from a flexible sheet magnet like one of those used on fridge magnets. You may need to experiment a little with the position and orientation (polarity). Turning the magnet one way triggered a flood of messages from lshal while turning it the other way did not.

The Following User Says Thank You to pichlo For This Useful Post:
Posts: 70 | Thanked: 17 times | Joined on Apr 2012 @ Mumai,India
I tried the gconf script on my N900 and it still isnt detecting the card.Actually ,even the magnet is in its place and yet I count mount my sd card or use it.
Also,another weird problem is that my phone WON'T BOOT with the sdcard in it,and if I do insert the sdcard after booting,then it wont get detected.I have tried this with multiple memory cards....
Posts: 77 | Thanked: 53 times | Joined on Dec 2007 @ Chester, CA
Man this issue was driving me crazy, sd card worked find through several card readers on my pc, checkdisk turned up no errors, re-partitioned and formatted, etc.

Finally i found this thread, and realized i had the old cover from my backup n900 on my main unit, and the magnet was missing. Swapped out back covers, and problem solved.

Posts: 4 | Thanked: 20 times | Joined on May 2013 @ the Netherlands
I have exactly the same problems. A few months ago I accidentally dropped my N900 in a hurry and since that moment the Camera app opens up on random moments. At first I wasn't aware that it had started just after I dropped it, but the next weekend when I was trying to boot Nemo on my N900, after hours of trying and thinking about why it wouldn't boot (I kept getting kernel panics due to a missing rootfs, which is on the SD card) I finally realized that the drop must have caused the problems. I checked my back cover and phone and all magnets are perfectly in place, I tried various strong magnets but nothing helped: it kept reporting that the back cover was open while it was mounted. I also think my 'magnet sensor' is broken.

I just tried the gconf commands, but it didn't have any effect, the SD card didn't show up in the file manager. I also ran the some commands another time as root, but that didn't work either.
Posts: 187 | Thanked: 213 times | Joined on Apr 2013 @ Poland
superpelican, did you solve your issue? I just posted here:

and I noticed that the thread is in "general talk" forum, so I duplicate, sorry for that:

2 days ago my n900 lived through giant impact (over 2 meters on concrete). I immidietley put it back together turned on and everything seemed to be working just fine. Today I tried to refresh swap (Through Flopswap) and noticed that there are no swaps available except the 768mb built-in partition. It came to me and I tired to put camera cover on open position and nothing happed. I thought, yeah, the magnet fell of and as it turns out - it did.

I replaced whole back cover (Got few spare ones). So now I got the camera working properly but still no card detection. Checked the microsd itself - working fine. Tired my n900 with another card from my n800 tablet - no detection.

In /dev/ there is no other partitions excluding nokia's ones.

What could have happend? Did I somehow killed sd card slot?

I took a quick look at my n900 hardware parts and also compared it with fully working motherboard from another n900. Couldn't find any broken parts or so, everything is all right and my eyes are good for sure

I would like to know that is there any chance that this drop of my phone could appear as software mix-up, instead of real hardware failure? I'm going to re-flash my device, just need to know that it iis worth it.

Last edited by Ridd92; 2016-08-05 at 15:11.
Posts: 278 | Thanked: 389 times | Joined on Jan 2010 @ NYC
Dropped my phone recently and didn't notice at first, but the sd card wasn't mounting. I check it on another computer no problems, but nothing worked.

Until I was reminded by this thread that the cover has a magnet in it that could effect the sd card. Tried one of my backup covers and thank goodness it worked. Check the dropped one and sure enough it was missing the magnet.

So my solution was to take one of those magnet sticker type of materials, which have one side with adhesive and stuck a small piece to the spot where it was missing ... but on the inside!

This is my last fully working n900 at the moment so I was very nervous. But thankfully back to 100%.

As always love this forum.


The Following 3 Users Say Thank You to xman For This Useful Post:

backcover, missing magnet

Thread Tools

Forum Jump

All times are GMT. The time now is 01:13.