Notices


Reply
Thread Tools
Posts: 243 | Thanked: 225 times | Joined on May 2010 @ Ljubljana, Slovenia
#381
Here's my output from terminal:

Code:
/home/user/MyDocs/Downloads # dpkg -i advancedcaching_0.9.1.3_all.deb
Aegis rejecting advancedcaching_0.9.1.3_all.deb: opt/advancedcaching/launch not installed by the package
aegis-deb-release: Missing ':' in '<br clear="all">
</big>
</body>
</html>
'
aegis-deb-release: Missing ':' in '<br clear="all">
</big>
</body>
</html>
'
aegis aborting dpkg -- all listed package files rejected
Compilation failed in require.
/home/user/MyDocs/Downloads #

Edit: I'm using 0.9.1.1 and parser 35 (2013-08-27) -- have no problems with caches.

Last edited by sponka; 2014-06-13 at 14:55.
 

The Following 2 Users Say Thank You to sponka For This Useful Post:
Posts: 830 | Thanked: 3,356 times | Joined on Mar 2009
#382
Unfortunately I can't do anything more for Meego version. I haven't found easy tutorial how to use aegis. If anybody knows what to do, I'm willing to fix building scripts.

This is complete tutorial how debs for meego have done. I encourage anybody to test it by yourself and report what is missing.

0) ( Debian-based/derived ) system with: git, dpkg-dev, perl

1) git clone https://github.com/webhamster/advancedcaching.git
2) cd advancedcaching/build/
3) ./make-meego-debuild.sh

-> got ../dist/meego-debuild/advancedcaching-0.9.1.3/advancedcaching_0.9.1.3_all.deb


Here is online readable make-meego-debuild.sh: https://github.com/webhamster/advanc...ego-debuild.sh

And aegis-builder, which it is using: https://github.com/webhamster/advanc.../aegis-builder
 

The Following 4 Users Say Thank You to AapoRantalainen For This Useful Post:
Posts: 54 | Thanked: 54 times | Joined on Dec 2013 @ Austria
#383
Is there still somebody using this programm on the N9????
I still have the problem that the cache download/update stops after a few caches (mostly around 10) and the already downloaded once are then discard and don't appear in the map. Sadly the update function is not working and i'm still on version 0.9.1.1.

Can someone provide a never version .deb or help me with making a newer version .deb from the github source files??
The tutorial from AapoRantalainen is not working for me, as i always get the feedback that i have no permissions.

Last edited by Shadowdog; 2015-03-14 at 11:03.
 
Posts: 830 | Thanked: 3,356 times | Joined on Mar 2009
#384
Originally Posted by Shadowdog View Post
The tutorial from AapoRantalainen is not working for me, as i always get the feedback that i have no permissions.
Copy-paste your error message here. I just tested and it works for me.

Is your current directory mounted with noexec?
 

The Following User Says Thank You to AapoRantalainen For This Useful Post:
Posts: 54 | Thanked: 54 times | Joined on Dec 2013 @ Austria
#385
Attached is a screenshot of my terminal window.
I hope the picture has a resolution you can work with.
Thanks that you take your time.
Attached Images
 
 
Posts: 830 | Thanked: 3,356 times | Joined on Mar 2009
#386
Ok, here is deb for meego:
http://www.cs.helsinki.fi/u/rantalai....9.1.3_all.deb


Originally Posted by Shadowdog View Post
Attached is a screenshot of my terminal window..
Yeah, that was one way to show it.
I didn't expect you are doing it on N9, because any Linux would work. I suggested you install ssh-server on N9 and connect using computer and ssh-client, so you can use copy-paste.
 

The Following User Says Thank You to AapoRantalainen For This Useful Post:
Posts: 54 | Thanked: 54 times | Joined on Dec 2013 @ Austria
#387
Thanks for the .deb, sadly it's not working.
Now i get this error message:

/home/user/MyDocs/Downloads # dpkg -i advancedc
aching_0.9.1.3_all.deb
Aegis rejecting advancedcaching_0.9.1.3_all.deb: opt/advancedcaching/launch not installed by the package
aegis aborting dpkg -- all listed package files rejected
Compilation failed in require.
 
Posts: 1,177 | Thanked: 3,942 times | Joined on Oct 2014
#388
# AEGIS_FIXED_ORIGIN=com.nokia.maemo dpkg -i .......
__________________
You can still support my work by donation - click here

ETH: 0xFcD031609DB739C62730589361940C68ceEbC913

Last edited by nieldk; 2015-03-28 at 05:43.
 

The Following User Says Thank You to nieldk For This Useful Post:
Posts: 54 | Thanked: 54 times | Joined on Dec 2013 @ Austria
#389
Originally Posted by nieldk View Post
# AEGIS_FIXED_ORIGIN=com.nokia.maemo dpkg -i .......
Thanks for the reply, but sadly it doesn't make a change. I get the same error message as before. I have installed Coderus's aegis hack, can this be the source of the problem?
 
Posts: 1,177 | Thanked: 3,942 times | Joined on Oct 2014
#390
Ok, the /opt/advancedcaching/launch file is not installed.

You could try

dpkg -x (debfile name) /

Then, create the /opt/advancedcaching/launch containing these lines

#!/bin/sh
cd /opt/advancedcaching/
python core.py --qml
__________________
You can still support my work by donation - click here

ETH: 0xFcD031609DB739C62730589361940C68ceEbC913
 

The Following 2 Users Say Thank You to nieldk For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 08:10.