Notices


Reply
Thread Tools
Posts: 12 | Thanked: 38 times | Joined on Nov 2016 @ Bavaria
#2521
HTML Code:
,---
| Sailfish OS 2.2.0.29 (Mouhijoki)
'---
[nemo@Sailfish ~]$ devel-su
Password: 
[root@Sailfish nemo]# ssu re 2.2.0.29
Changing release from 2.1.4.14 to 2.2.0.29
Your device is now in release mode!
[root@Sailfish nemo]# version --dup
Now the workaround from http://talk.maemo.org/showpost.php?p...postcount=2491 works!

First time my phone upgradet not fully?

Last edited by chris_bavaria; 2018-06-02 at 09:30. Reason: Reinstalled Upgrade
 

The Following 2 Users Say Thank You to chris_bavaria For This Useful Post:
Posts: 469 | Thanked: 893 times | Joined on Aug 2014
#2522
Originally Posted by seiichiro0185 View Post
Just installed 2.2.0.29 on my Dual SIM F5122, and managed (apparently) to convert to the official Dual SIM SFOS by doing the following (YMMV - PROCCEED AT YOUR OWN RISK AND HAVE A BACKUP AVAILABLE!!!):

Code:
# zypper ref
# zypper in droid-config-f5122 droid-config-f5122-bluez5 droid-config-f5122-flashing droid-config-f5122-policy-settings droid-config-f5122-preinit-plugin droid-config-f5122-pulseaudio-settings droid-config-f5122-sailfish droid-system-f5122 droid-hal-version-f5122 pattern:jolla-configuration
# zypper remove droid-config-f5121 droid-config-f5121-bluez5 droid-config-f5121-flashing droid-config-f5121-policy-settings droid-config-f5121-preinit-plugin droid-config-f5121-pulseaudio-settings droid-config-f5121-sailfish droid-hal-version-f5121
# reboot
You need Developer Mode and zypper installed. Each command starting with "zypper " needs to be on one line. The zypper install will ask to resolve a conflict involving droid-system-f5122 and droid-system-f5121, choose to install the f5122 version and remove the f5121 one.
I basically searched all packages with "f5122" in their name and replace the corresponding "f5121 ones.

After the Reboot my 2 SIM-Cards are detected without any manual changing of the configs, and the "About Device"- Dialog in the Setting states product as "Xperia X Dual SIM"

I only did some brief testing, but everything does seem to work fine. CSD tests als show no apparent failures.

And again, this is a "hacky" method I tried on my device and which seems to have worked. It might develop long term problems or not work on your device. Make sure to have backups available and be ready to reflash your device if anything fails!
If you want to see "SIM cards" under Settings upon F5122 would still need to add:
HTML Code:
pkcon install jolla-settings-networking-multisim
and reboot.
 

The Following 7 Users Say Thank You to aspergerguy For This Useful Post:
seiichiro0185's Avatar
Posts: 261 | Thanked: 559 times | Joined on Nov 2007 @ Leipzig/Germany
#2523
Originally Posted by aspergerguy View Post
If you want to see "SIM cards" under Settings upon F5122 would still need to add:
HTML Code:
pkcon install jolla-settings-networking-multisim
and reboot.
You're most certanly right, I had the jolla-settings-networking-multisim installed before the update (I used the config-mod to activate the second SIM before), and the update didn't uninstall it in my case. So if you where to attempt this from a pristine F5121 SFOS you'll also have to add the settings plugin.
__________________
N800 -> N810 -> N900 -> N9 -> Jolla & TOHKBD -> Jolla C -> Xperia X F5122 (SFOS X)

http://www.seiichiro0185.org
 

The Following 5 Users Say Thank You to seiichiro0185 For This Useful Post:
Posts: 82 | Thanked: 273 times | Joined on Jan 2012
#2524
Originally Posted by aspergerguy View Post
If you want to see "SIM cards" under Settings upon F5122 would still need to add:
HTML Code:
pkcon install jolla-settings-networking-multisim
and reboot.
Trying to install that results fatal error in my F5122:
(translated from Finnish) "fatal error: jolla-settings-networking-multisim-0.4.11.10.3.1.jolla.arm7hl needs jolla-settings-networking-multisim = 0.4.11.10.3.1.jolla, but install does not succeed"
 

The Following User Says Thank You to Heik For This Useful Post:
Posts: 469 | Thanked: 893 times | Joined on Aug 2014
#2525
Originally Posted by Heik View Post
Trying to install that results fatal error in my F5122:
(translated from Finnish) "fatal error: jolla-settings-networking-multisim-0.4.11.10.3.1.jolla.arm7hl needs jolla-settings-networking-multisim = 0.4.11.10.3.1.jolla, but install does not succeed"
Could timing of this have anything to do with release of official Sailfish image 2.2.0.29 for F5122 closing a loop-hole previously being exploited?

I can't remember unfortunately whether I had already manually amended default.prop and ril_subscription.conf before applying seiichiro0185 hack:
http://talk.maemo.org/showpost.php?p...postcount=2491 should this make any difference to outcome.
 

The Following 3 Users Say Thank You to aspergerguy For This Useful Post:
Posts: 1,150 | Thanked: 3,818 times | Joined on Oct 2014
#2526
Originally Posted by Heik View Post
Trying to install that results fatal error in my F5122:
(translated from Finnish) "fatal error: jolla-settings-networking-multisim-0.4.11.10.3.1.jolla.arm7hl needs jolla-settings-networking-multisim = 0.4.11.10.3.1.jolla, but install does not succeed"
Do a pkcon refresh first
__________________
You can still support my work by donation - click here

ETH: 0xFcD031609DB739C62730589361940C68ceEbC913
 

The Following 4 Users Say Thank You to nieldk For This Useful Post:
Posts: 82 | Thanked: 273 times | Joined on Jan 2012
#2527
Originally Posted by nieldk View Post
Do a pkcon refresh first
That helped for installation.
But
Code:
pkcon install jolla-settings-networking-multisim
did not bring other sim visible in settings.
Probably still needs default.prop and ril_subscription.conf modifications to work, if not flashed again.

So, I will reflash later.

Edit:
After default.prop and ril_subscription.conf modifications both sims work as before. Reflashing will wait...

Last edited by Heik; 2018-06-09 at 08:50.
 

The Following 3 Users Say Thank You to Heik For This Useful Post:
mikecomputing's Avatar
Posts: 3,399 | Thanked: 4,759 times | Joined on Feb 2010 @ Gothenburg in Sweden
#2528
Upgared my X some days ago.

Also realized that I have run SFOS on my Xperia X for some month now and work flawlessly I do NOT miss the ugly broken Android pacer of garbage OS. However I have to run Android on another device when I doing banking or online payment for two reasons:

* BankID need newer android version than the one used in SFOS.
* Google **** services

I just wonder if Jolla plans to update dalvik engine to later version of Android.... One can only hope... because it would be nice get rid of my other phone ASAP.
__________________
Go librem

telegram @mike7b4
mastodon.social @mike7b4

Last edited by mikecomputing; 2018-06-11 at 18:18.
 

The Following 10 Users Say Thank You to mikecomputing For This Useful Post:
explit's Avatar
Posts: 577 | Thanked: 1,539 times | Joined on Apr 2010 @ Berlin / Germany
#2529
What about microG ? Working for me so far
 

The Following 3 Users Say Thank You to explit For This Useful Post:
eson's Avatar
Posts: 242 | Thanked: 727 times | Joined on Nov 2015 @ Sweden
#2530
Originally Posted by mikecomputing View Post
However I have to run Android on another device when I doing banking or online payment for two reasons:

* BankID need newer android version than the one used in SFOS.
* Google **** services
You could switch bank! I,ve been using Forex Bank with their own ForexID for some year now. Works flawless on my Xperia X with dalvik. No Google **** services needed.
Not to mention the underlying message you send to the Swedish bank cartel...
 

The Following 5 Users Say Thank You to eson For This Useful Post:
Reply

Tags
sailfish os, sony xperia x

Thread Tools

 
Forum Jump


All times are GMT. The time now is 21:30.