Active Topics



Thread Tools
Posts: 571 | Thanked: 980 times | Joined on Dec 2012
It was half year ago
I was able to compile 2.23 and I use it with ubuntu 17.04 on 3.0 kernel.
I only changed MIN_KERNEL_SUPPORTED in debian/sysdeps/
My Thumb repo

The Following 2 Users Say Thank You to elros34 For This Useful Post:
Posts: 819 | Thanked: 2,668 times | Joined on Jan 2011 @ Germany
I just built Netsurf 3.7 for Easy Debian Jessie/armhf and it seems to work fine. So I uploaded an archive of the Debian packages. [1] As always, please feel free to host and share this archive as it will undoubtedly vanish at some point.
$ md5sum netsurf_3.7_ed_sulu.tar
2d789e49980b19fe8369d7511ee12c9a  netsurf_3.7_ed_sulu.tar
I also tried to backport zulucrypt from Buster. but while the build process worked smoothly, actually mounting volumes fails with this error message:
ERROR: Insufficient privilege to mount the device with given options
Unfortunately the code is ambiguous about throwing this message [2] and I did not bother to investigate further. The same packages fail mounting a truecrypt volume with a different error message in their build environment (Jessie chroot on Stretch host on my Cubieboard2), while a parallel amd64 build works fine in a Jessie/amd64 chroot. So I don't know whether to blame the Maemo kernel, the architecture or something entirely different.


The Following 6 Users Say Thank You to sulu For This Useful Post:
Posts: 819 | Thanked: 2,668 times | Joined on Jan 2011 @ Germany
Just some quick tip (and it's probably not even new in this thread - in fact I'm pretty sure it's at least mentioned somewhere in the early 100 pages):

I just installed Marble in ED and stumbled upon the problem of not being able to create waypoints for routing, because that requires a right-click, which doesn't work for KDE applications via ED's default way of tap&hold.

So I installed xdotool and added these five lines to my .config/openbox/lxde-rc.xml:
$ diff lxde-rc.xml.orig  lxde-rc.xml
--- lxde-rc.xml.orig
+++ lxde-rc.xml
@@ -501,6 +501,11 @@
     <context name="Client">
+      <mousebind button="S-mod5-Left" action="Click">
+        <action name="Execute">                                                  
+          <command>xdotool click 3</command>                                             
+        </action>
+      </mousebind>
       <mousebind button="Left" action="Press">
         <action name="Focus"/>
         <action name="Raise"/>
This allows me to perform a right-click by holding down Shift+Mod5 (the blue arrow key) and tapping the screen.

It should work in pretty much any application. At least it does in Marble, Netsurf and Pcmanfm (although in the latter two also tap&hold works).
For reasons I don't really care to dig into, it doesn't work in Lxterm.

The Following 5 Users Say Thank You to sulu For This Useful Post:

beta, debian, easy debian, extras-devel, fremantle, i <3 qole, squeeze

Thread Tools

Forum Jump

All times are GMT. The time now is 10:51.