Active Topics



Thread Tools
Posts: 547 | Thanked: 1,381 times | Joined on Sep 2009 @ Stockholm, Sweden

Help translate fMMS to your own language!

Troubleshooting 101:

How fMMS works
fMMS installs a daemon (program running in the background) which will start whenever an SMS Push message (this SMS is of a special kind which is not handled by default in Fremantle) related to MMS is received by your phone. It will read the SMS message and try to fetch the MMS from your operator.
If successful you will get a notification "MMS Received" which looks like the notification you get when you receive a new e-mail; click on it or start fMMS manually to view your MMS.
If the fetching fails, you will get a notification saying "SMS Push received" which looks like the "New SMS" notification, clicking on this also launches fMMS.

Help improve
Encountered an error?
Please do the following:
Open X-Terminal and enter the following:
cp /tmp/fmms.log /home/user/MyDocs/

Then either use the email client on the N900 to send me 'fmms.log' or connect it as "Mass Storage" and send it from your desktop computer - the file is in the root directory when plugged in as mass storage device.
In the email/reply please include what operator you are on and in what country, as well as your forum username (if registered) and a link to any relevant post you may have posted in this thread. Thanks!
Please send the email to: or post it as an attachment in a reply to this topic.

Delete messages:
Tap-and-hold in the main view -> Click "Delete"
or Open the message -> Application menu -> Delete

Save images from MMS message:
Tap-and-hold on the image -> Open -> "Photos" application opens with the image.
Press the application bar when in the viewer -> Save attachments.

Explanation of connection modes
# Polite: This mode only connects to the MMS APN if no other connection is active.

# Rude: Automatically takes down your current connection, connects to the MMS APN and when it’s done reconnects to the previous connection if possible.

# Havoc: This is what other phone does (albeit much more reliably), it opens a second connection to the MMS APN in parallel with the one currently open. As an added bonus, the MMS APN is hidden from the “Connections” UI in this mode as it does not need to be visible. Due to the nature of the kernel in Maemo 5 there are some ugly hacks involved in this, so if your current connection and the MMS APN configuration share the same ip subnet, things might get ugly. Also, if the application fails in some way when opening/closing a connection in this mode it MIGHT lead to the modem not being able to open a new GPRS connection until a device reboot. You have been warned. Note: I’ve been using this mode for more than 5 months and not yet experienced it.

Note on APN
fMMS adds its own APN as of 0.9.0, if its a fresh install it will try to get the settings for you automatically when you open the configuration, otherwise it will import your old settings from the previous APN.
When using Havoc mode the MMS APN will be removed from the list in the connections UI as Fremantle does not handle 2 APNs gracefully and Havoc mode does not need it listed there.
The other two modes does however still show it, HOPEFULLY it should not get automatically picked up if you got autoconnect to GPRS on.

If the device is auto connecting to the MMS APN instead of the regular internet one automatically; runing:
in the terminal should correct this - please verify by checking in "Internet Connections" as well as edit the access point to make sure all settings got changed.

If your settings seems to be wrong, please check:

Known issues:
Other devices might not receive/display non-english characters properly.
Other devices might not receive/display MMS without any text in.

Advanced configuration
Changing user-agent fMMS sends (Softbank JP users need to do this from what I've heard):
gconftool-2 -st string /apps/fmms/useragent "New UA String"

Manually specify image resize:
gconftool-2 -st int /apps/fmms/img_resize_width 1024

Disable all connection modes:
gconftool-2 -st int /apps/fmms/connmode 10

Reset all settings:
gconftool-2 -R /apps/fmms|grep apn
Should return: apn = xxxx
gconftool-2 --recursive-unset /system/osso/connectivity/IAP/xxxx
gconftool-2 --recursive-unset /apps/fmms

Remove all messages: rm -r /home/user/.fmms/

Nokias position on MMS for the N900:
Vodafone UK support: and
Old thread:

Great walkthrough/FAQ:

Garage site:
Code available at:
Dev blog:
(PS. I'm not above accepting donations for the time I've invested in this project: )

Problem with fMMS? Run in x-terminal: cp /tmp/fmms.log /home/user/MyDocs/
After that you'll see fmms.log in filemanager or when you connect the device to your desktop as a mass storage device.
E-mail the log to me, if you don't have the email address, drop me a PM. Thanks!

fMMS - MMS for your N900
fAPN - GUI for adding a new GPRS APN
If you like this post, don't be shy to thank me -->

Last edited by frals; 2010-11-08 at 20:50.

The Following 234 Users Say Thank You to frals For This Useful Post:
aamirgigani, abufaisal.o, acvetkov, adhrie, alexff, amboydene, Andeh, andraeseus1, apache, archebyte, arjunkumar87, b0unc3, Bacchus, Bahador, bandora, Behemoth, Berserk, biggzy, BigTony, blackopz, Blaizzen, Brank, brera, Brunorange, buxz777, calvin_42, ceevee, CepiPerez, chemist, chill, chrget, Chrome, cibyr, crxtodd16, cubezombie, cyapalmos, CYPHERC, Dactar, Dancairo, daperl, dart45, DaveR53, dee, deegore, demolition, Digicom, DJPecu, donaggio, Dosenblech, Dousan, dqm, Dr.MZ, drewdudemn, DrWilken, dynomot, ecos01, edmac316, eefo,, eikido, elektr00n, Erebo, ericdviking, fcrochik, felbutss, festivalnut, fgs, figaro, FreeThinker, gjoe, gowen, Grant, grog, H3llb0und, Halftux, HammY, hellomezzy, Helmuth, Hmoobwarrior, humvee28, ikerrg, imo, inkirby, ironm8, isma, ivyking, jabba_29, Jago, jakiman, jakoleh, JKO65, Joe Cool, Jopp3, Joseph9560, josh, kai, Kamen, kamil365, kanna, kdrozd, khuong, Kingsley, kojacker, kristoph76, latindark, Laughing Man, Laughingstok, LES.., littlebadger, LondonBenji, lordbyron, lostinmirkwood, luk1803, m.r.a.haak, magnuslu, Maj3stic, majesty, manavs, marcdxn, Marklar, Marshall Banana, mattiviljanen, Mattside, mccarmo, mdb666, mele, Mentalist Traceur, mike_shenoda, Millsy1, mobiledivide, moepda, MohammadAG, MoKopila, mornage, mpi, mr id, mrsellout, mr_bridger, muppis, musculus, mveplus, nad6234, Natan_xy, nicolai, niqbal, nkirk, noobmonkey, noorallah, nymajoak, oakman7004, oldnetdog, onethreealpha, ossipena, OVK, oxpo, Parlapipas, paul900, pavlik, peppe78, peter2p, peterleinchen, piebob, pitmik, purgiaali, Quasar, quipper8, qwerty12, RATBAG, raverpol, rdwrig0ceo, rfa, Robb, rolfok, Ronaldo, S0urcerr0r, s4br0s0, SallyJane, sanki, SavageBrat, sbock, Schturman, sgbirch, Shadx, shazosbourne, skalogre, skanky, Soder, sorensen, SSLMM, stefan-78, stefbeer, stevomanu, stlpaul, stooobs, Strutten, Switch_, symbiosis, tek, thefoxtrot, thej80, tlex26, torshind, traysh, tuminoid, tuxsavvy, UKAndy, Veleno, Venemo, Venty, vietn900, vitaminj, vode, Wanker, Wikiwide, wmarone, woob, wotevah, Xerotole, xomm, xRobby, Yabba, youngcalihottie, zehjotkah, Zentenario, zetagi, ziller, zombiegavins, zoukij, zvogt
skalogre's Avatar
Posts: 327 | Thanked: 249 times | Joined on Sep 2009 @ Λεμεσιανός, ρε!
Great job! Thank you for all the effort.
Venemo's Avatar
Posts: 1,290 | Thanked: 1,753 times | Joined on Aug 2009 @ Budapest, Hungary
Frals, this is very good news!
Posts: 19 | Thanked: 6 times | Joined on Apr 2010 @ UK
Awesome, thanks alot for all your hard work!
zombiegavins's Avatar
Posts: 150 | Thanked: 20 times | Joined on May 2010 @ UK
i really want to use this but for some reason the new access point i set up for it wont connect. any ideas? i used all the settings from the wiki, i'm on vodafone uk by the way

ok so i got it working, it was the automatically created apn that wasn't working so set one up from scratch and it seems to be fine.

one question though, does anyone know how to get rid of the apn that fmms sets up automatically? i dont seem to be able to delete it

Last edited by zombiegavins; 2010-05-04 at 23:32.
Posts: 35 | Thanked: 4 times | Joined on Feb 2010
Originally Posted by zombiegavins View Post
i really want to use this but for some reason the new access point i set up for it wont connect. any ideas? i used all the settings from the wiki, i'm on vodafone uk by the way
join the club not resolved this yet. Have tried two passwords - user and wap but nothing. Is vodafone blocking us? With an early version I could send and recieve but with last update no luck.
Posts: 47 | Thanked: 29 times | Joined on Dec 2009 @ Leicester - United Kingdom
@ frals: Great news mate, keep up the good work!

Originally Posted by zombiegavins View Post
i really want to use this but for some reason the new access point i set up for it wont connect. any ideas? i used all the settings from the wiki, i'm on vodafone uk by the way
What setting have you put for the "Resize image width" option? as for me and a few other people, original does not work, I'd recommend leaving it on Large for now until this is fixed.
zombiegavins's Avatar
Posts: 150 | Thanked: 20 times | Joined on May 2010 @ UK
i have it on small and i seem to have it working after setting up a new apn from scratch
Posts: 35 | Thanked: 4 times | Joined on Feb 2010
ok tried all the sizes but no luck so will try to delete the original apn set up and start again!
zombiegavins's Avatar
Posts: 150 | Thanked: 20 times | Joined on May 2010 @ UK
i cant figure out how to delete the apn that fmms sets up for itself and now my connection list looks cluttered.......

bada rox, bada rulez, fmms, mms, mms config, n900, python

Thread Tools

Forum Jump

All times are GMT. The time now is 19:09.