Notices


Reply
Thread Tools
Posts: 3 | Thanked: 0 times | Joined on Sep 2012
#1
Started facing this problem very recently.

The battery is draining out even if the phone is not in use. The battery status always shows charging or fully charged and the battery green light keeps growing even after removing from charger. The notification light keeps glowing.

I have already flashed the phone once and even updated with latest software.

Even replaced the battery with new one. Still same problem exists, i feel it's more to do with Software rather Hardware.
Please help...
 
Community Council | Posts: 579 | Thanked: 905 times | Joined on Sep 2010 @ Mbabane
#2
install 'powertop' from the sdk repository. this will show you what is draining your battery.

but having flashed the phone, i would suspect your hardware, eg battery, contacts, etc
 
Posts: 3 | Thanked: 0 times | Joined on Sep 2012
#3
Originally Posted by qhubekela View Post
install 'powertop' from the sdk repository. this will show you what is draining your battery.

but having flashed the phone, i would suspect your hardware, eg battery, contacts, etc

I have taken a backup and the phone is working after flash. Only issue is with the battery. I have downloaded the powertop_1.2_armel.deb, what is the next step i need to follow.
 
Community Council | Posts: 579 | Thanked: 905 times | Joined on Sep 2010 @ Mbabane
#4
your initial post suggested that the problem still existed after a reflash, which is why i began to suspect hardware. can you please clarify this point...

as for the powertop...deb, install it using
Code:
sudo dpkg -i <full path to powertop file>
Alternatively, open the file in File Manager, and it will launch HAM to install it.
 

The Following User Says Thank You to sicelo For This Useful Post:
Posts: 3 | Thanked: 0 times | Joined on Sep 2012
#5
Suddenly the battery is working fine.

After flashing the phone even the emmc. Initially 5 days i used external charger to charge the phone and later i charged the phone for about 10 hours using USB connector. From the next moment the battery started behaving as expected. even the discharge is very less.

I really dono how it has stated working fine. just updating my post incase someone faces the same problem.
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 17:49.