Notices


Reply
Thread Tools
Posts: 10 | Thanked: 14 times | Joined on Jan 2018 @ USA
#1
I messed around a little with partitions, but now whenever I try to flash MMC I get this error:

Code:
[cmptutr@computer n9folder]$ sudo flasher -f -F D4A3D2AC_DFL61_HARMATTAN_40.2012.21-3_PR_LEGACY_009-OEM1-958_ARM.bin -F nomaps.bin --flash-only=mmc
flasher 3.12.1 (Oct  5 2011) Harmattan
WARNING: This tool is intended for professional use only. Using it may result
in permanently damaging your device or losing the warranty.

USB device found at bus 001, device address 021.
Device identifier: 357923040985998 (SN: N/A)
Raw data transfer EP found at EP2.
Ping attempt 1 (250 ms)
Server application: 1.7.2
Found product RM-696 rev. 1507
Server implements softupd protocol version 1.8
Image SW version DFL61_HARMATTAN_40.2012.21-3_PR_009
Image cmt-2nd skipped
Image cmt-algo skipped
Image cmt-mcusw skipped
Image xloader skipped
Image secondary skipped
Image kernel skipped
Image moslo skipped
Image rootfs skipped
Image tar skipped
Image config skipped

Battery level 74 %, continuing.

    image        [state    progress         transfer     flash speed]
---------------------------------------------------------------------
[x] cert-sw      [finished   100 %       1 /       1 kB      NA     ]
[_] mmc          [init        25 %   32768 /  261587 kB      NA     ]
It gets stuck at 25%. The EMMC image used to work before I messed up the partitions (when installing nemo). How do I fix it?
 

The Following 2 Users Say Thank You to cmptutr For This Useful Post:
Community Council | Posts: 4,438 | Thanked: 11,076 times | Joined on May 2012 @ Southerrn Finland
#2
Originally Posted by cmptutr View Post
How do I fix it?
By cold-flashing?
 

The Following 2 Users Say Thank You to juiceme For This Useful Post:
Posts: 10 | Thanked: 14 times | Joined on Jan 2018 @ USA
#3
Can I have a link for how to cold flash N9? All searches show only cold flashing N900..
 

The Following 2 Users Say Thank You to cmptutr For This Useful Post:
Posts: 10 | Thanked: 14 times | Joined on Jan 2018 @ USA
#4
Nevermind my previous post, found out how. But, I get an error:

Code:
[cmptutr@computer n9folder]$ sudo flasher -c -f -F D4A3D2AC_DFL61_HARMATTAN_40.2012.21-3_PR_LEGACY_009-OEM1-958_ARM.bin -R
[sudo] password for cmptutr: 
flasher 3.12.1 (Oct  5 2011) Harmattan
WARNING: This tool is intended for professional use only. Using it may result
in permanently damaging your device or losing the warranty.

Using 1st image to detect HW
Suitable USB interface (bootrom) not found, waiting...
USB device found at bus 002, device address 009.
Device identifier: (null) (SN: N/A)
Waiting for ASIC id...
Got 69 bytes.
ASIC ID:
05 01 05 01 36 30 07 07  13 02 01 00 12 15 01 6c 
15 fd 17 51 bc 3f 6f 61  7b 85 ea 01 16 06 47 67 
c8 6a ab 14 15 01 12 dd  2f 66 d4 55 fe 19 2c 62 
b9 b8 e2 65 0a fc 1d 9f  3f 90 15 09 01 13 bf 3e 
ef 15 52 e7 03 
HW variant: HS
Found matching 1st (916)
Sending 1st image (26496 bytes)... done.
Sending HWID query... Received 11 bytes from 1st
usb_bulk_read: Input/output error
Got HWID: RM-696:1507
USB device found at bus 002, device address 009.
Device identifier: (null) (SN: N/A)
Waiting for ASIC id...
usb_bulk_read: Input/output error
ERROR: Cold flashing failed.
 

The Following 2 Users Say Thank You to cmptutr For This Useful Post:
Posts: 485 | Thanked: 937 times | Joined on Aug 2014
#5
How about?
Code:
flasher -F main.bin -F emmc.bin --erase-user-data=secure --erase-mmc=secure --no-preserve -f -R

Last edited by aspergerguy; 2018-01-28 at 19:38. Reason: Correction
 

The Following 5 Users Say Thank You to aspergerguy For This Useful Post:
peterleinchen's Avatar
Posts: 3,389 | Thanked: 6,448 times | Joined on Aug 2010 @ Ruhrgebiet, Germany
#6
Originally Posted by aspergerguy View Post
How about?
Code:
flasher -F mail.bin -F emmc.bin --erase-user-data=secure --erase-mmc=secure --no-preserve -f -R
erase should not be important
but the no-preserve is (after partition layout changes)
__________________
SIM-Switcher, automated SIM switching with a Double (Dual) SIM adapter
--
Thank you all for voting me into the Community Council 2014-2016!

Please consider your membership / supporting Maemo e.V. and help to spread this by following/copying this link to your TMO signature:
[MC eV] Maemo Community eV membership application, http://talk.maemo.org/showthread.php?t=94257

editsignature, http://talk.maemo.org/profile.php?do=editsignature
 

The Following 3 Users Say Thank You to peterleinchen For This Useful Post:
Posts: 10 | Thanked: 14 times | Joined on Jan 2018 @ USA
#7
I tried no preserve but it did not fix partition problems. When I boot up with the ubiboot kernel (so i can export partitions over USB) it shows three partitions, but when I boot to Harmattan and run /sbin/sfdisk it shows four partitions.
 

The Following 2 Users Say Thank You to cmptutr For This Useful Post:
peterleinchen's Avatar
Posts: 3,389 | Thanked: 6,448 times | Joined on Aug 2010 @ Ruhrgebiet, Germany
#8
Erm, would you mind posting your commands and results?

I have the feeling you try to reach flashing eMMC without providing the second "-F emmc.bin"...
__________________
SIM-Switcher, automated SIM switching with a Double (Dual) SIM adapter
--
Thank you all for voting me into the Community Council 2014-2016!

Please consider your membership / supporting Maemo e.V. and help to spread this by following/copying this link to your TMO signature:
[MC eV] Maemo Community eV membership application, http://talk.maemo.org/showthread.php?t=94257

editsignature, http://talk.maemo.org/profile.php?do=editsignature
 

The Following 2 Users Say Thank You to peterleinchen For This Useful Post:
Posts: 10 | Thanked: 14 times | Joined on Jan 2018 @ USA
#9
Ok, new developments. I'm stuck in a bootloop and when I even try flashing normally, it fails:

Code:
[cmptutr@computer n9folder]$ sudo flasher -f -F D4A3D2AC_DFL61_HARMATTAN_40.2012.21-3_PR_LEGACY_009-OEM1-958_ARM.bin
flasher 3.12.1 (Oct  5 2011) Harmattan
WARNING: This tool is intended for professional use only. Using it may result
in permanently damaging your device or losing the warranty.

USB device found at bus 002, device address 006.
Device identifier: 357923040985998 (SN: N/A)
Raw data transfer EP found at EP2.
Ping attempt 1 (250 ms)
Server application: 1.7.2
Found product RM-696 rev. 1507
Server implements softupd protocol version 1.8
Image SW version DFL61_HARMATTAN_40.2012.21-3_PR_009
Image moslo not present
Image mmc not present
Image tar skipped
Image config skipped

Battery level 73 %, continuing.

    image        [state    progress         transfer     flash speed]
---------------------------------------------------------------------
[x] cert-sw      [finished   100 %       1 /       1 kB      NA     ]
[x] cmt-2nd      [finished   100 %      95 /      95 kB      NA     ]
[x] cmt-algo     [finished   100 %     789 /     789 kB      NA     ]
[_] cmt-mcusw    [finishing   25 %    6050 /    6050 kB    3768 kB/s]
[x] xloader      [finished   100 %      23 /      23 kB      NA     ]
[x] secondary    [finished   100 %      94 /      94 kB      NA     ]
[x] kernel       [finished   100 %    2714 /    2714 kB    1935 kB/s]
[_] rootfs       [finishing  100 %   32768 / 1170206 kB      NA     ]
ERROR: SU_GET_UPDATE_STATUS_REQ terminated with error code 1: Unknown error

    image        [state    progress         transfer     flash speed]
---------------------------------------------------------------------
[x] cert-sw      [finished   100 %       1 /       1 kB      NA     ]
[x] cmt-2nd      [finished   100 %      95 /      95 kB      NA     ]
[x] cmt-algo     [finished   100 %     789 /     789 kB      NA     ]
[x] cmt-mcusw    [finished   100 %    6050 /    6050 kB    3768 kB/s]
[x] xloader      [finished   100 %      23 /      23 kB      NA     ]
[x] secondary    [finished   100 %      94 /      94 kB      NA     ]
[x] kernel       [finished   100 %    2714 /    2714 kB    1935 kB/s]
[f] rootfs       [finishing    0 %   32768 / 1170206 kB      NA     ]
Fetching error list:
========================================
bb5_rdc_cert_read failed
bb5_rdc_cert_read failed
bb5_rdc_cert_read failed
bb5_rdc_cert_read failed
bb5_rdc_cert_read failed
mmc: sfdisk returned status 1
mmc: Could not exec 'tune2fs -L rootfs /tmp/sudmmcXVNAv3/internal0p2'
mmc: Could not remove mount directory /tmp/sudmmcXVNAv3/mnt: No such file or directory
[Pipe   4] Finishing in error state with status 1
========================================

ERROR: Failed to flash images
Never got that error before... freaked me out. Also, i know that this image was working fine in the morning... maybe after cold flash errors something weird happened?
 

The Following 2 Users Say Thank You to cmptutr For This Useful Post:
peterleinchen's Avatar
Posts: 3,389 | Thanked: 6,448 times | Joined on Aug 2010 @ Ruhrgebiet, Germany
#10
Repeating:
where are the --no-preserve AND the -F emmc.bin parameters

right now you only try to flash firmware (-F main.bin)
without flashing eMMC you will never get partitioning clean again

--edit
oh and that error I have seen too often (very bad)
__________________
SIM-Switcher, automated SIM switching with a Double (Dual) SIM adapter
--
Thank you all for voting me into the Community Council 2014-2016!

Please consider your membership / supporting Maemo e.V. and help to spread this by following/copying this link to your TMO signature:
[MC eV] Maemo Community eV membership application, http://talk.maemo.org/showthread.php?t=94257

editsignature, http://talk.maemo.org/profile.php?do=editsignature
 

The Following 3 Users Say Thank You to peterleinchen For This Useful Post:
Reply

Tags
harmattan, maemo 6

Thread Tools

 
Forum Jump


All times are GMT. The time now is 13:16.