Notices


Reply
Thread Tools
Moderator | Posts: 6,215 | Thanked: 6,398 times | Joined on Nov 2011
#11
I got same errors as Kozzi for Fruit Ninja & Angry Birds Space...

Putting this out there so that its useful for someone else who attempts these 2 apps...


Edit: Added this to the compatibility page...I urge others to do the same too

Last edited by thedead1440; 2012-10-21 at 13:28.
 

The Following 3 Users Say Thank You to thedead1440 For This Useful Post:
Aranel's Avatar
Posts: 301 | Thanked: 227 times | Joined on Nov 2009 @ Turkey
#12
Tested JetPack Joyride (1.3.5), Bejeweled 2 (2.0.11), Zombie Cafe and Cordy Sky (v11943). First three of them encountered that global.jni_library error, last one failed with shlib error.

Here's Game Compatibility wiki-page: http://wiki.maemo.org/Apkenv/Game_Compatibility
__________________
Maemo/MeeGo/Tizen Turkey - http://meegoturkiye.org & http://tizenturkiye.com
N900: Turkish Localization | MT Theme | VodaSMS
N9: MeeSaver
Maintaining: Audelicious | xmp

Last edited by Aranel; 2012-10-21 at 13:06.
 

The Following 6 Users Say Thank You to Aranel For This Useful Post:
Posts: 34 | Thanked: 7 times | Joined on Sep 2012
#13
hey, i get the same error, somebody could install something?

Usage: apkenv <file.apk>
~ # apkenv /home/user/MyDocs/Tab.apk
apkenv: apkenv.c:45: main: Assertion `shlib !=((void *)0)' failed.
Aborted

~ #
 

The Following User Says Thank You to CarM14 For This Useful Post:
Posts: 184 | Thanked: 204 times | Joined on Aug 2012
#14
Too bad tapatalk doesn't work. It's the app I miss the most from Android.
 
qwazix's Avatar
Moderator | Posts: 2,621 | Thanked: 5,429 times | Joined on Jan 2010
#15
My take is that you should try fullscreen opengl games, not Dalvik apps.
__________________
Proud coding competition 2012 winner: ρcam
My other apps: speedcrunch N9 N900 Jolla contactlaunch timenow

Nemo UX blog: Grog
My website: qwazix.com
My job: oob
 

The Following 6 Users Say Thank You to qwazix For This Useful Post:
Posts: 34 | Thanked: 7 times | Joined on Sep 2012
#16
neither doodle jump... Shlib error..
 
thp's Avatar
Posts: 1,389 | Thanked: 4,248 times | Joined on Sep 2007 @ Vienna, Austria
#17
Updated harmattan binary (apkenv.harmattan.2012-10-21b). Should fix an issue on Harmattan devices without open mode. Also displays more useful error messages.
 

The Following 15 Users Say Thank You to thp For This Useful Post:
Moderator | Posts: 6,215 | Thanked: 6,398 times | Joined on Nov 2011
#18
With the new version the global.jni error seems to have been replaced by Missing library dependencies error and the shlib error is replaced by Not a native .apk error...
 
Posts: 83 | Thanked: 64 times | Joined on May 2012 @ Spain
#19
Not supported:

EDGE
Osmos
Anomaly
World of goo

that works?

Last edited by tanrax; 2012-10-21 at 14:34.
 

The Following User Says Thank You to tanrax For This Useful Post:
lkravovicz's Avatar
Posts: 131 | Thanked: 147 times | Joined on Mar 2007 @ Tallinn, Estonia
#20
Anyone feeling like trying EverNote?
 

The Following User Says Thank You to lkravovicz For This Useful Post:
Reply

Tags
android, emu_layer, new_whazapp, orphanenv, sfdroid, thp ole ole ole, thp's up, y u disobey thp

Thread Tools

 
Forum Jump


All times are GMT. The time now is 14:13.