Active Topics

 



Notices


Reply
Thread Tools
Aranel's Avatar
Posts: 301 | Thanked: 227 times | Joined on Nov 2009 @ Turkey
#21
Maybe in a future version it'd be better to print which libraries are missing, it looks like every single game on Android depends on some libraries which I don't have it installed.

PS: I think it may be futile to try running APK apps, since those weren't supported by Preenv either, if apkenv works the similar way as preenv, opengl games are more likely.
__________________
Maemo/MeeGo/Tizen Turkey - http://meegoturkiye.org & http://tizenturkiye.com
N900: Turkish Localization | MT Theme | VodaSMS
N9: MeeSaver
Maintaining: Audelicious | xmp

Last edited by Aranel; 2012-10-21 at 14:35.
 

The Following User Says Thank You to Aranel For This Useful Post:
Moderator | Posts: 6,215 | Thanked: 6,400 times | Joined on Nov 2011
#22
Originally Posted by tanrax View Post
Not supported:

EDGE
Osmos
Anomaly
World of goo
Please update in wiki instead...

Thanks!


http://wiki.maemo.org/Apkenv/Apps_Compatibility
http://wiki.maemo.org/Apkenv/Game_Compatibility
 
Posts: 169 | Thanked: 132 times | Joined on Oct 2011 @ Toronto, Canada
#23
I can't get it to run cause I'm an idiot.

When trying to install it, it gives me errors. dpkg-i says it's not a debian archive, and compilation failed in require.

Am I missing a very basic step here?
 

The Following User Says Thank You to SolarisSixth For This Useful Post:
thp's Avatar
Posts: 1,389 | Thanked: 4,248 times | Joined on Sep 2007 @ Vienna, Austria
#24
Error message explanation:

Not a native .apk - This is a Dalvik-only .apk, and is not supported via this method (and never will be).
Missing library dependencies - Some required symbols were not found. Make sure you have the Bionic libraries downloaded, and placed in the same folder from where you run apkenv. If it still does not work, try a different (older/newer) version of the .apk you are trying to run.
Not supported yet - apkenv does not know how to run this .apk, but it has native support, and all symbols could be resolved. It might be possible that support for this .apk could be added in the future.

Like preenv, expect this to only run games, not apps.
 

The Following 21 Users Say Thank You to thp For This Useful Post:
Posts: 362 | Thanked: 182 times | Joined on Sep 2010
#25
i'm getting ./apkenv not found or premession denied.
What should the file ending be for apkenv? Mine looks like this apkenv.harmattan.2012-10-21b
 
ibrakalifa's Avatar
Posts: 1,560 | Thanked: 1,096 times | Joined on Dec 2011 @ Everywhere
#26
its opened for a while and then closed, lol, but its cool!!! Awesome

__________________
~$
~#
 

The Following 3 Users Say Thank You to ibrakalifa For This Useful Post:
Aranel's Avatar
Posts: 301 | Thanked: 227 times | Joined on Nov 2009 @ Turkey
#27
Originally Posted by SolarisSixth View Post
I can't get it to run cause I'm an idiot.

When trying to install it, it gives me errors. dpkg-i says it's not a debian archive, and compilation failed in require.

Am I missing a very basic step here?
That's because it's not a debian archive and it's already compiled.

Installation steps:
  • Transfer the binary file and Bionic libraries to your N9. (/home/user/apkenv would be okay) Make sure libraries and binary are in the same folder.
  • Run chmod +x apkenv.harmattan.versiongoeshere
  • Run ./apkenv.harmattan.versiongoeshere <apk filename>
__________________
Maemo/MeeGo/Tizen Turkey - http://meegoturkiye.org & http://tizenturkiye.com
N900: Turkish Localization | MT Theme | VodaSMS
N9: MeeSaver
Maintaining: Audelicious | xmp
 

The Following 4 Users Say Thank You to Aranel For This Useful Post:
Moderator | Posts: 6,215 | Thanked: 6,400 times | Joined on Nov 2011
#28
Originally Posted by SolarisSixth View Post
I can't get it to run cause I'm an idiot.

When trying to install it, it gives me errors. dpkg-i says it's not a debian archive, and compilation failed in require.

Am I missing a very basic step here?
It isn't a DEB!

Download it and in terminal do [assuming you saved it to MyDocs]:

Code:
cp -R /home/user/MyDocs/apkenv.harmattan ./apkenv
chmod 775 ./apkenv

Also copy the bionic libraries as stated in thp's support page to ./


Edit: Beaten to it

Last edited by thedead1440; 2012-10-21 at 14:45.
 

The Following 3 Users Say Thank You to thedead1440 For This Useful Post:
Posts: 835 | Thanked: 772 times | Joined on Oct 2007 @ Finland
#29
With new version:
Spirits 1.1.0
- Quick flash (my heart stopped for 2s)
- Missing library dependencies
Zombie panic in wonderland 1.2
- Missing library dependencies
Plants vs Zombies
- Not supported yet
 

The Following User Says Thank You to Kozzi For This Useful Post:
ibrakalifa's Avatar
Posts: 1,560 | Thanked: 1,096 times | Joined on Dec 2011 @ Everywhere
#30
Its only for games? I tried friendcaster and failed, lol
__________________
~$
~#
 
Reply

Tags
android, emu_layer, new_whazapp, orphanenv, sfdroid, thp ole ole ole, thp's up, y u disobey thp

Thread Tools

 
Forum Jump


All times are GMT. The time now is 09:17.