Active Topics

 



Notices


Reply
Thread Tools
Posts: 3 | Thanked: 1 time | Joined on May 2016
#1
I run a bot in my desktop PC and I would like to use my N800 to do this job. The problem is that the bot is made for python 2.7 and the version in Maemo is 2.5.
Is there any way to install python 2.7 on N800 or any workaround to make the bot work?

Thanks for your help.
 

The Following User Says Thank You to tuberculo For This Useful Post:
Posts: 73 | Thanked: 101 times | Joined on Jan 2012 @ Washington State
#2
Originally Posted by tuberculo View Post
I run a bot in my desktop PC and I would like to use my N800 to do this job. The problem is that the bot is made for python 2.7 and the version in Maemo is 2.5.
Is there any way to install python 2.7 on N800 or any workaround to make the bot work?
FWIW, I have Python 2.7.3 on my n810; I needed it for something
(ages ago, I even forget what...). The important "but" is that I'm
going to tell you it's just a /usr/local/bin install. If you know what
that means then I can supply the bits. If you need a package, then
I'm really not set up to supply one. Perhaps somebody else
will come to the rescue in that case!
 

The Following User Says Thank You to vandys For This Useful Post:
Posts: 3 | Thanked: 1 time | Joined on May 2016
#3
If you mean that I will have to manually copy the files to /usr/local/bin, I can do that.
Thanks for your help.
 
Posts: 73 | Thanked: 101 times | Joined on Jan 2012 @ Washington State
#4
Originally Posted by tuberculo View Post
If you mean that I will have to manually copy the files to /usr/local/bin, I can do that.
Thanks for your help.
Actually, it'll be /usr/local (there are bin, lib, and include files).
You can pick it up at:

http://vsta.org/Nokia/n810_python27.tar.gz

Hope it helps,
Andy
 
Posts: 3 | Thanked: 1 time | Joined on May 2016
#5
Thank you.
I have extracted the files, but now I get the following error:
Code:
error while loading shared libraries: libtk8.6.so: cannot open shared object file: No such file or directory
I've googled that message. So, I added
Code:
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib
to .bashrc but that solution did not work.

Is there something else I can do?
 
Posts: 73 | Thanked: 101 times | Joined on Jan 2012 @ Washington State
#6
Originally Posted by tuberculo View Post
Thank you.
I have extracted the files, but now I get the following error:
Code:
error while loading shared libraries: libtk8.6.so: cannot open shared object file: No such file or directory
I've googled that message. So, I added
Code:
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib
to .bashrc but that solution did not work.

Is there something else I can do?
Hi,

Looks like the port wanted an updated TCL/TK. Add these
(also to /usr/local):

http://vsta.org/Nokia/n810_tcltk86.tar.gz
 
Posts: 3 | Thanked: 0 times | Joined on Jan 2010 @ St Louis, MO
#7
Thank you for the files. It's nice to have a more useful build of python available

Edit
To make my life easier and to avoid messing with the existing python env I went with the shell alias:method so that when I type python it uses 2.7 vs 2.5 yet when system apps look for python they should still use the version they are expecting.
Code:
alias python=/usr/local/bin/python2.7

Last edited by kc0nlh; 2016-06-23 at 07:50.
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 01:16.