Notices


Reply
Thread Tools
Posts: 7 | Thanked: 4 times | Joined on Jul 2008 @ italy
#21
I have the same problem in diablo, granule loads but not starts.
If started from xterminal I get this error:

error while loading shared libraries: libhildonmm-1.0.so.1: cannot open shared object file: No such file or directory.

Any help greatly appreciated.
Thanks.
 
Posts: 2 | Thanked: 1 time | Joined on Aug 2008 @ Cedar Rapids, Iowa
#22
From the fring thread:

Code:
#ln -s /usr/lib/libhildonmm-1.0.so.2 /usr/lib/libhildonmm-1.0.so.1
I'm back on chinook for now until more software is updated, but see if that fixes your problems.
 

The Following User Says Thank You to syntoad For This Useful Post:
vlg's Avatar
Posts: 44 | Thanked: 26 times | Joined on Jan 2006 @ Rockville, MD, USA
#23
I pushed granule-1.4.0-7 both to chinook and diablo 'extras' last night. You should be able to install it with one-click install from the Download

This release introduces new UI design for the Deck Player dialog to take full advantage of scarce screen real estate of Nokia IT N8x0 and adds support for full-screen mode with touch-screen navigation keys.



happy learning,
--Vlad
 
Posts: 4,556 | Thanked: 1,622 times | Joined on Dec 2007
#24
I tried installing it but it says it needs gstreamer-tools. Should I redpill it or grab it from another repo?
__________________
Originally Posted by ysss View Post
They're maemo and MeeGo...

"Meamo!" sounds like what Zorro would say to catherine zeta jones... after she slaps him for looking at her dirtily...
 
vlg's Avatar
Posts: 44 | Thanked: 26 times | Joined on Jan 2006 @ Rockville, MD, USA
#25
gstreamer-tools is listed as dependency and should have been installed automatically. You can, of course, install it in redpill mode - but it makes me wonder what I do wrong on my part.

Here is my debian/control file. Perhaps, someone can point out to me my mistake:

Code:
Source: granule
Section: user/other
Priority: optional
Maintainer: Vladislav Grinchenko <vlg@users.sourceforge.net>
Build-Depends: debhelper (>= 4.0.0), libxml2-dev, libhildon1-dev, libosso-dev, l
ibosso-gnomevfs2-dev, libhildonfm2-dev, osso-af-settings, libgconf2-dev, libhildonmm-dev, libhildon-fmmm-dev, intltool, libassa-dev
Standards-Version: 3.6.1

Package: granule
Architecture: any
Depends: ${shlibs:Depends}, gstreamer-tools
Description: flashcard program for learning new words
 
Posts: 2 | Thanked: 0 times | Joined on Sep 2008
#26
gstreamer-tools doesn't seem to exist in the extras repository, or any of the other default repositories. I'm not sure where you've gotten it from, but it is actually missing, so it's not the fault of your control file. I noticed libassa in extras-devel, so I guess that package just needs to be promoted.
 
vlg's Avatar
Posts: 44 | Thanked: 26 times | Joined on Jan 2006 @ Rockville, MD, USA
#27
gstreamer-tools is a system-level package.

I tested the chinook installation and it worked for me as expected.

I wonder if diablo is different in this respect and if I should install it and
investigate this issue further.

You might try to install gstreamer-tools from XTerm with something like

$ sudo gainroot
# apt-get install gstreamer-tools
 
Posts: 18 | Thanked: 2 times | Joined on Oct 2007
#28
I'm having the same issue with gstreamer-tools on diablo.

Thanks for the work with granule, I'm sure it will be great once I install it.
 
Posts: 18 | Thanked: 2 times | Joined on Oct 2007
#29
I've resolved my problems with gstreamer-tools on diablo.

I grabbed the chinook gstreamer-tools debs:

http://repository.maemo.org/pool/chi...nook_armel.deb

http://repository.maemo.org/pool/chi...nook_armel.deb

Granule installs after this
 
Posts: 69 | Thanked: 10 times | Joined on Nov 2007
#30
When I tried to install gstreamer using cashel's links, I got the incompatible error message. I am running the latest version of diablo on an 810. How do I install a chinook app on a diablo machine?

Many thanks.
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 16:08.