Notices


Reply
Thread Tools
Posts: 15 | Thanked: 0 times | Joined on May 2010 @ Saigon
#1
Hi alls
After upgrade to PR1.2, my N900 can not play FM radio any more.
Its error message: Cannot Load FM driver Module.
I had tried to uninstall/reinstall several times but it did not help.
I also tried to send bug reports but there is no answer
Is there any expert can help me to fix this problem
Your help is highly appreciated.
Thanks & Best Regards
YinYang
 
Posts: 15 | Thanked: 0 times | Joined on May 2010 @ Saigon
#2
Hic do I need to flash my N900 again?
Pls advice
Many thanks
Yinyang
 
Posts: 14 | Thanked: 8 times | Joined on Feb 2010
#3
Getting the same error here.
 
Posts: 1 | Thanked: 0 times | Joined on Oct 2010
#4
fixed it using the shell:

Assuming that you know your root password or have root access: [ http://wiki.maemo.org/Root_access ]

Step 1: Uninstall FMReceiver from application manager
Step 2: Open the shell (x-terminal)
Step 3: run : "apt-get install fmradio"
Once step 3 is complete:
Step 4: run "apt-get install gstreamer-tools"

now try running the app.. worked for me.
 
Posts: 3 | Thanked: 1 time | Joined on Nov 2010
#5
I tried those directions viveksri15 but didn't work, the newly installed app still claims it "Cannot Load FM driver Module"
 
Posts: 490 | Thanked: 191 times | Joined on May 2010
#6
Originally Posted by so142001 View Post
I tried those directions viveksri15 but didn't work, the newly installed app still claims it "Cannot Load FM driver Module"

Are you using host-mode kernel ?

Last edited by aligatro; 2010-11-08 at 22:09.
 
mrwormp's Avatar
Posts: 127 | Thanked: 40 times | Joined on Sep 2010 @ Jamaica
#7
I am having the same problem also. right now am really missing my radio
 
Posts: 8 | Thanked: 0 times | Joined on Jul 2010 @ The Netherlands
#8
i lost my radio also and reinstall dont work not even with xterm. anyway to fix it then reinstall os with nsu3 ?
 
Posts: 50 | Thanked: 11 times | Joined on Nov 2009
#9
I recently ran into this problem as well. I use titan's enhanced kernel, and had recently updated it. Since that was one of the last changes I had made since I noticed my radio stopped working, i downgraded it.

In x-term:

apt-get install kernel-power-flasher=2.6.28-maemo42 kernel-power=2.6.28-maemo42 kernel-power-modules=2.6.28-maemo42

This fixed my problem, radio works fine again. Hope this helps.
 

The Following 3 Users Say Thank You to llamastyle For This Useful Post:
Posts: 8 | Thanked: 0 times | Joined on Jul 2010 @ The Netherlands
#10
[img]img812.imageshack.us/img812/2046/screenshot2010111823115.png [/img] am i doing something wrong?
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 00:34.