Notices


Reply
Thread Tools
Posts: 1 | Thanked: 0 times | Joined on Apr 2011
#11
Originally Posted by llamastyle View Post
I recently ran into this problem as well. I use titan's enhanced kernel, and had recently updated it. Since that was one of the last changes I had made since I noticed my radio stopped working, i downgraded it.

In x-term:

apt-get install kernel-power-flasher=2.6.28-maemo42 kernel-power=2.6.28-maemo42 kernel-power-modules=2.6.28-maemo42

This fixed my problem, radio works fine again. Hope this helps.
Thanks mate, it worked for me also.
 
adelalgomai's Avatar
Posts: 54 | Thanked: 47 times | Joined on Oct 2011 @ Yemen
#12
Originally Posted by aligatro View Post
Are you using host-mode kernel ?
I have the same problem too , and as u mentioned , I have hostmode , I was able to use radio , but it;s long time since the last use, so I don;t know if the problem happened before or after installing hostmode,, but u might be right ... and for more details , I want to tell u that my hostmode is not working yet since i installed it and I have an error say: kenel power version no proper match, something like that .. and beside that u may need to know that I have 2 radio players and both are not working now .. and the last thing : FM transmeter works fine with no problems ..
so i hope u maight find a way to help us .. thank u anyway ..

Last edited by adelalgomai; 2011-10-27 at 17:11.
 
Posts: 502 | Thanked: 361 times | Joined on Jun 2010 @ /dev/null
#13
Hostmode in theory should not cause any issues with FMRX. The FMRX is the same chipset that controls bluetooth which is a broadcom based. It might be a good idea to check `dmesg' (via X Terminal) to see any potential reasons why.
__________________
 
Posts: 25 | Thanked: 14 times | Joined on May 2012
#14
So, has no fix ever been found for this one? I've lost my FM radio, too.
 
Posts: 54 | Thanked: 6 times | Joined on Nov 2011
#15
Hello everyone, any idea on how to fix this?
I use the radio a lot and i really miss it, i am currently on kernel power v50, please help.
thanks a lot
 
Posts: 54 | Thanked: 6 times | Joined on Nov 2011
#16
Anyone any idea?
 
Posts: 279 | Thanked: 34 times | Joined on Jan 2010 @ Belgrade, Serbia
#17
Still no fix for this...?
 
Posts: 8 | Thanked: 0 times | Joined on Jan 2014
#18
I've noticed that people have been having problems with their Nokia N900 not having radio after the PR 1.3 update.
I've managed to get my radio turned back on. Here's how. Please follow the instructions on the following MyNokiaBlog website except
flash the necessary .bin files and Z-Image files at the following associated sites:

http://mynokiablog.com/2010/06/02/ho...-v10-2010-19-1

Cut and paste into your browser the addresses from where to get the files that will re-enable your N900's built-in radio.

RX-51_2009SE_21.2011.38-1.002_PR_COMBINED_002_ARM.bin from URL_REMOVED

RX-51_2009SE_10.2010.13-2.VANILLA_PR_EMMC_MR0_ARM.bin from URL_REMOVED


Download an image to make your N900 faster at 900 mHz -it defaults at 600 mHz. The operative command line is:

flasher-3.5.exe -k zImage-900mhz -f -R

zImage-900mhz from URL_REMOVED


Install the fmradio.install app from Maemo's Repository after you have flashed the N900 with everything else.

fmradio.install from http://repository.maemo.org/extras-d...mradio.install

Last edited by chemist; 2014-01-30 at 21:08.
 
Posts: 3 | Thanked: 4 times | Joined on Feb 2010 @ Bangalore, India
#19
Originally Posted by yinyang69_vn View Post
Hi alls
After upgrade to PR1.2, my N900 can not play FM radio any more.
Its error message: Cannot Load FM driver Module.
I had tried to uninstall/reinstall several times but it did not help.
I also tried to send bug reports but there is no answer
Is there any expert can help me to fix this problem
Your help is highly appreciated.
Thanks & Best Regards
YinYang
I was getting the same problem after installing kernel-power latest version (53). I did the following to fix it.

Not sure if these steps will work for others, but documenting anyway as it worked for me.

1. Uninstalled kernel-power and reinstalled stock kernel after making a backup of the radio kernel module.

$ cp /lib/modules/current/radio-bcm2048.ko ~/radio-bcm2048.ko.new

2. Rebooted.
3. Copied the radio kernel module of stock kernel to home directory.

$ cd /lib/modules/current
$ sudo cp radio-bcm2048.ko ~
4. Installed kernel-power again.
5. Copied the stock version of radio kernel module back to /lib/modules/current .

$ cd /lib/modules/current
$ sudo cp ~/radio-bcm2048.ko .
6. Rebooted.

Upon reboot and launching FM radio, you will get the same error since the old module won't load in the new kernel. Now,

7. Copy back the actual module again.

$ sudo cp ~/radio-bcm2048.ko.new /lib/modules/current/radio-bcm2048.ko
8. Load it

$ sudo modprobe radio-bcm2048

9. A dmesg shows me the following messages.

[ 2177.886901] radio_bcm2048: disagrees about version of symbol struct_module
[ 2181.590332] radio_bcm2048: disagrees about version of symbol struct_module
[ 2230.163513] I2C driver for BCM2048 FM Radio Receiver
[ 2230.202178] bcm2048 3-0022: BCM2048 Version 0x0

The same message comes but the module is loaded now correctly.

I am listening to FM radio using kernel-power53 while writing this post.
 

The Following User Says Thank You to pythonhacker For This Useful Post:
waiku's Avatar
Posts: 17 | Thanked: 1 time | Joined on Feb 2011 @ Pondokcina AX (Jawa Barat ID)
#20
Originally Posted by pythonhacker View Post
I was getting the same problem after installing kernel-power latest version (53). I did the following to fix it.

Not sure if these steps will work for others, but documenting anyway as it worked for me.

1. Uninstalled kernel-power and reinstalled stock kernel after making a backup of the radio kernel module.

$ cp /lib/modules/current/radio-bcm2048.ko ~/radio-bcm2048.ko.new

2. Rebooted.
3. Copied the radio kernel module of stock kernel to home directory.

$ cd /lib/modules/current
$ sudo cp radio-bcm2048.ko ~
4. Installed kernel-power again.
5. Copied the stock version of radio kernel module back to /lib/modules/current .

$ cd /lib/modules/current
$ sudo cp ~/radio-bcm2048.ko .
6. Rebooted.

Upon reboot and launching FM radio, you will get the same error since the old module won't load in the new kernel. Now,

7. Copy back the actual module again.

$ sudo cp ~/radio-bcm2048.ko.new /lib/modules/current/radio-bcm2048.ko
8. Load it

$ sudo modprobe radio-bcm2048

9. A dmesg shows me the following messages.

[ 2177.886901] radio_bcm2048: disagrees about version of symbol struct_module
[ 2181.590332] radio_bcm2048: disagrees about version of symbol struct_module
[ 2230.163513] I2C driver for BCM2048 FM Radio Receiver
[ 2230.202178] bcm2048 3-0022: BCM2048 Version 0x0

The same message comes but the module is loaded now correctly.

I am listening to FM radio using kernel-power53 while writing this post.
Hi..
Can you write the command in more specific, because i can not follow your step directly.

thank you
__________________
Salam Hangat....
Assirac Agung


email: jcmnerv@yahoo.com
weblog: agunginfo.wordpress.com
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 04:05.