Notices


Reply
Thread Tools
Posts: 427 | Thanked: 1,136 times | Joined on Feb 2012 @ Germany
#31
Originally Posted by mr_pingu View Post
Thanks, now I have insight why it doesn't work.
So I started manually qemu and it looks like it is a graphics driver problem. In squeeze there is no emulated gl driver it could be that there is a backport.

libEGL.so.1 is missing....
 

The Following 2 Users Say Thank You to Halftux For This Useful Post:
Posts: 427 | Thanked: 1,136 times | Joined on Feb 2012 @ Germany
#32
So I got the emulator in QtCreator running.

update sources.list and add apt.conf in /etc/apt/ see attachment.

run as su:
Code:
apt-get update
apt-get install libegl1-mesa
apt-get install libgles2
ln -s /usr/lib/libGLESv2.so.2.0.0 /usr/lib/libGLESv2.so.1
chmod -R 777 /opt/QtSDK
Attached Files
File Type: gz aptupdate.tar.gz (443 Bytes, 27 views)
 

The Following 3 Users Say Thank You to Halftux For This Useful Post:
Posts: 427 | Thanked: 1,136 times | Joined on Feb 2012 @ Germany
#33
Reminder....

After the last Virtualbox update I wanted to update also the guest additions because I never did before.
Due to the backport sources there could be a new kernel.
Furthermore I got some hint about libgl need a fix.

So here is what I did:
as root:

Code:
strip -R .note.ABI-tag /usr/lib/libGl.so.1
ldconfig
It is also necessary that you check your kernel version (uname -r) and if the headers are missing install the headers for your running kernel.
After this you can install the guest additions.
Attached Images
 
 

The Following 2 Users Say Thank You to Halftux For This Useful Post:
Reply

Tags
crosstool, image, qtsdk, scratchbox, toolchain

Thread Tools

 
Forum Jump


All times are GMT. The time now is 14:39.