Active Topics

 



Notices


Reply
Thread Tools
Posts: 155 | Thanked: 700 times | Joined on Aug 2016 @ Estonia
#201
Originally Posted by eson View Post
I found one string untranslated. This one is missing in translation file.
Thank you! Fixed in the latest commit and uploaded for translation.
 

The Following 4 Users Say Thank You to rinigus For This Useful Post:
Posts: 23 | Thanked: 41 times | Joined on Sep 2013 @ Norway
#202
Norwegian translation is now complete. -->Norsk oversettelse er nå komplett
 

The Following 6 Users Say Thank You to PamNor For This Useful Post:
Posts: 155 | Thanked: 700 times | Joined on Aug 2016 @ Estonia
#203
Originally Posted by PamNor View Post
Norwegian translation is now complete. -->Norsk oversettelse er nå komplett
Thank you very much! Its a big work.
 

The Following 3 Users Say Thank You to rinigus For This Useful Post:
Posts: 155 | Thanked: 700 times | Joined on Aug 2016 @ Estonia
#204
With the map distribution server back online (thank you @MartinK!), I am preparing for a new release with an updated geocoder-nlp implementation that reduces the used storage size and should be faster as well. Unfortunately, it requires a new data storage format. While I did my best with the testing, its a major change and could lead to some breakage.

So, if you are planning a trip and depend on OSM Scout Server then I suggest to get the required maps today/tomorrow and store them in a safe place before the upgrade. If all goes as planned, I will publish new version on Wednesday morning with the World maps uploaded to the maps distribution server during a night between Tuesday and Wednesday.
 

The Following 5 Users Say Thank You to rinigus For This Useful Post:
Posts: 155 | Thanked: 700 times | Joined on Aug 2016 @ Estonia
#205
I am happy to announce 0.8.0 release.

This release is mainly about geocoder-nlp polishing. Searches using geocoder-nlp should be faster and the datasets are about 2 times smaller. The libpostal part is still as large as before, but that is out of my hands.

The database format has changed and, as a result, you would have to get new version of the maps. The maps have been uploaded, so all should be ready. If you get the server from Harbour, it should be published on 29th, to sync with the new maps update.

To update the maps, open Map Manager and click Check for updates. Note that due to incompatibility of geocoder-nlp part, you cannot use 0.7.x maps on 0.8.x if you subscribed to geocoder-nlp. Update the maps as soon as you move to 0.8.x, please.

In this version, Linux CLI is supported again. Use command line options to subscribe and download the maps. Some configuration is done via INI configuration file that is populated with defaults on the first run. If you have any questions, please ask and I will help you out.

There are several translations updated. In addition, several fixes are carried over via update of libosmscout version.

I consider geocoder-nlp as ready for use. Please let me know if you experience slow response, too much RAM used, missing or not found data in search. I'll be happy to improve it as much as I can.

Unless major bug reports will start flying in, I will focus now on other aspects of the map server.
 

The Following 9 Users Say Thank You to rinigus For This Useful Post:
Posts: 70 | Thanked: 142 times | Joined on Sep 2016 @ Yekaterinbourg, Russia
#206
@rinigus I updated without problems. Maps (77MB + 81MB) have been updated via 3G in 8 minutes.
 

The Following 2 Users Say Thank You to XOleg For This Useful Post:
Posts: 73 | Thanked: 69 times | Joined on Feb 2014 @ Spain
#207
Originally Posted by rinigus View Post
I am happy to announce 0.8.0 release.

This release is mainly about geocoder-nlp polishing. Searches using geocoder-nlp should be faster and the datasets are about 2 times smaller. The libpostal part is still as large as before, but that is out of my hands.

The database format has changed and, as a result, you would have to get new version of the maps. The maps have been uploaded, so all should be ready. If you get the server from Harbour, it should be published on 29th, to sync with the new maps update.

To update the maps, open Map Manager and click Check for updates. Note that due to incompatibility of geocoder-nlp part, you cannot use 0.7.x maps on 0.8.x if you subscribed to geocoder-nlp. Update the maps as soon as you move to 0.8.x, please.

In this version, Linux CLI is supported again. Use command line options to subscribe and download the maps. Some configuration is done via INI configuration file that is populated with defaults on the first run. If you have any questions, please ask and I will help you out.

There are several translations updated. In addition, several fixes are carried over via update of libosmscout version.

I consider geocoder-nlp as ready for use. Please let me know if you experience slow response, too much RAM used, missing or not found data in search. I'll be happy to improve it as much as I can.

Unless major bug reports will start flying in, I will focus now on other aspects of the map server.
Thanks for the update!! I've installed it on my tablet, but I can't open it. Is this a bug?
 

The Following 5 Users Say Thank You to carmenluci For This Useful Post:
Posts: 155 | Thanked: 700 times | Joined on Aug 2016 @ Estonia
#208
Originally Posted by carmenluci View Post
Thanks for the update!! I've installed it on my tablet, but I can't open it. Is this a bug?
Sounds like a bug. I presume you use it on i486, right? Do you have any output when you start it from command line? did the earlier versions work ?
 

The Following 4 Users Say Thank You to rinigus For This Useful Post:
Posts: 155 | Thanked: 700 times | Joined on Aug 2016 @ Estonia
#209
Originally Posted by XOleg View Post
@rinigus I updated without problems. Maps (77MB + 81MB) have been updated via 3G in 8 minutes.
Great to hear!
 

The Following User Says Thank You to rinigus For This Useful Post:
Posts: 73 | Thanked: 69 times | Joined on Feb 2014 @ Spain
#210
Originally Posted by rinigus View Post
Sounds like a bug. I presume you use it on i486, right? Do you have any output when you start it from command line? did the earlier versions work ?
Yeah, I installed on i486 device. If I open the app via Terminal, it shows this message: 'Instrucción ilegal' (in English 'Illegal instruction').
0.7.5 version works fine, but I can't download maps because they aren't compatible and I must update the app.

Last edited by carmenluci; 2017-03-29 at 17:00.
 

The Following 3 Users Say Thank You to carmenluci For This Useful Post:
Reply

Tags
offline maps, sailfish os

Thread Tools

 
Forum Jump


All times are GMT. The time now is 02:59.