Notices


Reply
Thread Tools
Posts: 3 | Thanked: 1 time | Joined on Dec 2009 @ Italy
#21
Originally Posted by lordbyte View Post
I have a Parrot MKi9100 that support PBAP and Garmin Zumo 660.

On my N900 I have do all (Install packages, replace obexd , phone reboot, new pairing with car kit, ecc.....) but not work.

When Car Kit connect to N900 on display appare "Sync in progress" but after 1 sec disappare and no contact ws synced.

Attached you can find hcidump trace
Can anyone tell me what is wrong?

Thank

-=LordByte=-
New details:

Zumo connect to n900 and no other messages appare
Parrot connect to N900 , say "sync in progress" , but after 1 sec disappare and no contacts was sync.

I ave already check:

- Obexd is running and --pbap options is present
- If I do sdptool from my linux box I can see PBAP profile on my N900


Please help

-=LordByte=-
 
Posts: 2 | Thanked: 0 times | Joined on Jul 2010
#22
I tested it yesterday and for the first time I could see the "Contact list" option on my car, however when I click on the option nothing happens, the contact list does not appear. Also, I noticed the BT connection becomes very unstable (dropping from time to time).

Anyway, I could uninstall it and the connection got stable again but as expected the "Contact list" option dissapeared...

I just hope Nokia implement PBAP on a next update...

Thanks,
Andre.
 
Reflektorfalke's Avatar
Posts: 597 | Thanked: 490 times | Joined on Dec 2009 @ Germany
#23
Originally Posted by langkjer View Post
I tested it yesterday and for the first time I could see the "Contact list" option on my car, however when I click on the option nothing happens, the contact list does not appear.
Please note that the phone book transfer might take some moments to complete and appear (guess up to around 1 minute).
Furthermore, with previous versions it was in some cases necessary to place an outgoing call once to initiate the transfer...
Not sure if it was really the call or just the additional time that did the trick and assumed it is not necessary anymore with the latest version - but its still worth a try and place an outgoing call after the connection was established...
 
Posts: 8 | Thanked: 0 times | Joined on Feb 2010 @ Netherlands
#24
Originally Posted by thofstee View Post
Strange. The phone got paired, the icon changed on my phone and I was able to access the phone menu on my RNS-510 system.

What steps do I need to describe better? I start the logging just before I started my car, the phone got paired, drove for about 40 minutes, parked my car, the phone got unpaired, entered the building and stopped logging by pressing Ctrl+C.

Just to be sure I reinstalled the original obex packages and used the manual from the first post to install the packages again.

Even now I don't end up with a correct hcidump file. But this time the file shows a few errors. However I didn't see any errors on my N900 or RNS-510 system.
Attached Files
File Type: zip log.zip (3.8 KB, 197 views)
 
Posts: 9 | Thanked: 3 times | Joined on Jan 2010 @ Germany/Berlin
#25
Works perfect, on my:

BMW E91 320d with Business Navi (07/2008)

thanks for all your work !!!!
 

The Following 2 Users Say Thank You to breeze For This Useful Post:
Posts: 197 | Thanked: 101 times | Joined on Dec 2009 @ Netherlands
#26
To analyse failures I think it is very vsaluable to also get syslog output. Thsi can show what obexd is doing. It shows things you won't see in the hcidump log.

To use syslog:

apt-get install sysklogd

and add the --debug optuon to your obexd command invocation.

sysklogd will create a file /var/log/syslog

After your test copy this file to some other location (do not delete the original)
and edit out the relevant part. so you can post it alongside the hcidump log.
 

The Following 2 Users Say Thank You to mirakels For This Useful Post:
Reflektorfalke's Avatar
Posts: 597 | Thanked: 490 times | Joined on Dec 2009 @ Germany
#27
Originally Posted by mirakels View Post
To analyse failures I think it is very vsaluable to also get syslog output. Thsi can show what obexd is doing. It shows things you won't see in the hcidump log.

To use syslog:

apt-get install sysklogd

and add the --debug optuon to your obexd command invocation.

sysklogd will create a file /var/log/syslog

After your test copy this file to some other location (do not delete the original)
and edit out the relevant part. so you can post it alongside the hcidump log.
Hi Mirakels!

Thankx a lot for your support!
Would it be possible to give us a more detailed guideline how to enable the --debug option, one that even Linux-noobs will understand
I think it would be nice to have this in the summary in the first post...
 
Posts: 197 | Thanked: 101 times | Joined on Dec 2009 @ Netherlands
#28
The startup command should become something like

/usr/lib/obex/obexd --debug --opp --ftp --pcsuite --pbap --symlinks --root .obex-root --root-setup /usr/bin/obex-root-setup --capability !/usr/bin/gen-obex-capability.sh

Ypu can run this manually after killing the current running one, or
you can change the dbus service file (somewhere in /usr/share/dbus/service I think) so it will be started like this on startup,

Not this is only usefull if you install the sysklog package.
 

The Following User Says Thank You to mirakels For This Useful Post:
danramos's Avatar
Posts: 4,672 | Thanked: 5,453 times | Joined on Jul 2008 @ Springfield, MA, USA
#29
Dammit.. my 1974 VW Beetle isn't listed.
 
Reflektorfalke's Avatar
Posts: 597 | Thanked: 490 times | Joined on Dec 2009 @ Germany
#30
Originally Posted by danramos View Post
Dammit.. my 1974 VW Beetle isn't listed.
Haha, no worries, I have the same situation with my 1980 one
But who knows maybe its worth a try and this is the way to make Herbie talk to me ;-)
 

The Following User Says Thank You to Reflektorfalke For This Useful Post:
Reply

Tags
bada rox, bluetooth, carkit, contacts, irmc sync, pbap profile

Thread Tools

 
Forum Jump


All times are GMT. The time now is 11:32.