Notices


Reply
Thread Tools
Posts: 756 | Thanked: 2,657 times | Joined on Apr 2012
#661
I got it working, as a hack, by copying the .ini file from my Jolla. Not a great solution though.
 
Posts: 35 | Thanked: 133 times | Joined on Apr 2017 @ Germany
#662
Short info: I was not able to install v1.3-3 on my OPX. That was because I could not get the qt5-qtwebsockets from the jolla repos:
Code:
No provider of 'qt5-qtwebsockets' found.
I think this is due to old version of SFOS on my phone (2.1.0.11).
So I had to find a version which would work with rockpool.
I tested every version on openrepos and finally found one:
https://openrepos.net/content/aa13q/qt5-qtwebsockets

If you need help, feel free to contact me or ask in this thread.
 
Posts: 18 | Thanked: 19 times | Joined on Mar 2016 @ Finland
#663
How about this:

https://openrepos.net/content/coderus/qt5websockets

Does Rockpool work with that ?
 
Posts: 285 | Thanked: 851 times | Joined on Dec 2015
#664
Now QtWebSockets is in the Sailfish repos. You should remove any other version and repo and use that one. Instruction are on the OpenRepos page for Rockpool.
 
Posts: 18 | Thanked: 19 times | Joined on Mar 2016 @ Finland
#665
Ok, so you mean these commands:

Code:
rpm -e --nodeps qt5-qtwebsockets

zypper ref openrepos-abranson

zypper in --from=jolla qt5-qtwebsockets
Suppose I have to devel-su ? Do I need to be in specific location when executing those? What does the second command do ?

How could I check if I already have the "official" qtwebsockets ?

EDIT: And I don't seem to have a command named 'zypper' !?

Last edited by Upp15; Today at 20:22.
 
Posts: 285 | Thanked: 851 times | Joined on Dec 2015
#666
Originally Posted by Upp15 View Post
Suppose I have to devel-su ? Do I need to be in specific location when executing those? What does the second command do ?
Yes, devel-su for installing and removing packages. No specific directory. The second command refreshed my repo, if you were using that, to pick up the fact that I removed that rpm from my repo. The community built versions were a higher version than the Jolla one, so it won't upgrade unless you really force it.

Originally Posted by Upp15 View Post
How could I check if I already have the "official" qtwebsockets ?
zypper if qt5-qtwebsockets

Originally Posted by Upp15 View Post
EDIT: And I don't seem to have a command named 'zypper' !?
pkcon install zypper
 
Posts: 18 | Thanked: 19 times | Joined on Mar 2016 @ Finland
#667
pkcon install zypper

ends with an error saying that " ...augeas-libs-1.0.0-1.1.5... couldn't be found from ...<url to jolla.com>" !?
 
Posts: 285 | Thanked: 851 times | Joined on Dec 2015
#668
pkcon refresh
 
Posts: 18 | Thanked: 19 times | Joined on Mar 2016 @ Finland
#669
Ok, that helped. Thanks!

It seemed, that I already had the jolla version of qtwebsockets. The Rockpool upgrade went fine.
 
Posts: 409 | Thanked: 942 times | Joined on Jan 2012 @ Enschede, The Netherlands
#670
Apart from the WebSocket change, I had to uninstall and reinstall Rockpool. "Update" from 1.3.3 to 1.4 wan't available. Sorry, I didn't investigate further what was blocking it, this work-around worked for me and am now on 1.4.

Thanks for the update!
 
Reply

Tags
pebble, smartwatch

Thread Tools

 
Forum Jump


All times are GMT. The time now is 22:28.