Notices


Reply
Thread Tools
Posts: 2,230 | Thanked: 3,956 times | Joined on Apr 2010 @ England
#1
So the repositories are now repaired thanks to our techstaff.

It's now time for the community (yes, you), to get back to using maemo.org to it's full potential.

Testers:-
There are a large quantity of packages that need testing CORRECTLY and voting on.
Please if you can, start testing and QA'ing packages, filing bug reports on bugzilla, bumping threads on TMO regarding any versions stuck in devel/testing, contacting maintainers for support etc.

Developers:-
If you have a package that has been hanging in devel or testing, why?? Get it promoted, if you feel is it stable enough for all the community to enjoy. Extras-devel is no longer the place to be pushing long term "stable" updates.
Let's get our repositories working how they should be again.

Also if any developers feel like supplying fixes or becoming a maintainer of a package, feel free to request that on the package interface.

http://wiki.maemo.org/Extras-testing
http://wiki.maemo.org/Extras-testing/QA_Checklist
http://wiki.maemo.org/Testing_Squad
http://wiki.maemo.org/Extras-testing/Darp

Package testers your community needs you to QA and promote.
Any questions feel free to find me on #maemo.
__________________
The stable-beast currently runs...
21.2011.38-1Smaemo8 (CSSU Stable)
2.6.28.10power53 (125-600Mhz SR VDD1&2)

Wiki Admin
sixwheeledbeast's wiki
Testing Squad Subscriber
- mcallerx - tenminutecore - FlopSwap - Qnotted - zzztop - Bander - Fight2048 -


Before posting or starting a thread please try this.

Last edited by sixwheeledbeast; 2013-12-17 at 20:27.
 

The Following 35 Users Say Thank You to sixwheeledbeast For This Useful Post:
Posts: 2,230 | Thanked: 3,956 times | Joined on Apr 2010 @ England
#2
Well so far the response to my thread has been a bit slow.
I have been monitoring the QA list and I can't say many packages have been given the thumbs up.
While I do agree it has only been 5 days, I have fairly high expectations of our community

So in order to help the process along I will be testing a package each week and featuring it here.
Hopefully with willing participants this method can consolidate on providing enough votes to promote at least a single package per week.

Testers will have the comfort of knowing I have glanced through the source of the package and tested it on my device first. This doesn't mean in anyway that the package is completely safe and therefore tested BTW.

The exposure to new packages maybe enlightening so do feel free to test other packages in the QA queue, if you have time.
http://maemo.org/packages/repository...xtras-testing/

Even if packages have been given thumbs up before from other people please test them correctly. It's worth noting a good number of packages are now broken even though they where tested fine 2 years ago.

Slowly we can weed these broken packages out, please let us know if you find any broken packages.
The best place to report at the moment is http://talk.maemo.org/showthread.php?t=88353.
Post here only if you get no response from bug tickets on bugs.maemo.org or the packages bugtracker link.
Alternatively if required I can be found on #maemo.

So community - let's get testing.
__________________
The stable-beast currently runs...
21.2011.38-1Smaemo8 (CSSU Stable)
2.6.28.10power53 (125-600Mhz SR VDD1&2)

Wiki Admin
sixwheeledbeast's wiki
Testing Squad Subscriber
- mcallerx - tenminutecore - FlopSwap - Qnotted - zzztop - Bander - Fight2048 -


Before posting or starting a thread please try this.
 

The Following 9 Users Say Thank You to sixwheeledbeast For This Useful Post:
Posts: 2,230 | Thanked: 3,956 times | Joined on Apr 2010 @ England
#3
Well ... first on the featured packages, I think it's only fair to feature...

[DRUM-ROLL]

connectagram 1.0.1maemo0-1

Section: Games
Dev: Nicolai Hess

http://maemo.org/packages/package_in...1.0.1maemo0-1/

This was the first package to be promoted to extras-testing after this thread started on Thursday.

Happy Testing.
__________________
The stable-beast currently runs...
21.2011.38-1Smaemo8 (CSSU Stable)
2.6.28.10power53 (125-600Mhz SR VDD1&2)

Wiki Admin
sixwheeledbeast's wiki
Testing Squad Subscriber
- mcallerx - tenminutecore - FlopSwap - Qnotted - zzztop - Bander - Fight2048 -


Before posting or starting a thread please try this.
 

The Following 9 Users Say Thank You to sixwheeledbeast For This Useful Post:
Posts: 3,019 | Thanked: 12,499 times | Joined on Mar 2010 @ Sofia,Bulgaria
#4
Seems it will take some time for the (couple of) remaining developers and testers to start using the package interface etc. again. Unfortunately that makes sense, as it's been too long we have those non-functional.
__________________
Never fear. I is here.

720p video support on N900,SmartReflex on N900,Keyboard and mouse support on N900
Nothing is impossible - Stable thumb2 on n900

Community SSU developer
kernel-power developer and maintainer

 

The Following 2 Users Say Thank You to freemangordon For This Useful Post:
Posts: 826 | Thanked: 3,319 times | Joined on Mar 2009
#5
How about packages in extras-devel, which need features from CSSU?

I think I have some SDL-games (maybe about sdl-mixer) hanging on extras-devel, because they don't work correctly without CSSU.
 

The Following 4 Users Say Thank You to AapoRantalainen For This Useful Post:
Posts: 2,230 | Thanked: 3,956 times | Joined on Apr 2010 @ England
#6
Originally Posted by AapoRantalainen View Post
How about packages in extras-devel, which need features from CSSU?

I think I have some SDL-games (maybe about sdl-mixer) hanging on extras-devel, because they don't work correctly without CSSU.
This is a good question there are also applications that conflict with CSSU.

I don't see this as a reason to hold these packages in devel, they need to be tested.

I would guess these packages should be packaged in some standardised way to check for CSSU installation. However, I currently have no idea of the correct way to do this.
__________________
The stable-beast currently runs...
21.2011.38-1Smaemo8 (CSSU Stable)
2.6.28.10power53 (125-600Mhz SR VDD1&2)

Wiki Admin
sixwheeledbeast's wiki
Testing Squad Subscriber
- mcallerx - tenminutecore - FlopSwap - Qnotted - zzztop - Bander - Fight2048 -


Before posting or starting a thread please try this.
 

The Following 3 Users Say Thank You to sixwheeledbeast For This Useful Post:
Posts: 2,076 | Thanked: 3,251 times | Joined on Feb 2011
#7
Originally Posted by sixwheeledbeast View Post
This is a good question there are also applications that conflict with CSSU.

I don't see this as a reason to hold these packages in devel, they need to be tested.

I would guess these packages should be packaged in some standardised way to check for CSSU installation. However, I currently have no idea of the correct way to do this.
I think we need guidelines. Well thought of. There are console only program packages compiled in CSSU environments that have broken enter key in Nokia's 1.3.1 latest official release. Are they testing good? On CSSU devices, yeah, on non-CSSU, red-flags (using ctrl-m for enter is enough for red-flag i hope?). Which version is the truth testers should follow/grade?
 

The Following 2 Users Say Thank You to szopin For This Useful Post:
Posts: 2,230 | Thanked: 3,956 times | Joined on Apr 2010 @ England
#8
Originally Posted by szopin View Post
I think we need guidelines. Well thought of. There are console only program packages compiled in CSSU environments that have broken enter key in Nokia's 1.3.1 latest official release. Are they testing good? On CSSU devices, yeah, on non-CSSU, red-flags (using ctrl-m for enter is enough for red-flag i hope?). Which version is the truth testers should follow/grade?
Personally I would treat this as a thumbs down and comment on the bug. IMO the package should be adapted to suit PR1.3.1 and CSSU or made to conflict/depend on them.
This is why we have package testing, not everyone will have the same setup.

The future of Maemo is CSSU so IMO packages need to keep up to date and support it.
__________________
The stable-beast currently runs...
21.2011.38-1Smaemo8 (CSSU Stable)
2.6.28.10power53 (125-600Mhz SR VDD1&2)

Wiki Admin
sixwheeledbeast's wiki
Testing Squad Subscriber
- mcallerx - tenminutecore - FlopSwap - Qnotted - zzztop - Bander - Fight2048 -


Before posting or starting a thread please try this.
 

The Following User Says Thank You to sixwheeledbeast For This Useful Post:
Posts: 2,076 | Thanked: 3,251 times | Joined on Feb 2011
#9
Originally Posted by sixwheeledbeast View Post
Personally I would treat this as a thumbs down and comment on the bug. IMO the package should be adapted to suit PR1.3.1 and CSSU or made to conflict/depend on them.
This is why we have package testing, not everyone will have the same setup.

The future of Maemo is CSSU so IMO packages need to keep up to date and support it.
I think this is the problem, while everyone updated their packages (in theory) from 1.0 to 1.1 and .2 and .3, CSSU cannot really let backwards incompatibility to creep in, as having all the devs to update once again from .3 to .3CSSU-X is not going to happen (and sadly with more branches of cssu even less probable)
 
panjgoori's Avatar
Posts: 1,206 | Thanked: 1,215 times | Joined on Aug 2011 @ Balochistan
#10
i know 2 packages which are stable but are still in Extras-Devel. 1. Filebox 2. Picodrive. both are stable and working flawlessly. will check more packages and report.
 
Reply

Tags
extras-testing, testing squad

Thread Tools

 
Forum Jump


All times are GMT. The time now is 10:11.