Notices


Reply
Thread Tools
proprog's Avatar
Posts: 36 | Thanked: 142 times | Joined on Jul 2012
#21
As a side effect of adding support for newer firmwares I now have one pebble classic that I'm not using. Send me a pm if you want it, no strings attached.
 

The Following 6 Users Say Thank You to proprog For This Useful Post:
Posts: 261 | Thanked: 347 times | Joined on Jan 2010 @ NYC
#22
Thank for the update! Does this bring any new functions to the n900 version?
 

The Following 3 Users Say Thank You to xman For This Useful Post:
Community Council | Posts: 529 | Thanked: 746 times | Joined on Sep 2010 @ Mbabane
#23
Originally Posted by proprog View Post
As a side effect of adding support for newer firmwares I now have one pebble classic that I'm not using. Send me a pm if you want it, no strings attached.
can't you upload here for the benefit of the community?
 

The Following 3 Users Say Thank You to sicelo For This Useful Post:
Posts: 261 | Thanked: 347 times | Joined on Jan 2010 @ NYC
#24
Just thought of it but if you getting rid of your pebble classic does this mean no more support for the classic in your software? You won;t have a testing device. Thanks.

x
 

The Following 3 Users Say Thank You to xman For This Useful Post:
proprog's Avatar
Posts: 36 | Thanked: 142 times | Joined on Jul 2012
#25
The pebble classic is gone and my main watch is a pebble time. But I've got a spare classic upgraded to v3 that I can use for testing.

To avoid confusion regarding support of newer firmwares I've updated the first post.
 

The Following 4 Users Say Thank You to proprog For This Useful Post:
Posts: 394 | Thanked: 503 times | Joined on Jan 2011 @ Brisbane, Australia
#26
Code:
!! Traceback (most recent call last):
!!   File "maebbled.py", line 913, in configure
    cfg.readfp(open(config_file, 'r'))
!! TypeError: coercing to Unicode: need string or buffer, bool found

could not read config file
!! Traceback (most recent call last):
!!   File "maebbled.py", line 925, in configure
    bt_address = cfg.get('btservice', 'address')
!!   File "/usr/lib/python2.5/ConfigParser.py", line 511, in get
    raise NoSectionError(section)
!! NoSectionError: No section: 'btservice'

find nearby devices
no device found
None
Any ideas?

EDIT::
Unicode thing was stopping it from opening the config file.


Code:
_send_message
C2:3A:79:20:0A:76
0.25
30.0
4
True
[]
connect
(112, 'Host is down')
connect
(77, 'File descriptor in bad state')
connect
(77, 'File descriptor in bad state')
connect
(77, 'File descriptor in bad state')
None
__________________
2016 - N900 todo list
  • Update Smartcam M5 (rewrite, client+server)
  • Simple Skype client (chat)
  • Translink Brisbane script (time to bus/train)
  • Commbank client (check balance)
  • Uber (basic client, request ride, etc)
 

The Following 3 Users Say Thank You to azkay For This Useful Post:
Posts: 1,076 | Thanked: 1,556 times | Joined on Jan 2011 @ Touring
#27
I think my main problem is in pairing, did anyone else have to do anything unusual to get and stay paired.
I tried wiping all of my pairs and rebooting, it made no dfference, when the "Pairing Complete" yellow notification on my N900 goes back up the 'Connected" under N900 on the watch goes away.
 

The Following User Says Thank You to biketool For This Useful Post:
Community Council | Posts: 529 | Thanked: 746 times | Joined on Sep 2010 @ Mbabane
#28
I've had an almost similar problem with Pairing my ThinkOutside Stowaway keyboard a few months back. Could be something buggy in N900's Bluetooth manager. I ended up using the python simple-agent script (I think it was the one mentioned at http://wiki.openmoko.org/wiki/Manual...ooth#Pairing_2)

I don't think I made any changes, and you can, of course, find the file in lots of other places, e.g. towards the end of http://developer.toradex.com/knowled...-use-bluetooth

Worth a try.
Attached Files
File Type: tar simple-agent.tar (5.0 KB, 17 views)

Last edited by sicelo; 2017-08-31 at 09:16.
 

The Following 2 Users Say Thank You to sicelo For This Useful Post:
Posts: 394 | Thanked: 503 times | Joined on Jan 2011 @ Brisbane, Australia
#29
Just reflashed- my N900 doesn't even see the Pebble in the bluetooth list
__________________
2016 - N900 todo list
  • Update Smartcam M5 (rewrite, client+server)
  • Simple Skype client (chat)
  • Translink Brisbane script (time to bus/train)
  • Commbank client (check balance)
  • Uber (basic client, request ride, etc)
 

The Following 2 Users Say Thank You to azkay For This Useful Post:
Posts: 394 | Thanked: 503 times | Joined on Jan 2011 @ Brisbane, Australia
#30
Originally Posted by sicelo View Post
I've had an almost similar problem with Pairing my ThinkOutside Stowaway keyboard a few months back. Could be something buggy in N900's Bluetooth manager. I ended up using the python simple-agent script (I think it was the one mentioned at http://wiki.openmoko.org/wiki/Manual...ooth#Pairing_2)

I don't think I made any changes, and you can, of course, find the file in lots of other places, e.g. towards the end of http://developer.toradex.com/knowled...-use-bluetooth

Worth a try.
Doesn't work on my side ):

Code:
Nokia-N900:~# ./simple-agent hci0 C2:3A:79:20:0A:76
Creating device failed: org.bluez.Error.ConnectionAttemptFailed: Page Timeout
N900 sees other bluetooth devices (other android phone, computer, etc) just not the pebble
__________________
2016 - N900 todo list
  • Update Smartcam M5 (rewrite, client+server)
  • Simple Skype client (chat)
  • Translink Brisbane script (time to bus/train)
  • Commbank client (check balance)
  • Uber (basic client, request ride, etc)
 

The Following 2 Users Say Thank You to azkay For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 16:09.