Notices


Reply
Thread Tools
Raimu's Avatar
Posts: 139 | Thanked: 181 times | Joined on Nov 2011 @ Oulu, Finland
#31
I'm trying out your compile of libc 2.10 as per your instructions, and everything works fine except some fcamera-reliant apps are suddenly spitting out glib errors and generally bombing out.

Could there be a correlation? I try not to talk out of my butt, but this seems like a high probability I'm not totally wrong.
 

The Following 2 Users Say Thank You to Raimu For This Useful Post:
Posts: 3,296 | Thanked: 4,325 times | Joined on May 2011 @ Poland
#32
Originally Posted by misiak View Post
There are some reported backwards compatibility breaking changes in eglibc (as reported in few other projects, e.g. http://us.generation-nt.com/answer/b...205129881.html and http://osdir.com/ml/debian-glibc/2012-11/msg00045.html ).

Taking that to consideration, together with the fact that Debian aims to provide backwards compatibility when possible, I have to ask one question which may sound silly Did you try to apply standard Debian patches (e.g. ones from http://packages.debian.org/pl/source/sid/eglibc , file eglibc_2.17-6.debian.tar.xz , directory debian/patches/arm) to the sources and then build and check the Calendar? AFAIK Maemo's eglibc was based on Debian's version, so I would suspect there might be (just might, I'm not saying that for sure) a little chance that, after aplying Debian's fancy patches, the new version will be binary compatible with the previous version. The plain eglibc is known to have ABI incompatibilities even between versions used in Fremantle (2.5) and Harmattan (2.10.1) (see http://linuxtesting.org/compatibilit...at_report.html , "libc.so.6" section and further details for more info).
Maybe some patches from Maemo 2.5 would need to be applied...
__________________
If you want to support my work, you can donate by PayPal or Flattr

Projects no longer actively developed: here
 

The Following 2 Users Say Thank You to marmistrz For This Useful Post:
Posts: 830 | Thanked: 3,356 times | Joined on Mar 2009
#33
Originally Posted by Raimu View Post
some fcamera-reliant apps are suddenly spitting out glib errors and generally bombing out.
Can you recompile them against libc-2.10-dev? Or libglib must be compiled against newer libc? I'm not sure, but I think that applying old maemo patches won't be the correct solution.
 

The Following 2 Users Say Thank You to AapoRantalainen For This Useful Post:
Posts: 3,296 | Thanked: 4,325 times | Joined on May 2011 @ Poland
#34
Originally Posted by AapoRantalainen View Post
\I'm not sure, but I think that applying old maemo patches won't be the correct solution.
The possibility is relatively low, I know. But it's always possible that one at-first-sight-redundant patch would do the trick.
__________________
If you want to support my work, you can donate by PayPal or Flattr

Projects no longer actively developed: here
 
Raimu's Avatar
Posts: 139 | Thanked: 181 times | Joined on Nov 2011 @ Oulu, Finland
#35
Originally Posted by AapoRantalainen View Post
Can you recompile them against libc-2.10-dev? Or libglib must be compiled against newer libc? I'm not sure, but I think that applying old maemo patches won't be the correct solution.
I wish I had a dev environ and some trust in my skills, but I honestly can't do compiling for the n900. I did confirm however that reverting to an older situation with the stock Maemo PR1.3 libc did fix all the apps that use the fcam-drivers package.
 

The Following 2 Users Say Thank You to Raimu For This Useful Post:
Posts: 3,035 | Thanked: 12,654 times | Joined on Mar 2010 @ Sofia,Bulgaria
#36
OK, it turned out that missing locales is a bug in gcc 4.7.2, at least for glibc2.5 . I will push the needed changes in glibc thumb-testing branch so won't explain the details here.

EDIT:

this https://gitorious.org/community-ssu/...ad0cf41410ae23
__________________
Never fear. I is here.

720p video support on N900,SmartReflex on N900,Keyboard and mouse support on N900
Nothing is impossible - Stable thumb2 on n900

Community SSU developer
kernel-power developer and maintainer


Last edited by freemangordon; 2014-01-19 at 09:21.
 

The Following 7 Users Say Thank You to freemangordon For This Useful Post:
Posts: 271 | Thanked: 622 times | Joined on Aug 2011 @ suncity
#37
Hi All!

May I kindly ask if anyone has the upgraded glibc deb packages...? Since the links in the first post are not working I'm trying to make a package from svn but some of the commands in STEP1 are not clear for me (e.g. how to get arm-asm-page-header.diff or how to have glibc-2.5.1 directory, etc...).

Thanks,

jm

Edit:// OK, found out things, trying to build it now... But already built packegages would be still useful and appreciated if building won't succeed...

Edit2:// Successfully build version 2.10.

Last edited by justmemory; 2018-02-02 at 13:01.
 
Posts: 49 | Thanked: 16 times | Joined on Feb 2011
#38
anyone can reupload libc6_2.10.90-maemo1_armel.deb


link is dead. i need it!!!
 
Posts: 271 | Thanked: 622 times | Joined on Aug 2011 @ suncity
#39
Originally Posted by EL_CID_CAMPEADOR View Post
anyone can reupload libc6_2.10.90-maemo1_armel.deb


link is dead. i need it!!!
Hmm... do you really need it...?

Since no links were added I built it from svn as it is described in the first comment. You can find it here if you REALLY need it. Use at your own risk...

Note that maybe backupmenu won't work (at least it is not working for me since I installed it).
 

The Following User Says Thank You to justmemory For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 14:21.