Notices


Reply
Thread Tools
tanago's Avatar
Posts: 212 | Thanked: 446 times | Joined on Aug 2012 @ Burgas, Bulgaria
#1
Here is what I am working on lately - making a faster web browser for our N900s because MicroB is really outdated. I'm building Mozilla Firefox browser for Maemo 5 (a.k.a. Fennec)

Important:This fennec works ONLY under CSSU-Thumb- if you dont have it I strongly recommend you to install it!

First there are a few releases of the Mozilla browser:
Release : The most stable version of the browser
Beta : The name speaks for itself
Aurora : This is pre-beta release - (alpha release)
Central : The least stable version of the browser
Of course 'instability' is relative and everything is tested multiple times before it was uploaded.

Current versions of those releases
Release : 19
Beta : 20
Aurora : 21
Central : 22


Download links:
  1. v17:QT
    Added 2013-03-19 00:07:01
    Rapidshare : https://rapidshare.com/files/9416860...17.0_armel.deb
  2. v17:QT+pixman
    Added 2013-03-23 13:36:25
    Rapidshare : https://rapidshare.com/files/2950585...17.0_armel.deb



I recommend:v17:QT+pixman


Side notes
  • In version 18 we have a serious scrolling problem and it's not suitable for everyday users. Right from that version(18) Mozilla introduced a new JIT engine
    Today we enabled IonMonkey, our newest JavaScript JIT, in Firefox 18. IonMonkey is a huge step forward for our JavaScript performance and our compiler architecture. But also, it’s been a highly focused, year-long project on behalf of the IonMonkey team, and we’re super excited to see it land.
    and I believe it is the problem causing that scroll bugs.
  • Version 19 doesnt launch at all for Maemo......................
  • Looks like because I'm building Fennec with thumb packages installation of non Thumb Fennec will still require CSSU-Thumb, so I cease building non Thumb Fennec-s
  • To enable flash support open Fennec, type the following adress
    about:config
    find 'plugin.disable'
    Click on 'false'
  • With some plugins installed Fennec startup is minimized for ~20 seconds, if you see that even after that delay Fennec hasnt started open /home/user/.mozilla/fennec/******.default/ and delete every file that starts with 'sessionstore'

Last edited by tanago; 2013-03-23 at 12:28.
 

The Following 37 Users Say Thank You to tanago For This Useful Post:
Posts: 802 | Thanked: 1,587 times | Joined on Feb 2010 @ Gdynia, Poland
#2
Downloaded 17 non-thumb, couldn't install, dpkg said it depends on qt packges in thumb versions

edit: however, on my second n900 with cssu-thumb, installation went smooth (well, there was a problem with pre-removal script from old version of fennec installed there, but that's not related to this version of package), however i didn't test yet, will post later if anything breaks.
 

The Following 3 Users Say Thank You to misiak For This Useful Post:
Posts: 154 | Thanked: 110 times | Joined on Aug 2011
#3
just curious, are you going to build anything with gstreamer support?
 

The Following 2 Users Say Thank You to marbleuser For This Useful Post:
Posts: 93 | Thanked: 18 times | Joined on Oct 2011 @ Coimbatore, India
#4
Thanks Tannago.

I installed fennec V17 yesterday. When I open it, it tries to open but it disappears. Reboot did not give a solution. I use KP51r1 & CSSU-Thumb.

Thanks in advance.
 

The Following 2 Users Say Thank You to bharathkumarst For This Useful Post:
Posts: 863 | Thanked: 213 times | Joined on Feb 2012 @ Goa
#5
Y Feneec's UI is Not Faster as Opera?
 

The Following 3 Users Say Thank You to seanmcken For This Useful Post:
tanago's Avatar
Posts: 212 | Thanked: 446 times | Joined on Aug 2012 @ Burgas, Bulgaria
#6
Originally Posted by misiak View Post
Downloaded 17 non-thumb, couldn't install, dpkg said it depends on qt packges in thumb versions

edit: however, on my second n900 with cssu-thumb, installation went smooth (well, there was a problem with pre-removal script from old version of fennec installed there, but that's not related to this version of package), however i didn't test yet, will post later if anything breaks.
The newer gcc & g++ require some cssu-thumb packages. That means that if I say the compiler to build for ARM, not for Thumb( just because of the fact it is build with Thumb packages) it will still require CSSU-Thumb....

That means that building for ARM with Thumb packages is useless I will build only Thumb versions from now on.

Originally Posted by marbleuser View Post
just curious, are you going to build anything with gstreamer support?
I'm still working on that because gstreamer has some problems under Maemo SDK, first it is an ancient version, second I have the source to upgrade but it it needs newer version of the ancient (too) glib2.20. The moment I find a newer glib(for X86! not for armel, I found for armel) I will build with gstreamer support

Originally Posted by bharathkumarst View Post
Thanks Tannago.

I installed fennec V17 yesterday. When I open it, it tries to open but it disappears. Reboot did not give a solution. I use KP51r1 & CSSU-Thumb.

Thanks in advance.
2 variants
First : With some plugins loaded( I tried adblock plus & Phony) Fennec takes 20 seconds to start.

If you haven't installed any plugins : Open /home/user/.mozilla/fennec/
delete everything in there, restart the phone and it must work.

Originally Posted by seanmcken View Post
Y Feneec's UI is Not Faster as Opera?
Here goes the difference between Mozilla and Opera. Mozilla abandoned Fennec for N900 when it was version 7 now we have 18....Opera doesnt abandon it's browsers like that, improves them, adds new features and fixes. In one word right now I'm doing the job for Mozilla and I can pretty much only change compiler flags to improve the browser I dont know it's source...it's big.

I don't know about you but I like that Fennec- it's reliable and fast & the most important thing is flash support that is missing in opera

Last edited by tanago; 2013-01-16 at 08:50.
 

The Following 6 Users Say Thank You to tanago For This Useful Post:
pichlo's Avatar
Posts: 5,326 | Thanked: 16,238 times | Joined on Sep 2012 @ UK
#7
Originally Posted by tanago View Post
Here is the v17 Release build
I get this for both links:

Download not available
Download permission denied by uploader. (0b67c2f5)
 

The Following 3 Users Say Thank You to pichlo For This Useful Post:
Posts: 802 | Thanked: 1,587 times | Joined on Feb 2010 @ Gdynia, Poland
#8
Originally Posted by tanago View Post
The newer gcc & g++ require some cssu-thumb packages. That means that if I say the compiler to build for ARM, not for Thumb( just because of the fact it is build with Thumb packages) it will still require CSSU-Thumb....

That means that building for ARM with Thumb packages is useless I will build only Thumb versions from now on.
Could you publish source packages or/and exact procedure how you managed to build that (including build options - compiler switches, etc.)? I would love to try to build that for non-thumb.
 

The Following 3 Users Say Thank You to misiak For This Useful Post:
tanago's Avatar
Posts: 212 | Thanked: 446 times | Joined on Aug 2012 @ Burgas, Bulgaria
#9
!!!Newer build uploaded!!! With more fixes and 5-10% speed improvement. - look at the first post

!!!Since building for non-thumb with thumb libraries is pointless I will provide only CSSU-Thumb builds from now on

Originally Posted by pichlo View Post
I get this for both links:

Download not available
Download permission denied by uploader. (0b67c2f5)
For you I created a Mediafire mirror - look at the first post

Originally Posted by misiak View Post
Could you publish source packages or/and exact procedure how you managed to build that (including build options - compiler switches, etc.)? I would love to try to build that for non-thumb.
First you need to create a new Scratchbox environment with newer gcc/g++ : http://wiki.maemo.org/CSSU-thumb_too....7.2-linaro%29

!!! If you want to build for non-thumb you WILL want to skip the step with adding CSSU-Thumb repos. I havent tried it, so I dont guarantee anything

At some time you may see an error about libfakeroot, issue:
Code:
dpkg -i /scratchbox/compilers/linaro-4.7-2012.07-fremantle-armv7a/packages/libfakeroot_1.14.4-0+sb1_armel.deb
Then you must download sources, make mozconfig file( contains compiling instructions) and build.

Last edited by tanago; 2013-01-16 at 23:19.
 

The Following 4 Users Say Thank You to tanago For This Useful Post:
Posts: 802 | Thanked: 1,587 times | Joined on Feb 2010 @ Gdynia, Poland
#10
Originally Posted by tanago View Post
First you need to create a new Scratchbox environment with newer gcc/g++ : http://wiki.maemo.org/CSSU-thumb_too....7.2-linaro%29

!!! If you want to build for non-thumb you WILL want to skip the step with adding CSSU-Thumb repos. I havent tried it, so I dont guarantee anything

At some time you may see an error about libfakeroot, issue:
Code:
dpkg -i /scratchbox/compilers/linaro-4.7-2012.07-fremantle-armv7a/packages/libfakeroot_1.14.4-0+sb1_armel.deb
Then you must download sources, make mozconfig file( contains compiling instructions) and build.
That's exactly what I wanted to do - create new target in scratchbox or destroy my current thumb target I was just curious if you passed some special configuration options or just used the default maemo config
 

The Following User Says Thank You to misiak For This Useful Post:
Reply

Tags
cssu thumb2, fennec

Thread Tools

 
Forum Jump


All times are GMT. The time now is 20:45.