Notices


Reply
Thread Tools
Posts: 574 | Thanked: 645 times | Joined on Mar 2011 @ Nantes, France
#2331
Hello,
I've taken the time to do a factory reset of my J1 and patiently update it back to 2.1.1.26.

Via Storeman, I can install some things, but not PatchManager 2.0, the error message I get is:

File'.core/armv7hl/patch-2.6.1-1.1.3.armv7hl.rpm not found on medium 'https://releases.jolla.com/releases/2.1.1.26/jolla/armv7hl'
This is totally cryptic to me. And I guess this is the best place to ask for help. Help.
 

The Following User Says Thank You to romu For This Useful Post:
olf's Avatar
Posts: 47 | Thanked: 124 times | Joined on Aug 2015
#2332
@romu, I did not intend to be overly harsh, stating "please search first, ask then", so I am glad to hear ...

Originally Posted by romu View Post
I've taken the time to do a factory reset of my J1 and patiently update it back to 2.1.1.26.
... that you successfully executed a factory reset and carried out the tedious procedure of updating SailfishOS through all its "stop releases" to its recent version.

Just for the records / your understanding: It was most likely (when you originally updated to SFOS 2.1.1.26, before the factory reset) the fact that you did not unapply all patches before updating SFOS, which caused the effects you experienced back then. Well, I considered this to be obvious; now I understand, that it was not to you, despite all the warnings in many places, e.g. each and every (!) SailfishOS release note.

Originally Posted by romu View Post
Via Storeman, I can install some things, but not PatchManager 2.0, the error message I get is:
File '.core/armv7hl/patch-2.6.1-1.1.3.armv7hl.rpm' not found on medium 'https://releases.jolla.com/releases/2.1.1.26/jolla/armv7hl'
This is totally cryptic to me.
As I can see (via pckon search name patch) having patch-2.7.5+git1-1.3.1.armv7hl installed under SFOS 2.1.1.26 on my devices, on your Jolla 1 phone pkcon / rpm (triggered by Storeman) is looking for a old version of the Unix patch utility.

Please try:
  1. Enable Settings --> Developer tools --> Developer mode and set a root password of your choice there (you may need root access later).
  2. Open a terminal window and enter pkcon refresh
  3. Then start Storeman and try to install Patchmanager2, again.
As a general remark: Storeman is really nice, capable and quick, but quite "young", so you may also install the old, a bit clumsy and slow Warehouse (by basil) as an alternative application for accessing Openrepos.net (you can install it via Storeman), so you can check that this is not Storeman's fault. Just do not use them concurrently.

Originally Posted by romu View Post
And I guess this is the best place to ask for help. Help.
Yes, it is: HTH

Last edited by olf; 2017-09-27 at 20:28.
 

The Following 2 Users Say Thank You to olf For This Useful Post:
Posts: 574 | Thanked: 645 times | Joined on Mar 2011 @ Nantes, France
#2333
No problem @olf. Life can be complicated and our brain are full. In such cases, I can be lazy and ask...it's easier than searching I confess.

Thanks a lot for the help. Eveything is fine, I'm in love with SFOS again, OMG! It's a shame the photo quality is so bad, because I use it a lot in my work. I can't wait for SFOS on my X Compact!!
 
coderus's Avatar
Posts: 6,063 | Thanked: 11,221 times | Joined on Nov 2011 @ Open Mobile Platform, Innopolis, Russia
#2334
Originally Posted by romu View Post
Hello,
I've taken the time to do a factory reset of my J1 and patiently update it back to 2.1.1.26.

Via Storeman, I can install some things, but not PatchManager 2.0, the error message I get is:



This is totally cryptic to me. And I guess this is the best place to ask for help. Help.
Code:
pkcon refresh
__________________
Twitter | Openrepos | GitHub | PayPal.Me
 

The Following User Says Thank You to coderus For This Useful Post:
Posts: 10 | Thanked: 4 times | Joined on Oct 2017 @ Lyon (France)
#2335
Hi all,
I'm facing something not usual for me.
During my last OS update, the "unapply all patches" process failed with the "Upcoming events on lockscreen" patch, but the update was a success.
It was in july with the 2.1.1.23.
Now, I want to update to 2.1.2.3 but the update fails when it tries to unapply the same patch.

I remove the patch with the command line
Code:
devel-su rpm -e upcoming-lockscreen --noscripts
Now storeman and warehouse tells me that the patch is removed.
but, it is still visible in patchmanager, and the update process still fails.

PS : like an idiot, I disable the developer mode, and now, I cannot reactivate it (can't find the jolla-developper-mode app in harbor). This is a know issue, and solution exists, but I prefere doing the update before solve it.

Thanks for your help.
 
olf's Avatar
Posts: 47 | Thanked: 124 times | Joined on Aug 2015
#2336
Originally Posted by vbelloir View Post
[...] PS : like an idiot, I disable the developer mode, and now, I cannot reactivate it (can't find the jolla-developper-mode app in harbor). [...]
Look for it with pkcon search name jolla-developer-mode
As long as you have Warehouse installed, you can still reinstall it as a non-root user via pkcon install jolla-developer-mode jolla-developer-mode-profile

Although it sounds as if you damaged Lipstick, so you may try to reinstall that afterwards, or directly go for a Factory Reset.
 
Posts: 74 | Thanked: 94 times | Joined on Jan 2012
#2337
Originally Posted by vbelloir View Post
Hi all,
I'm facing something not usual for me.
During my last OS update, the "unapply all patches" process failed with the "Upcoming events on lockscreen" patch, but the update was a success.
It was in july with the 2.1.1.23.
Now, I want to update to 2.1.2.3 but the update fails when it tries to unapply the same patch.

I remove the patch with the command line
Code:
devel-su rpm -e upcoming-lockscreen --noscripts
Now storeman and warehouse tells me that the patch is removed.
but, it is still visible in patchmanager, and the update process still fails.

PS : like an idiot, I disable the developer mode, and now, I cannot reactivate it (can't find the jolla-developper-mode app in harbor). This is a know issue, and solution exists, but I prefere doing the update before solve it.

Thanks for your help.
Once you get developer mode back a few things to try:

patch -R -p 1 -d / -i /var/lib/patchmanager/ausmt/patches/lockscreen-upcoming/unified_diff.patch

and skip already unapplied entries. Then:
1) Unapply all lockscreen related patches in Patchmanager but do not restart preloaded services.
2) In /usr/share/lipstick-jolla-home-qt5/lockscreen if it exists copy Lockscreen.qml.webosinternals.org to Lockscreen.qml. Check Lockscreen.qml doesn't have the lines from the patch (http://talk.maemo.org/showpost.php?p...postcount=1452)
3) In /usr/share/lipstick-jolla-home-qt5/lockscreen/ remove ShowCalEvents.qml, BorderRectangle.qml, LockEventItem.qml and LockTimeLabel.qml if they are there.
4) Remove any file ending in .webosinternals.orig

Hopefully should be fine after that. Otherwise you can reinstall lipstick with
pkcon install lipstick-jolla-home-qt5
 

The Following User Says Thank You to anig For This Useful Post:
Posts: 10 | Thanked: 4 times | Joined on Oct 2017 @ Lyon (France)
#2338
@olf, anig : I solved my firmware update issue with that thread, so now I will start working on removing this patch.

Vincent
 
Posts: 10 | Thanked: 4 times | Joined on Oct 2017 @ Lyon (France)
#2339
OK, I managed to reinstall lipstick, and remove the patch in patchmanager.

Solved for me.
Thanks for your help.
 
Reply

Tags
patchmanager, sailfish os

Thread Tools

 
Forum Jump


All times are GMT. The time now is 16:43.