Notices


Reply
Thread Tools
Posts: 3 | Thanked: 0 times | Joined on Jan 2010 @ Grimsby, UK
#1
hey
im having a problem with trying to access the browser on my n810, was working fine up until the other day when it crashed while i was briowsing the web, now everytime i try to open the browser it just opens and says 'updating' in the top right corner. that stays there for around 4 mins then the browser just closes.
i can still use the pidgin messenger and internet radio etc so im still connected its just the browser thats the problem?? i'm not over knowledgable with these linux based system so i havent done anything to ruin it ( that i know of lol ) and havent changed any settings or installed any new applications
ive tried to find answers to this problem but cant seem to get anything anywhere
hope someone can help
cheers
 
Posts: 1,950 | Thanked: 1,170 times | Joined on Jan 2008 @ Seattle, USA
#2
I don't know how to fix your problem specifically. But you know about flashing the device, yes? Or you could try installing the tear browser and using just that.

http://talk.maemo.org/showthread.php...owser+would-be
__________________
.
. .

Help Save This Forum
for N8x0/Diablo Users! Register and Vote for Solution #1 on this Brainstorm. (The Solution will let you see New Posts with any threads you choose -- like the N900 and Maemo5/Fremantle threads -- filtered out.) (To understand the Solution better, see these posts #17, #18, and #19.)
 
Posts: 1,101 | Thanked: 1,183 times | Joined on Aug 2008 @ Spain
#3
That happens because the browserd process has died.
Two possible fixes:
1 Easy: reboot the tablet
2 No so easy but not hard: open a xterm, become root, restart the browserd process with the command "/etc/init.d/tablet-browser-daemon start"
You can always check that the process is running by typing
ps ax|grep browserd
 
luca's Avatar
Posts: 1,137 | Thanked: 402 times | Joined on Sep 2007 @ Catalunya
#4
Or install tear and get rid of the browserd nonsense
 
heavyt's Avatar
Posts: 708 | Thanked: 125 times | Joined on Jan 2007 @ Too Close To D.C
#5
Originally Posted by dudeofrude View Post
hey
im having a problem with trying to access the browser on my n810, was working fine up until the other day when it crashed while i was briowsing the web, now everytime i try to open the browser it just opens and says 'updating' in the top right corner. that stays there for around 4 mins then the browser just closes.
i can still use the pidgin messenger and internet radio etc so im still connected its just the browser thats the problem?? i'm not over knowledgable with these linux based system so i havent done anything to ruin it ( that i know of lol ) and havent changed any settings or installed any new applications
ive tried to find answers to this problem but cant seem to get anything anywhere
hope someone can help
cheers
Turn off your N810 then back on.
 
xopher_mc's Avatar
Posts: 86 | Thanked: 9 times | Joined on Jan 2008 @ Berlin, Germany
#6
I have this problem too and the best way I've found is to restart the browser daemon.
 
Posts: 3 | Thanked: 0 times | Joined on Jan 2010 @ Grimsby, UK
#7
thanks guys but turning it off dosent change anything it still does its, i dont mean to sound thick but how do i restart the browser process??? like i said im not too good with these linux systems, if it were windows id be well away lol
 
MicroChip123's Avatar
Posts: 78 | Thanked: 10 times | Joined on Apr 2008 @ England
#8
1. Install rootsh (http://maemo.org/downloads/product/OS2008/rootsh/)
2. open xterm
3. copy paste this script

Code:
sudo gainroot
/etc/init.d/tablet-browser-daemon stop
/etc/init.d/tablet-browser-daemon start
#
#
if that fails
reflash
__________________
N810
OS2008
8GB Memory Card

Last edited by MicroChip123; 2010-01-07 at 18:21.
 
Posts: 3 | Thanked: 0 times | Joined on Jan 2010 @ Grimsby, UK
#9
thanks for help guys but i just tried the restart in xterm and got this

starting browser daemon: start-stop-daemon:unable
to set initgroups() with gid 29999 (operation not permitted)
browserd

any further advice would be great
cheers
 
MicroChip123's Avatar
Posts: 78 | Thanked: 10 times | Joined on Apr 2008 @ England
#10
backup and reflash.
__________________
N810
OS2008
8GB Memory Card
 
Reply

Tags
maemo, maemo 4, maemo browser, microb, os2008, problem, web browser

Thread Tools

 
Forum Jump


All times are GMT. The time now is 01:52.