Notices


Reply
Thread Tools
Posts: 17 | Thanked: 8 times | Joined on Mar 2010
#321
Its been a while since I last tried out Sailfish, and its been working great with this CM13 build, so first of all thanks for taking the time to provide this mautz!

Anyone else try out the most recent Sailfish releases? I've been able to update the phone with the terminal commands ssu re 2.1.4.14 and then version --dup after pkcon refresh. I've tried out 2.1.4.13, .14, .15. I don't have my sim in the phone, but bluetooth seems to be the only thing that isn't working correctly so far(at least for my limited needs)...again I haven't put a sim in my Nexus yet though so cell connectivity could be broken for all i know. It connects via bluetooth no problem(I think?), for instance my headphones look like they're synced up and the phone shows connected but all audio still plays through the external speaker. This happened on every one of the 2.1.4.xx releases I tried. Anyone have an idea why this would happen? I've read a bit about pulse audio crapping out, so I tried some suggestions on deleting the config folder (PS, I'm not really sure what I'm doing with half of this stuff) but alas it was no help. Just seeing if anyone else has had any issues.

I was able to get 2.2.0.29 to download and install a few times on a fresh install of 2.1.3.7, but it never got past the google logo to boot up. Oh well. I tried the version --dup in 2.1.4.14 but keep getting a pattern error after it refreshes.

All around, I've been having a blast with it, and will be giving this an honest shot with my sim for a week or two. It does everything I can ask of a phone to do really.
 

The Following 4 Users Say Thank You to HelloEverybody For This Useful Post:
Posts: 2 | Thanked: 5 times | Joined on Oct 2016
#322
Hello.

I did clean install CM 13.
Then SF OS 2.1.3.7.
Normal ROM.

I didn't install any patches or apps.
I did OTA upgrade to 2.1.4.14 and then 2.1.4.15 without problems.

I tried 2.2.0.29.
It says: Error: nothing provides pattern:jolla-sailfish-applications needed by pattern:jolla-configuration-hammerhead-0.0.25-10.30.4.jolla.noarch.

I'm probably dummy, what I'm doing wrong?
 

The Following 4 Users Say Thank You to flanker For This Useful Post:
Posts: 17 | Thanked: 8 times | Joined on Mar 2010
#323
flanker,

I'm having the same issue, and I'm probably a dummy too...I haven't had much time to mess with it lately, but would love to know if there is a way to update to 2.2.0.29. Were you able to get audio through Bluetooth working on 2.1.4.14, or 2.1.4.15?
 

The Following 2 Users Say Thank You to HelloEverybody For This Useful Post:
Posts: 424 | Thanked: 1,157 times | Joined on Feb 2014 @ Germany
#324
Hi, i think that i have to rebuild the hammerhead packages, but i am very busy at the moment. I hope to get the problems sorted out next month. I'll post an update here...
 

The Following 11 Users Say Thank You to mautz For This Useful Post:
Posts: 61 | Thanked: 112 times | Joined on Jul 2010
#325
Hi everybody,

So, I finally took the plunge and installed the new CM13 based SFOS. Just like flanker in #322 I ota'ed to 2.1.4.14 and straight on to 2.1.4.15.

What is missing now is the sensors. AIDA64 only shows values for the Magnetometer and the Rotation Sensor, i.e. the important ones are missing (Proximity etc.).

I reflashed sensorsfix3.zip, but that did not change anything. No luck with "devel-su systemctl restart sensorfwd", either.

Is there anything I can do now?

P.S. I came across another showstopper for me. While the phone happily connected to my bluetooth speaker (A2DP), it still plays the sound through the phone's speakers. I tried it with the Media Player and Talefish (multiple bluetooth reconnects). 90% of what I do with the Nexus is playing podcasts through the A2DP speakers in my car.

Last edited by dubliner; 2018-09-03 at 23:22. Reason: New problem added
 

The Following 3 Users Say Thank You to dubliner For This Useful Post:
Posts: 424 | Thanked: 1,157 times | Joined on Feb 2014 @ Germany
#326
Does 'devel-su systemctl stop bt-sleep-monitor.service' help?
 

The Following 3 Users Say Thank You to mautz For This Useful Post:
Posts: 61 | Thanked: 112 times | Joined on Jul 2010
#327
Thanks so much for your prompt reply, Mautz. It is appreciated (as always).

Well, eventually, I couldn't sleep last night, so I decided to retrace my steps and re-installed your 2.1.3.7 image - no ota'ing at all this time. And look and behold, everything seems to be working just fine.

Now I am in the process of setting everything up. So far, things have been going remarkably smoothly. So, I guess, I'll just wait for your 2.2.x image.

Thanks a million for all the help!!!

On a different note, since xt9 isn't working, I was wondering what are you guys using for word predictions (especially for English and German)?
 

The Following 3 Users Say Thank You to dubliner For This Useful Post:
Posts: 642 | Thanked: 3,378 times | Joined on Aug 2016 @ Estonia
#328
Originally Posted by dubliner View Post
On a different note, since xt9 isn't working, I was wondering what are you guys using for word predictions (especially for English and German)?
We wrote predictive keyboard for obscure languages or ported devices. English is available at https://openrepos.net/content/sailfi...ext-prediction , will install all dependencies.

German is not in the list yet [https://openrepos.net/user/12231/programs] , but you are welcome to make the corresponding databases. Packaging instructions at https://github.com/sailfish-keyboard/presage
 

The Following 5 Users Say Thank You to rinigus For This Useful Post:
Posts: 424 | Thanked: 1,157 times | Joined on Feb 2014 @ Germany
#329
I did a german dictionary for Okboard, both is on Openrepos. If you own a original Jolla device, you can just copy the xt9 rpm to tge Nexus5 and install it.
 

The Following 4 Users Say Thank You to mautz For This Useful Post:
Posts: 61 | Thanked: 112 times | Joined on Jul 2010
#330
@rinigus and @mautz, a hugh thank you to both of you. So, I installed OKBoard as mautz suggested and it's quite a revelation. As for presage, I read the packaging instructions and it's quite fascinating. Yet, I have a feeling this process might be beyond my abilities (for now).

Could I just bring up a few things I noticed? Maybe someone could help me with some of these, which would be highly appreciated.

1) When I connected the previous incarnation of the phone (Nexus5/CM12/SFOS2.0) to the car's "multi media system", the phone would normally send the address book automatically. Now (CM13/SFOS2.1.3.7) I get a "device connected - transfer failed" instead. No big deal, since I can always send the vcf file manually (BTW, A2DP audio works flawlessly, though). Which brings me to...

2) I am sure there used to be a "share" option in the file manager (to share via bluetooth or email). I cannot seem to find that anywhere. Any suggestions how to get it back would be appreciated.

3) When I used to type a text message, I got a counter giving me the number of characters left for that text/SMS. That seems to be gone. Is there are way to retrieve it?

4) Upon opening the case, the phone used to come to life (display lit up faintly), so I could double tap it to wake it up. Now, there is no reaction to opening the case, thus, I have to press the power button. No huge problem, but maybe it's just a setting. So, I thought I'd ask.

[5)] As for the broken audio on bluetooth phone calls, someone suggested to me that this sounded like an "endian" problem. Unfortunately, I couldn't get any further information. Has anyone looked into this issue?

Sorry, this ended up being rather a lot.
 

The Following 2 Users Say Thank You to dubliner For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 19:59.