Notices


Reply
Thread Tools
Posts: 60 | Thanked: 23 times | Joined on Jan 2010
#1
I followed the following tutorial:
http://wiki.forum.nokia.com/index.ph...in_Maemo_5_SDK
and I get these errors when I run make:

[sbox-FREMANTLE_X86: ~/pro/textedit] > make
g++ -c -pipe -g -g -O0 -Wall -W -D_REENTRANT -DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED -I/targets/FREMANTLE_X86/usr/share/qt4/mkspecs/linux-g++-opengl -I. -I/targets/FREMANTLE_X86/usr/include/qt4/QtCore -I/targets/FREMANTLE_X86/usr/include/qt4/QtGui -I/targets/FREMANTLE_X86/usr/include/qt4 -I. -o textedit.o textedit.cpp
textedit.cpp: In constructor 'TextEdit::TextEdit(QWidget*)':
textedit.cpp:78: error: 'ToolButtonFollowStyle' is not a member of 'Qt'
textedit.cpp: In member function 'void TextEdit::setupFileActions()':
textedit.cpp:163: error: 'fromTheme' is not a member of 'QIcon'
textedit.cpp:165: error: 'class QAction' has no member named 'setPriority'
textedit.cpp:165: error: 'LowPriority' is not a member of 'QAction'
textedit.cpp:171: error: 'fromTheme' is not a member of 'QIcon'
textedit.cpp:180: error: 'fromTheme' is not a member of 'QIcon'
textedit.cpp:189: error: 'class QAction' has no member named 'setPriority'
textedit.cpp:189: error: 'LowPriority' is not a member of 'QAction'
textedit.cpp: In member function 'void TextEdit::setupEditActions()':
textedit.cpp:234: error: 'fromTheme' is not a member of 'QIcon'
textedit.cpp:239: error: 'fromTheme' is not a member of 'QIcon'
textedit.cpp:241: error: 'class QAction' has no member named 'setPriority'
textedit.cpp:241: error: 'LowPriority' is not a member of 'QAction'
textedit.cpp:246: error: 'fromTheme' is not a member of 'QIcon'
textedit.cpp:248: error: 'class QAction' has no member named 'setPriority'
textedit.cpp:248: error: 'LowPriority' is not a member of 'QAction'
textedit.cpp:252: error: 'fromTheme' is not a member of 'QIcon'
textedit.cpp:254: error: 'class QAction' has no member named 'setPriority'
textedit.cpp:254: error: 'LowPriority' is not a member of 'QAction'
textedit.cpp:258: error: 'fromTheme' is not a member of 'QIcon'
textedit.cpp:260: error: 'class QAction' has no member named 'setPriority'
textedit.cpp:260: error: 'LowPriority' is not a member of 'QAction'
textedit.cpp: In member function 'void TextEdit::setupTextActions()':
textedit.cpp:278: error: 'fromTheme' is not a member of 'QIcon'
textedit.cpp:281: error: 'class QAction' has no member named 'setPriority'
textedit.cpp:281: error: 'LowPriority' is not a member of 'QAction'
textedit.cpp:290: error: 'fromTheme' is not a member of 'QIcon'
textedit.cpp:292: error: 'class QAction' has no member named 'setPriority'
textedit.cpp:292: error: 'LowPriority' is not a member of 'QAction'
textedit.cpp:302: error: 'fromTheme' is not a member of 'QIcon'
textedit.cpp:305: error: 'class QAction' has no member named 'setPriority'
textedit.cpp:305: error: 'LowPriority' is not a member of 'QAction'
textedit.cpp:321: error: 'fromTheme' is not a member of 'QIcon'
textedit.cpp:323: error: 'fromTheme' is not a member of 'QIcon'
textedit.cpp:324: error: 'fromTheme' is not a member of 'QIcon'
textedit.cpp:326: error: 'fromTheme' is not a member of 'QIcon'
textedit.cpp:327: error: 'fromTheme' is not a member of 'QIcon'
textedit.cpp:328: error: 'fromTheme' is not a member of 'QIcon'
textedit.cpp:330: error: 'fromTheme' is not a member of 'QIcon'
textedit.cpp:334: error: 'class QAction' has no member named 'setPriority'
textedit.cpp:334: error: 'LowPriority' is not a member of 'QAction'
textedit.cpp:337: error: 'class QAction' has no member named 'setPriority'
textedit.cpp:337: error: 'LowPriority' is not a member of 'QAction'
textedit.cpp:340: error: 'class QAction' has no member named 'setPriority'
textedit.cpp:340: error: 'LowPriority' is not a member of 'QAction'
textedit.cpp:343: error: 'class QAction' has no member named 'setPriority'
textedit.cpp:343: error: 'LowPriority' is not a member of 'QAction'
textedit.cpp: In member function 'void TextEdit::textStyle(int)':
textedit.cpp:613: error: 'ListLowerRoman' is not a member of 'QTextListFormat'
textedit.cpp:616: error: 'ListUpperRoman' is not a member of 'QTextListFormat'
make: *** [textedit.o] Error 1

What is wrong ? Please help.
 
Posts: 16 | Thanked: 11 times | Joined on Dec 2009
#2
The stuff that's missing seems to be from Qt 4.6

You propably have Qt 4.5 installed. The Qt packages prefixed with
libqt4-maemo5 (libqt-maemo5-dev etc...) should work with the code.
 

The Following User Says Thank You to rkm For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 14:04.