Active Topics

 



Notices


Reply
Thread Tools
Posts: 16 | Thanked: 3 times | Joined on Oct 2012 @ UK
#1
As the email client gets frozen for a minute or longer each time I switch to it, it was necessary to remove old emails. Cache was just to large so I all the files from: /home/user/.qmf/mail

However all the ancient emails from a few years back got redownloaded. Can this be avoided anyhow?

Syncing is done via google account.
 
pichlo's Avatar
Posts: 5,651 | Thanked: 17,620 times | Joined on Sep 2012 @ UK
#2
I do not have a (working) N9 to test so this may be a BS but the first thing I would try if I had that problem would be moving old emails to a dedicated folder. I assume you have tried that already though as that seems such an obvious thing.
 

The Following User Says Thank You to pichlo For This Useful Post:
Posts: 90 | Thanked: 38 times | Joined on Jan 2014
#3
Just an opinion:

Delete everything, then create account again

In Accounts >> mail >> At downloads select>>> headers only

log in, sync, then change back from <<<headers only>> to <<full messages.>>
 

The Following User Says Thank You to youFailed For This Useful Post:
Posts: 16 | Thanked: 3 times | Joined on Oct 2012 @ UK
#4
Originally Posted by pichlo View Post
I do not have a (working) N9 to test so this may be a BS but the first thing I would try if I had that problem would be moving old emails to a dedicated folder. I assume you have tried that already though as that seems such an obvious thing.
Do you mean imap folder on the server? I would prefer avoid doing so. If you mean folder on the device, I already deleted all the emails from it but they got re-downloaded.

BTW. does google account on Nokia N9 use pop or imap for syncing? There are some options in gmail settings which may be handy for solving this issue.

Originally Posted by youFailed View Post
Just an opinion:

Delete everything, then create account again

In Accounts >> mail >> At downloads select>>> headers only

log in, sync, then change back from <<<headers only>> to <<full messages.>>
Well, this certainly would help for the app data space consumption on the device. But I already solved that with symlinking /home/user/.qmf/mail -> /home/user/MyDocs/.mail which is on the other, much bigger partition (BTW. default partition sizes for 64GB N9 is a joke).

However the vast amount of emails loaded into the mail app makes it unbearable slow. Each time I switch to it freezes for 30 sec, then asks would I like to kill the process, then after another 30 sec unfreezes. Searching is even 'better', type one letter, wait a minute, type another one, wait a minute, and so on...
 
pichlo's Avatar
Posts: 5,651 | Thanked: 17,620 times | Joined on Sep 2012 @ UK
#5
Originally Posted by tamashumi View Post
Do you mean imap folder on the server?
Yes. With the "I have not tested it" caveat.

If you have so many emails that they cause problems then deleting them or at least organizing them into folders is the best way forward anyway, IMO. If you don't want to do that, well...
 
Posts: 16 | Thanked: 3 times | Joined on Oct 2012 @ UK
#6
I may consider that but it would take a lot of time as there are years of emails. Besides gmail is a good email archive. I keep referring back to old email messages with their pretty accurate search feature. Obviously it may be done in other folder as well but then I would often need to search twice (inbox then archive) and keep maintaining the inbox-to-archive moving of emails which are getting old.

Those are all efforts which seems to me like avoidable and unnecessary. I've found in gmail settings that imap folder sync can be limited to 1000 emails. I'll wipe out emails on the N9 and try to sync again with this limit enabled. We'll see does it help.
 
Reply

Tags
email, google, synchronization

Thread Tools

 
Forum Jump


All times are GMT. The time now is 14:56.