Active Topics

 



Notices


Reply
Thread Tools
Posts: 2 | Thanked: 1 time | Joined on Nov 2011
#1
I just got N9 and like the style of the phone and OS. I used Straight Talk pre-paid $45 unlimited Plan and was succesfully able to manually set the Internet APN settings under
Settings -> Internet connection -> Edit networks where it showed AT&T Internet by default on detecting my Straight Talk SIM. I edit that to "Straight Talk Internet" with APN value to att.mvno. I cleared the username and password to blank values and now my mobile Internet works.

I have two questions. First, in the status bar I don't see 3G, instead I see 2.5. Second, my MMS doesn't work as I didn't find way to add second APN which has different settings for Straight Talk.

Any help appreciated on where to add second APN for MMS and also if I am connect to EDGE or 3G.

[Updated]
I figured it finally.

MMS settings can be editing from Settings -> Applications -> Messages -> "Multimedia message center" and choose "User defined" with following settings:

APN: att.mvno
Username:
Password:
MMSC: http://mmsc.cingular.com
MMS Proxy: proxy.mvno.tracfone.com
MMS port: 80

Last edited by kitsVA; 2011-11-04 at 09:07. Reason: update
 

The Following User Says Thank You to kitsVA For This Useful Post:
Posts: 2 | Thanked: 1 time | Joined on Nov 2011
#2
I figured it finally.

MMS settings can be editing from Settings -> Applications -> Messages -> "Multimedia message center" and choose "User defined" with following settings:

APN: att.mvno
Username:
Password:
MMSC: http://mmsc.cingular.com
MMS Proxy: proxy.mvno.tracfone.com
MMS port: 80
 
Posts: 153 | Thanked: 81 times | Joined on Oct 2011 @ New Zealand
#3
Not sure if you figured the 3G 2G part or not so.....

To get it off 2.5, go to
settings -> mobile network -> network mode and change from there.

You have dual, 2G only or 3G only, I personally have my phones set to 3G only as 2G is ancient tech, internet 3G vs 2G is like broadband vs dial up.
Battery standby does benefit from 2G mind you.

Try choosing between 2G 3G on iOS or Android, you cant.
 
Posts: 78 | Thanked: 10 times | Joined on Sep 2010
#4
I got my MMS now.
 
Posts: 1 | Thanked: 0 times | Joined on Feb 2018
#5
Originally Posted by HanzBlix View Post
Not sure if you figured the 3G 2G part or not so.....

To get it off 2.5, go to
settings -> mobile network -> network mode and change from there.

You have dual, 2G only or 3G only, I personally have my phones set to 3G only as 2G is ancient tech, internet 3G vs 2G is like broadband vs dial up.
Battery standby does benefit from 2G mind you.

Try choosing between 2G 3G on iOS or Android, you cant.
This one is working for me.

To start with, there are two Official versions of the Straight talk apn settings, one for those using Straight Talk AT&T service and another for those folks on the Straight Talk T-Mobile service. I have mentioned the AT&T service settings below, you can check out the Straight talk apn settings for T-mobile on the reference too.

Straight Talk AT&T service

If you are using AT&T as service provider, then please use the following values:

Name: straight talk
APN: tfdata
MMSC: http://mms-tf.net
MMS proxy: mms3.tracfone.com
MMS port: 80
MCC: 310
MNC: 410

You donít need to setup a username nor password.

Reference: - https://www.techwhoop.com/update-str...-phone-signal/
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 21:02.