Active Topics

 



Notices


Reply
Thread Tools
Posts: 34 | Thanked: 15 times | Joined on Jan 2010
#21
Hi paulkoan, this is my dmesg output:

'*/ AWUS036H USB plugged and enumerated with h-e-n (high Speed hostmode)
[130299.919769] twl4030_usb twl4030_usb: HW_CONDITIONS 0xd0/208; link 2
[130302.114288] usb usb1: usb resume
[130302.137756] hub 1-0:1.0: hub_resume
[130302.137878] hub 1-0:1.0: port 1: status 0101 change 0001
[130302.247222] hub 1-0:1.0: state 7 ports 1 chg 0002 evt 0000
[130302.247344] hub 1-0:1.0: port 1, status 0101, change 0000, 12 Mb/s
[130302.372222] usb 1-1: new high speed USB device using musb_hdrc and address 22
[130302.522460] usb 1-1: default language 0x0409
[130302.529754] usb 1-1: uevent
[130302.529968] usb 1-1: usb_probe_device
[130302.529998] usb 1-1: configuration #1 chosen from 1 choice
[130302.534576] usb 1-1: adding 1-1:1.0 (config #1, interface 0)
[130302.534912] usb 1-1:1.0: uevent
[130302.539672] /home/builder2/maemo-fremantle-armel-extras-devel/work/kernel-power-2.6.28/drivers/usb/core/inode.c: creating file '022'
[130302.540344] usb 1-1: New USB device found, idVendor=0bda, idProduct=8187
[130302.540405] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[130302.540435] usb 1-1: Product: RTL8187_Wireless_LAN_Adapte˙
[130302.540466] usb 1-1: Manufacturer: Manufacturer_Realtek_RTL8187_
[130302.540496] usb 1-1: SerialNumber: 00C0CA2053D9
[130302.540527] hub 1-0:1.0: state 7 ports 1 chg 0000 evt 0002
[130302.540618] hub 1-0:1.0: port 1 enable change, status 00000503
'/*

'*/ insmoding modules ussing this sequence:
ieee80211_crypt-rtl.ko ieee80211_crypt_wep-rtl.ko ieee80211_crypt_tkip-rtl.ko ieee80211_crypt_ccmp-rtl.ko ieee80211-rtl.ko r8187.ko
[130460.969970] ieee80211_crypt: registered algorithm 'NULL'
[130476.009155] ieee80211_crypt: registered algorithm 'WEP'
[130486.802551] ieee80211_crypt: registered algorithm 'TKIP'
[130496.717346] ieee80211_crypt: registered algorithm 'CCMP'
[130519.260101] r8187: no symbol version for ieee80211_wx_set_rate_rtl7
[130519.260131] r8187: Unknown symbol ieee80211_wx_set_rate_rtl7
[130519.260742] r8187: no symbol version for ieee80211_wx_get_scan_rtl7
[130519.260772] r8187: Unknown symbol ieee80211_wx_get_scan_rtl7
[130519.261383] r8187: no symbol version for ieee80211_wx_set_wap_rtl7
[130519.261413] r8187: Unknown symbol ieee80211_wx_set_wap_rtl7
[130519.262176] r8187: no symbol version for ieee80211_wlan_frequencies_rtl7
[130519.262176] r8187: Unknown symbol ieee80211_wlan_frequencies_rtl7
[130519.262573] r8187: no symbol version for ieee80211_wake_queue_rtl7
[130519.262603] r8187: Unknown symbol ieee80211_wake_queue_rtl7
[130519.263458] r8187: no symbol version for ieee80211_softmac_start_protocol_rtl7
[130519.263488] r8187: Unknown symbol ieee80211_softmac_start_protocol_rtl7
[130519.264282] r8187: no symbol version for ieee80211_softmac_stop_protocol_rtl7
[130519.264312] r8187: Unknown symbol ieee80211_softmac_stop_protocol_rtl7
[130519.264862] r8187: no symbol version for ieee80211_wx_get_essid_rtl7
[130519.264862] r8187: Unknown symbol ieee80211_wx_get_essid_rtl7
[130519.265258] r8187: no symbol version for ieee80211_wx_set_freq_rtl7
[130519.265289] r8187: Unknown symbol ieee80211_wx_set_freq_rtl7
[130519.265686] r8187: no symbol version for ieee80211_stop_queue_rtl7
[130519.265686] r8187: Unknown symbol ieee80211_stop_queue_rtl7
[130519.266448] r8187: no symbol version for ieee80211_wx_set_scan_rtl7
[130519.266479] r8187: Unknown symbol ieee80211_wx_set_scan_rtl7
[130519.267303] r8187: no symbol version for ieee80211_wx_get_wap_rtl7
[130519.267303] r8187: Unknown symbol ieee80211_wx_get_wap_rtl7
[130519.268249] r8187: no symbol version for ieee80211_reset_queue_rtl7
[130519.268280] r8187: Unknown symbol ieee80211_reset_queue_rtl7
[130519.269317] r8187: no symbol version for ieee80211_wx_get_encode_rtl7
[130519.269317] r8187: Unknown symbol ieee80211_wx_get_encode_rtl7
[130519.270050] r8187: no symbol version for ieee80211_is_shortslot_rtl7
[130519.270080] r8187: Unknown symbol ieee80211_is_shortslot_rtl7
[130519.270751] r8187: no symbol version for ieee80211_wpa_supplicant_ioctl_rtl7
[130519.270751] r8187: Unknown symbol ieee80211_wpa_supplicant_ioctl_rtl7
[130519.271209] r8187: no symbol version for ieee80211_is_54g_rtl7
[130519.271209] r8187: Unknown symbol ieee80211_is_54g_rtl7
[130519.271667] r8187: no symbol version for ieee80211_wx_get_mode_rtl7
[130519.271697] r8187: Unknown symbol ieee80211_wx_get_mode_rtl7
[130519.272827] r8187: no symbol version for ieee80211_wx_get_rate_rtl7
[130519.272827] r8187: Unknown symbol ieee80211_wx_get_rate_rtl7
[130519.273223] r8187: no symbol version for ieee80211_get_beacon_rtl7
[130519.273254] r8187: Unknown symbol ieee80211_get_beacon_rtl7
[130519.273651] r8187: no symbol version for ieee80211_rx_rtl7
[130519.273651] r8187: Unknown symbol ieee80211_rx_rtl7
[130519.274047] r8187: no symbol version for ieee80211_wx_set_mode_rtl7
[130519.274078] r8187: Unknown symbol ieee80211_wx_set_mode_rtl7
[130519.274475] r8187: no symbol version for ieee80211_wx_set_encode_rtl7
[130519.274475] r8187: Unknown symbol ieee80211_wx_set_encode_rtl7
[130519.274932] r8187: no symbol version for ieee80211_wx_set_essid_rtl7
[130519.274932] r8187: Unknown symbol ieee80211_wx_set_essid_rtl7
[130519.275329] r8187: no symbol version for alloc_ieee80211_rtl7
[130519.275360] r8187: Unknown symbol alloc_ieee80211_rtl7
[130519.275726] r8187: no symbol version for ieee80211_wx_get_freq_rtl7
[130519.275756] r8187: Unknown symbol ieee80211_wx_get_freq_rtl7
[130519.276336] r8187: no symbol version for free_ieee80211_rtl7
[130519.276367] r8187: Unknown symbol free_ieee80211_rtl7
[130519.276916] r8187: no symbol version for ieee80211_wx_get_name_rtl7
[130519.276916] r8187: Unknown symbol ieee80211_wx_get_name_rtl7
'/*

'*/ lsusb output:
Bus 001 Device 022: ID 0bda:8187 Realtek Semiconductor Corp.
Bus 001 Device 001: ID 1d6b:0002
'/*

Thanx for helping
 
Posts: 540 | Thanked: 387 times | Joined on May 2009
#22
Perhaps instead of using the ieee80211 stack + r8187 driver you could try the mac80211 stack + rtl8187 driver? Provided of course the mac80211 stack is available/compatible with your kernel. Maemo5 has a much newer kernel so it should be do-able.

In my experience both drivers work well with this card, though the r8187 driver works slightly better in monitor/injection mode than the rtl8187 and OTOH the rtl8187 works slightly better in managed/web-browsing mode than the r8187. Yet both are perfectly capable of both managed and monitor mode.

Anyway give the mac80211+rtl8187 route a shot if possible.

The unknown symbols error usually means either it wasn't compiled cleanly or that the driver source needs some moderate (to major) changes in the code to work properly with your kernel.

It's good to hear that usb host-mode is finally working on the N900 (although it's possible that it's the culprit). Oh and you are providing the card adequate external power, yes?
 

The Following User Says Thank You to linuxeventually For This Useful Post:
Posts: 422 | Thanked: 241 times | Joined on Feb 2008
#23
This is just the insmod phase so power isn't an issue yet... but it will be of course.

The messages you are getting should be warnings according to the wiki, but there is also a fix there too:

http://www.aircrack-ng.org/doku.php?id=r8187

When I was using this driver, it was with n810, so an older/different kernel. But I used ieee rather than mac and it worked fine. The mac approach is worth testing though, just another data point.

Last edited by paulkoan; 2010-12-03 at 20:50.
 

The Following 2 Users Say Thank You to paulkoan For This Useful Post:
Posts: 34 | Thanked: 15 times | Joined on Jan 2010
#24
In my experience both drivers work well with this card, though the r8187 driver works slightly better in monitor/injection mode than the rtl8187 and OTOH the rtl8187 works slightly better in managed/web-browsing mode than the r8187. Yet both are perfectly capable of both managed and monitor mode.
You are 100% correct
I wont say im not interested about injection rates , but for now it will be great to have it just working.

I compiled module from kernel-power-2.6.28...
Im not 100% sure i've it correcly so here is what i did.

1. from scratchbox i downloaded kernel source:
[sbox-MaemoKernel: ~/maemo_kernel] > apt-get source kernel-power

2. I entered kernel-power folder and copied default config:
[sbox-MaemoKernel: ~/maemo_kernel/kernel-power-2.6.28] > cp debian/rx51power_defconfig arch/arm/configs/
[sbox-MaemoKernel: ~/maemo_kernel/kernel-power-2.6.28] > make EXTRAVERSION=$(dpkg-parsechangelog | sed -ne 's/^Version: .*-maemo\(.*\)/.10power\1/p') rx51power_defconfig

3. I edited .config and discomented "CONFIG_RTL8187 is not set" to "CONFIG_RTL8187=m" i think its a good idea to compile it as module:
#
# Wireless LAN
#
# CONFIG_WLAN_PRE80211 is not set
CONFIG_WLAN_80211=y
# CONFIG_LIBERTAS is not set
# CONFIG_LIBERTAS_THINFIRM is not set
# CONFIG_USB_ZD1201 is not set
# CONFIG_USB_NET_RNDIS_WLAN is not set
CONFIG_RTL8187=m
# CONFIG_MAC80211_HWSIM is not set (im not sure if its necesary, i think not)

4. Including changes for compilation.
[sbox-MaemoKernel: ~/maemo_kernel/kernel-power-2.6.28] > make EXTRAVERSION=$(dpkg-parsechangelog | sed -ne 's/^Version: .*-maemo\(.*\)/.10power\1/p') oldconfig

5. Compiling modules
[sbox-MaemoKernel: ~/maemo_kernel/kernel-power-2.6.28] > make EXTRAVERSION=$(dpkg-parsechangelog | sed -ne 's/^Version: .*-maemo\(.*\)/.10power\1/p') modules

Once compiled i took the module apart and tried to insmod it, here is dmesg output:
[ 9536.131896] rtl8187: no symbol version for struct_module

I have not provide any external power source such as a powered hub, i think h-e-n provides itself enough power, anyway i will try one.

Thanx for helping
 
Posts: 306 | Thanked: 566 times | Joined on Jan 2010 @ Romania
#25
what kernel do you have on your n900 ?
 
Posts: 34 | Thanked: 15 times | Joined on Jan 2010
#26
2.6.28.10power46
 
Posts: 306 | Thanked: 566 times | Joined on Jan 2010 @ Romania
#27
you compiled the driver without errors ?
when i tried the screen fill with errors like chickenpox.

The legacy drivers use the ieee80211 or net80211 stacks
keep in mind kpower46 already have mac80211 so you must adapt rtl driver for mac80...

blacklist ieee80211 for peace of mind

you can put EXTRAVERSION=".10power46"
try once more.

Last edited by blue_led; 2010-12-04 at 00:37.
 
Posts: 34 | Thanked: 15 times | Joined on Jan 2010
#28
Legacy rtl8187 use net80211 witch is included by default in the stock and power kernels, so i thought it sould just work.

Recent kernels (2.6.27 and newer) contain a fully-functional driver for RTL8187B - it's the same driver as the new one for RTL8187L, rtl8187. You should consider trying that version. The new driver is mac80211-based, so the usual mac80211 rules apply.
Source: http://www.aircrack-ng.org/doku.php?...869cc901b6514f

I compiled just the modules not the entire kernel and copied the rtl8187 module to /lib/modules/2.6.28.10power10/ at N900 and tried to insmod it.
No luck so far.
When i edited the config i was whiling to find CONFIG_RTL8187_LEDS option too but it was not present, anyway CONFIG_WLAN_80211=y was set

If you do lsmod | grep ieee will see there's no ieee80211 module loaded.
mac80211 is loaded by the built in wifi card module wl12xx.

I had always work with rtl8187 included at kernels (2.6.27 and newer) for browsing and compiled r8187 for monitor/injection task at debian without problems.
 
Posts: 34 | Thanked: 15 times | Joined on Jan 2010
#29
Hey guys, i've got r8187 compiled and insmoded ok

Tryed once again compiling r8187 and trying to understand every step i was doing

The messages you are getting should be warnings according to the wiki, but there is also a fix there too:

http://www.aircrack-ng.org/doku.php?id=r8187
Thanks paulkoan for this tip

Ok, here are the steps i did so anyone can build it:

1. at scratchbox download the rtl8187 source
wget http://dl.aircrack-ng.org/drivers/rt...ux_26.1010.zip

2. Unzip and enter source folder
unzip rtl8187_linux_26.1010.zip
cd rtl8187_linux_26.1010.0622.2006/

3. Download patch
wget http://patches.aircrack-ng.org/rtl8187_2.6.27.patch

4. Unpack driver and stack
tar xzf drv.tar.gz
tar xzf stack.tar.gz

5. apply the new patch:
patch -Np1 -i rtl8187_2.6.27.patch

6. edit ./beta-8187/r8187.h
change the line:
#include <asm/semaphore.h>
to:
#include <linux/semaphore.h>

7.edit ./beta-8187/Makefile
change the line:
EXTRA_CFLAGS += -mhard-float -DCONFIG_FORCE_HARD_FLOAT=y
to:
EXTRA_CFLAGS += -msoft-float -DCONFIG_FORCE_HARD_FLOAT=n
(Thanx to qwerty12)

8. Compile stack against kernel-power-headers
make -C /usr/src/kernel-power-headers/ M=/targets/FREMANTLE_ARMEL/usr/src/rtl8187_linux_26.1010.0622.2006/ieee80211/ modules

9. Remove ./beta-r817/Module.symvers and link the one at the folder ieee80211:
rm -f ./beta-8187/Module.symvers
ln -s ../ieee80211/Module.symvers ./beta-8187Module.symvers
(Thanxs to paulkoal)

10. Compile driver against kernel-power-headers
make -C /usr/src/kernel-power-headers/ M=/targets/FREMANTLE_ARMEL/usr/src/rtl8187_linux_26.1010.0622.2006/beta-8187/ modules

Note: If its fails saying it needs ECHI KERNEL SUPPORT remove lines referencing this at ./beta-8187/r8187_core.c
(Thanx qwerty12)

11. Copy modules to your N900, rmmod modules for wifi and mac80211 stack and insmod new modules in sequence.
rmmod wl12xx
rmmod mac80211
insmod /path.to.your.modules/ieee8011_crypt-rtl.ko
insmod /path.to.your.modules/ieee8011_crypt_wep-rtl.ko
insmod /path.to.your.modules/ieee8011_crypt_tkip-rtl.ko
insmod /path.to.your.modules/ieee8011_crypt_ccmp-rtl.ko
insmod /path.to.your.modules/r8187.ko

You are done.

Take a look to this:
Loading Modules:
[83180.697662] ieee80211_crypt: registered algorithm 'NULL'
[83180.729888] ieee80211_crypt: registered algorithm 'WEP'
[83180.761230] ieee80211_crypt: registered algorithm 'TKIP'
[83180.791564] ieee80211_crypt: registered algorithm 'CCMP'
[83180.928344]
[83180.928344] Linux kernel driver for RTL8187 based WLAN cards
[83180.928375] Copyright (c) 2004-2005, Andrea Merello
[83180.928375] rtl8187: Initializing module
[83180.928405] rtl8187: Wireless extensions version 22
[83180.928405] rtl8187: Initializing proc filesystem
[83180.933319] usbcore: registered new interface driver rtl8187

Connecting usb adapter with h-e-n:
[87292.424987] twl4030_usb twl4030_usb: HW_CONDITIONS 0xd0/208; link 2
[87294.017333] usb usb1: usb resume
[87294.036346] hub 1-0:1.0: hub_resume
[87294.036407] hub 1-0:1.0: port 1: status 0101 change 0001
[87294.146575] hub 1-0:1.0: state 7 ports 1 chg 0002 evt 0000
[87294.146667] hub 1-0:1.0: port 1, status 0101, change 0000, 12 Mb/s
[87294.270904] usb 1-1: new high speed USB device using musb_hdrc and address 27
[87294.421234] usb 1-1: default language 0x0409
[87294.428497] usb 1-1: uevent
[87294.428710] usb 1-1: usb_probe_device
[87294.428741] usb 1-1: configuration #1 chosen from 1 choice
[87294.433959] usb 1-1: adding 1-1:1.0 (config #1, interface 0)
[87294.434326] usb 1-1:1.0: uevent
[87294.434600] rtl8187 1-1:1.0: usb_probe_interface
[87294.434631] rtl8187 1-1:1.0: usb_probe_interface - got id
[87294.568725] rtl8187: Enabling 14 channels.
[87294.569427] rtl8187: MAC chip version: 04
[87294.569458] rtl8187: Card type: AD
[87294.569610] rtl8187: Reported EEPROM chip is a 93c46 (1Kbit)
[87294.671600] rtl8187: Card MAC address is 00:c0:ca:20:53:d9
[87294.921722] rtl8187: RF Chip ID: 05
[87294.964965] rtl8187: Card reports RF frontend Realtek 8225
[87294.964996] rtl8187: WW:This driver has EXPERIMENTAL support for this chipset.
[87294.965026] rtl8187: WW:use it with care and at your own risk and
[87294.965057] rtl8187: WW:**PLEASE** REPORT SUCCESS/INSUCCESS TO andreamrl@tiscali.it
[87295.044311] rtl8187: This seems a new V2 radio
[87295.044708] rtl8187: PAPE from CONFIG2: 0
[87295.056091] rtl8187: Driver probe completed
[87295.056121]
[87295.074859] /home/builder2/maemo-fremantle-armel-extras-devel/work/kernel-power-2.6.28/drivers/usb/core/inode.c: creating file '027'
[87295.076538] usb 1-1: New USB device found, idVendor=0bda, idProduct=8187
[87295.076599] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[87295.076629] usb 1-1: Product: RTL8187_Wireless_LAN_Adapte˙
[87295.076660] usb 1-1: Manufacturer: Manufacturer_Realtek_RTL8187_
[87295.076690] usb 1-1: SerialNumber: 00C0CA2053D9
[87295.076721] hub 1-0:1.0: state 7 ports 1 chg 0000 evt 0002
[87295.076812] hub 1-0:1.0: port 1 enable change, status 00000503


iwconfig output:

wlan0 802.11b/g Mode:Managed Access Point: Not-Associated
Bit Rate:11 Mb/s Tx-Power=5 dBm
Retryn Fragment thrff
Encryption keyff
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Its works without any external power source , at list for the moment

Now im going to experiment a little

Thanx to everyone who helped me and, of course, h-e-n developers. (rtl8187 stack mac80211 is next)

Last edited by pinoverclock; 2010-12-04 at 18:35.
 

The Following 3 Users Say Thank You to pinoverclock For This Useful Post:
Posts: 63 | Thanked: 27 times | Joined on Apr 2011
#30
TO PINOVERCLOCK:

I´m trying to compile this drivers but in step 8 when i type in my N900 terminal:

make -C /usr/src/kernel-power-headers/ M=/targets/FREMANTLE_ARMEL/usr/src/rtl8187_linux_26.1010.0622.2006/ieee80211/ modules

i get the following output:

make: arm-linux-gcc: program not found
make: Entering directory `/usr/src/kernel-power-headers'
CC [M] /targets/FREMANTLE_ARMEL/usr/src/rtl8187_linux_26.1010.0622.2006/ieee80211/ieee80211_softmac.o
/bin/sh: arm-linux-gcc: not found
make[1]: *** [/targets/FREMANTLE_ARMEL/usr/src/rtl8187_linux_26.1010.0622.2006/ieee80211/ieee80211_softmac.o] Error 127
make: *** [_module_/targets/FREMANTLE_ARMEL/usr/src/rtl8187_linux_26.1010.0622.2006/ieee80211] Error 2
make: Leaving directory `/usr/src/kernel-power-headers'


HELP!!

Last edited by -Tyler-; 2011-04-17 at 03:59.
 
Reply

Tags
alfa, external, r8187, rtl8187, wifi

Thread Tools

 
Forum Jump


All times are GMT. The time now is 16:27.