Notices


Reply
Thread Tools
Posts: 1,698 | Thanked: 1,693 times | Joined on Dec 2010
#311
Originally Posted by Mara View Post
I gave it a first shot to flash Sailfish on my new XperiaX using the latest community build image. Unfortunately it did not work.

I tried first the windows method (flash.bat) but it seems the bat file has some issues and doesn't work. I manually executed the steps on the bat file in terminal window and everything seemed to go fine.

Code:
F:\SONY\SailfishOS-2.1.2.3-f5121-0.0.1+master.20170125170904.537a491.15>fastboot flash boot hybris-boot.img
target reported max download size of 536870912 bytes
sending 'boot' (10846 KB)...
OKAY [  0.354s]
writing 'boot'...
OKAY [  0.075s]
finished. total time: 0.435s

F:\SONY\SailfishOS-2.1.2.3-f5121-0.0.1+master.20170125170904.537a491.15>fastboot flash system fimage.img001
target reported max download size of 536870912 bytes
erasing 'system'...
OKAY [  0.983s]
sending sparse 'system' 1/2 (524284 KB)...
OKAY [ 18.141s]
writing 'system' 1/2...
OKAY [  3.845s]
sending sparse 'system' 2/2 (44832 KB)...
OKAY [  1.582s]
writing 'system' 2/2...
OKAY [  0.323s]
finished. total time: 24.885s

F:\SONY\SailfishOS-2.1.2.3-f5121-0.0.1+master.20170125170904.537a491.15>fastboot flash userdata sailfish.img001
target reported max download size of 536870912 bytes
erasing 'userdata'...
OKAY [  0.542s]
sending sparse 'userdata' 1/1 (0 KB)...
OKAY [  0.013s]
writing 'userdata' 1/1...
OKAY [  0.011s]
finished. total time: 0.571s

F:\SONY\SailfishOS-2.1.2.3-f5121-0.0.1+master.20170125170904.537a491.15>fastboot flash oem xperiax_m_loire.img
target reported max download size of 536870912 bytes
sending 'oem' (163040 KB)...
OKAY [  5.297s]
writing 'oem'...
OKAY [ 21.028s]
finished. total time: 26.329s
After restart the phone entered to bootloop (shows SONY logo and restarts endlessly).

The only difference is that I did shorten the Sony OEM blob file name... This should have nothing to do with this? There are several versions of the Sony OEM blob files available. I used the one that was mentioned in the instructions.

I was able to recover it back to Android using the EMMA tool. It flashed back slightly older version (228) while the version before was 344 if I recall.

I retried flashing after the EMMA tool recovery but I still get the bootloop. This time I can't even get the EMMA to recognize the phone any more... so I'll need to recover it using the fastboot only.

One interesting point I noted with EMMA: It can not be used in the fastboot mode (blue LED after holding volume up key up) but only in "standard mode" showing green LED...
what were the issues with the bat file?
 
Mara's Avatar
Posts: 1,285 | Thanked: 700 times | Joined on Mar 2006 @ Irving, TX
#312
Originally Posted by m4r0v3r View Post
what were the issues with the bat file?
It kicked me out on checking if I had correct product: Manually given the "fastboot getvar product" command responds with "product: F5121"

The bigger problem now I have is that I cannot flash the userdata... More details are in my previous post.
 
Posts: 1,698 | Thanked: 1,693 times | Joined on Dec 2010
#313
Originally Posted by Mara View Post
It kicked me out on checking if I had correct product: Manually given the "fastboot getvar product" command responds with "product: F5121"

The bigger problem now I have is that I cannot flash the userdata... More details are in my previous post.
can you get into the green flash mode? also what size is the userdata file?

Last edited by m4r0v3r; Yesterday at 21:10.
 
Mara's Avatar
Posts: 1,285 | Thanked: 700 times | Joined on Mar 2006 @ Irving, TX
#314
Originally Posted by m4r0v3r View Post
can you get into the green flash mode?
I'm not sure if it matters any more... I fixed the userdata flashing issue by doing it from linux (dual boot). It worked flawlessly and now I'm already using Sailfish on my XperiaX

Busy now playing with my new toy...
 
Posts: 1,698 | Thanked: 1,693 times | Joined on Dec 2010
#315
Originally Posted by Mara View Post
I'm not sure if it matters any more... I fixed the userdata flashing issue by doing it from linux (dual boot). It worked flawlessly and now I'm already using Sailfish on my XperiaX

Busy now playing with my new toy...
am glad man had me worried for a sec :P windows is always crap
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 05:35.