Notices


Reply
Thread Tools
Posts: 3 | Thanked: 0 times | Joined on Jan 2012 @ Japan
#1
I made Mer iso file and I tried to install on virtual machine.
But failed to install Mer.
I can't understand why failing it.

Could you advise me wrong point of my procedure to make iso file.
Please advise me wrong point of my procedure to make iso file or reasons for failure.

My procedure is following.

=====
1.install software for build
sudo apt-get install yum rpm kpartx parted syslinux isomd5sum kvm zlib1g-dev squashfs-tools python2.6-dev qemu-arm-static python-urlgrabber

2.Add package source
sudo vi /etc/apt/sources.list
deb http://repo.meego.com/MeeGo/tools/repos/ubuntu/10.04/ /

3.import the key
wget http://repo.meego.com/MeeGo/tools/re...04/Release.key
Open System->Administrator->Software Sources.

4.update
sudo apt-get update

5.install mic2
sudo apt-get install mic2

6.make work directory
sudo mkdir /var/cache/mic

7.make bootstrap directory
/var/cache/meego-bootstrap

8.make bootstrap
sudo mic-create-bootstrap -n trunk -k /var/cache/mic -r http://repo.meego.com/MeeGo/builds/t...ia32/packages/ -o /var/cache/meego-bootstrap

9.download kickstart file
wget nemo-handset-i586-testing-0.20111128.3.CE.2011-12-01.2.ks

10.make iso file.
sudo mic-image-creator --format=livecd --cache=/var/cache/mic --mainrepo=mer-core --arch=i586 --config=nemo-handset-i586-testing-0.20111128.3.CE.2011-12-01.2.ks --bootstrap=/var/cache/meego-bootstrap/
=====

I attached virtual machine error display.
Attached Files
File Type: zip VirtualBox.png.zip (26.2 KB, 185 views)

Last edited by Eiden; 2012-01-12 at 13:19.
 
Posts: 482 | Thanked: 550 times | Joined on Oct 2010
#2
Maybe the image is corrupted?
 
Posts: 1,523 | Thanked: 1,997 times | Joined on Jul 2011 @ not your mom's FOSS basement
#3
I'm pretty sure that VirtualBox is not the way to go for embedded Linux - would try it under Qemu instead.
 

The Following User Says Thank You to don_falcone For This Useful Post:
Stskeeps's Avatar
Posts: 1,671 | Thanked: 11,477 times | Joined on Jun 2008 @ Warsaw, Poland
#4
VirtualBox works fine for embedded linux:



His mistake (talked on IRC) was to make an image without LLVMpipe installed
__________________
As you go on to other communities, remember to build them around politeness, respect, trust and humility. Be wary of poisonous people and deal with them before they end up killing your community.. Seen it happen to too many IRC channels, forums, open source projects.
 

The Following 3 Users Say Thank You to Stskeeps For This Useful Post:
Posts: 3 | Thanked: 0 times | Joined on Jan 2012 @ Japan
#5
Thanks for everyone to reply.

I installed llvm-dev in my PC and tried to install on Virtual box.
But the result is failure.
I could have installed completely on Virtual box but fail to boot.
I tried to install on qemu , but fail to install.

I checked kickstart file and I found that qemu-arm-static version was checked whether it's version is over 0.14 or not.

Is qemu-arm-static Ver.0.14 needed for making iso file?

Last edited by Eiden; 2012-01-12 at 15:45.
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 12:18.