Active Topics

 



Notices


Reply
Thread Tools
Posts: 5 | Thanked: 9 times | Joined on Jun 2018
#1
Hello world,

First, sorry if I'm in the wrong place, and sorry if this is an already known and easely fixable issue.

I red a lot about the n9 and meago on this (awsome) site and here and there on the internet, and i decided to buy one. I'm new to the meamo world (I've never touched android either, in fact I'm new to the smartphone world), so forgive me if I ask silly questions, although I usually try not to open topic before being completely hopeless...

So I carefully red the "Resurrect your N9" topic (https://wiki.maemo.org/Resurrect_your_N9) and so the first thing I tried to do was to change the repo. I turned the Allow installations from Non-Store sources option on then opened the browser: And well I couldn't browse to openrepos.net as well as nearly every website I tried to browse to. (I could access meamo.org and A small videogame blog merlfrit.net and that's all). It seems to load a few things before prompting an error message "Couldn't open page [url]".

I looked for a solutions on this forum but nothing helped me... I new I might not be able to access every websites, but here it's serioulsly getting on my nerves

I guess I can install the N9 repomirror package transfering it from my PC but still.... I'd expect the browser to access most sites since it's compatible HTML5. I guess the probleme isn't about that though.

I really love this device so I'm ready to put a lot of effort and time into it

Thank you if you took the time ti read this, I'm looking forwoard to your help!
 

The Following 2 Users Say Thank You to holistik For This Useful Post:
mike727's Avatar
Posts: 63 | Thanked: 121 times | Joined on Aug 2015 @ Australia
#2
Have you tried setting the date to 2013.. 2012 ? (I think that's what fixed me up)
Could there be a network problem? Have you tried using a different wifi source?
 

The Following User Says Thank You to mike727 For This Useful Post:
Posts: 5 | Thanked: 9 times | Joined on Jun 2018
#3
thanks for taking the time to answer me.

Yes, I red it was wise to set the date between 2012 and 2015 so I did so right away when I booted the.phone for the first time.

Perhaps it is but, why would sites like this one work while others dont? Moreover my other devices (I have an x61 under debian 9, a windows PC) can access any site without problem and I could try with an android 5 smartphone and a nokia 610 under obsolete windows phone version and it worked perfectly as well... I'm completely lost

Maybe proxy or dns things I dont know I'll keep invetigating though
I live in deep countryside so I can't acces any other wifi source right now, but I'll try!

EDIT: I tried using 3G and it's.exactly the same.
EDIT2: I found a commun point between all sites I can't access: There are https... I just can't access secure sites. This is something I probably could fix changing the browser's settings (like the TLS things)... As microB is based on mozilla, I tried the about:config thing but nothing was prompted... Developper mod won't intall so I can't use term and change .js files values manualy.

Last edited by holistik; 2018-06-15 at 10:30.
 

The Following User Says Thank You to holistik For This Useful Post:
DA5's Avatar
Posts: 58 | Thanked: 263 times | Joined on Jan 2013 @ US
#4
Try setting the date to the correct one for browsing https sites. (TLS 1.2 sites still won't work, but openrepos will.)
Then set the clock a few years back only when you install things because some of the certificates have expired, and they won't install if the date on the phone is past the valid date of the certificate. When everything's installed set the correct date for browsing https sites.
 

The Following User Says Thank You to DA5 For This Useful Post:
Posts: 5 | Thanked: 9 times | Joined on Jun 2018
#5
Hi,
Still doesn't work... But thank you for your help!
I'm thinking about flashing the device and get everything fresh... Although I'd prefere not to do so cause I got the device brand new with 1 year garanty and I find it sad to waste it

Any suggestion that would help me accessing the browser settings?
 

The Following User Says Thank You to holistik For This Useful Post:
Posts: 229 | Thanked: 612 times | Joined on Jun 2015 @ Lisbon - Portugal
#6
Originally Posted by holistik View Post
Hi,
Still doesn't work... But thank you for your help!
I'm thinking about flashing the device and get everything fresh... Although I'd prefere not to do so cause I got the device brand new with 1 year garanty and I find it sad to waste it

Any suggestion that would help me accessing the browser settings?
Flashing your device won't void your warranty and almost sure it'll fix your issues
 

The Following 2 Users Say Thank You to deutch1976 For This Useful Post:
Posts: 5 | Thanked: 9 times | Joined on Jun 2018
#7
Ah ok greate then let's go for it!
I'll edit this poste when it'll be done to tell if it's fixed or not
Thank you very much for your help!

EDIT: I performed a Comprehansive reset with PR 1.3 and.. It's all fixed! I can access openrepos.net now.

Last edited by holistik; 2018-06-17 at 00:36.
 

The Following 3 Users Say Thank You to holistik For This Useful Post:
Posts: 170 | Thanked: 182 times | Joined on Apr 2013 @ Poland
#8
For sure flashing wont fix the problem. I'm facing the same problem on two of my n900s and n9 as well. The problem is somewhere else, probably not in browser itself 'cause microb, opera and qmlbrowser on maemo 5 reports the same problem:

Code:
cannot communicate securely with peer: no common encryption algorithm(s).Error code: ssl_error_no_cypher_overlap
I really hope that we didn't reach the point where our OS's are so out of date that we cannot even try to open web pages...
 

The Following 2 Users Say Thank You to Ridd92 For This Useful Post:
peterleinchen's Avatar
Posts: 3,329 | Thanked: 6,240 times | Joined on Aug 2010 @ Ruhrgebiet, Germany
#9
Originally Posted by Ridd92 View Post
For sure flashing wont fix the problem. I'm facing the same problem on two of my n900s and n9 as well. The problem is somewhere else, probably not in browser itself 'cause microb, opera and qmlbrowser on maemo 5 reports the same problem:

Code:
cannot communicate securely with peer: no common encryption algorithm(s).Error code: ssl_error_no_cypher_overlap
I really hope that we didn't reach the point where our OS's are so out of date that we cannot even try to open web pages...
This may be / is already the case (just see here as latest example

Giving an example of web site could help to compare/confirm...
__________________
SIM-Switcher, automated SIM switching with a Double (Dual) SIM adapter
--
Thank you all for voting me into the Community Council 2014-2016!

Please consider your membership / supporting Maemo e.V. and help to spread this by following/copying this link to your TMO signature:
[MC eV] Maemo Community eV membership application, http://talk.maemo.org/showthread.php?t=94257

editsignature, http://talk.maemo.org/profile.php?do=editsignature

Last edited by peterleinchen; 2018-06-16 at 06:28.
 

The Following User Says Thank You to peterleinchen For This Useful Post:
Posts: 5 | Thanked: 9 times | Joined on Jun 2018
#10
Hi,
Thanks for all these answers!

There are still few sites I can't open, like twitch, but I guess it's all about TLS 1.2 like DA5 said. So Harmattan is not completely obselete yet! At least for me...
 

The Following 2 Users Say Thank You to holistik For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 04:14.