Active Topics

 



Notices


Reply
Thread Tools
Posts: 10 | Thanked: 10 times | Joined on Feb 2012
#11
@deprecated - disregard that PM I just sent you about the APN setting. I just found this thread and caught up.

@rest of thread - I am SO glad to hear that T-Mobile USA and correct settings will give us read speed. Now I am really stoked to get the XX ordered and official build installed. Thanks for being trailblazers!

Gee, I will have to change my username soon.
 

The Following 2 Users Say Thank You to RasLikesN9 For This Useful Post:
Posts: 13 | Thanked: 50 times | Joined on Jul 2012
#12
Just want to say thanks for identifying and solving this. This had been plaguing me and preventing me from using Sailfish OS as my daily driver since I toyed with Nexus 5 port this time last year.

I had incorrectly assumed it was specific to the Nexus 5 port and was about to freak out hard when SailfishX exhibited the same behavior.
 

The Following 3 Users Say Thank You to trashHeap For This Useful Post:
Posts: 27 | Thanked: 119 times | Joined on Feb 2013
#13
MMS still does not work for me (Portland US, Sailfish X, T-Mobile)...
By default Data and texting works fine. But sending an MMS just hangs with the the message "Sending..."
If I edit the MMS access point as suggested, MMS will not get stuck on "Sending..." but instead just says "Problem with sending message"

Also, After a reboot the MMS setting revert to:
T-Mobile MMS
internet2.voicestream.com
IP
Auth: None
Proxy: 216.155.165.50
Port: 8080
MMS message center: http://216.155.174.84/servlets/mms
 

The Following User Says Thank You to one_with_linux For This Useful Post:
Posts: 218 | Thanked: 569 times | Joined on Jun 2010 @ USA
#14
Originally Posted by one_with_linux View Post
MMS still does not work for me (Portland US, Sailfish X, T-Mobile)...
By default Data and texting works fine. But sending an MMS just hangs with the the message "Sending..."
If I edit the MMS access point as suggested, MMS will not get stuck on "Sending..." but instead just says "Problem with sending message"

Also, After a reboot the MMS setting revert to:
T-Mobile MMS
internet2.voicestream.com
IP
Auth: None
Proxy: 216.155.165.50
Port: 8080
MMS message center: http://216.155.174.84/servlets/mms
Make sure to apply my fix for APN settings sticking:

http://talk.maemo.org/showpost.php?p...7&postcount=93

My settings that work flawlessly in Chicago:

T-Mobile MMS
epc.t-mobile.com
IPv6
Auth: None
Proxy: Blank
Port: Blank
MMS message center: http://mms.msg.eng.t-mobile.com/mms/wapenc

T-Mobile Data
epc.t-mobile.com
Dual
Auth: None

Works every time, just not when you're on WiFi exclusively, or on a VPN.

Edit: I also select "Prefer 4G" and set the network to T-Mobile manually in the settings.
__________________
Sony Xperia X SFOS 2.1.2.3, Nokia N810
 

The Following 2 Users Say Thank You to deprecated For This Useful Post:
Posts: 218 | Thanked: 569 times | Joined on Jun 2010 @ USA
#15
Originally Posted by RasLikesN9 View Post
@deprecated - disregard that PM I just sent you about the APN setting. I just found this thread and caught up.

@rest of thread - I am SO glad to hear that T-Mobile USA and correct settings will give us read speed. Now I am really stoked to get the XX ordered and official build installed. Thanks for being trailblazers!

Gee, I will have to change my username soon.
Looking forward to you joining the club! I miss my N9, for what it's worth.
__________________
Sony Xperia X SFOS 2.1.2.3, Nokia N810
 

The Following User Says Thank You to deprecated For This Useful Post:
Posts: 27 | Thanked: 119 times | Joined on Feb 2013
#16
Originally Posted by deprecated View Post
Make sure to apply my fix for APN settings sticking:

http://talk.maemo.org/showpost.php?p...7&postcount=93

My settings that work flawlessly in Chicago:

T-Mobile MMS
epc.t-mobile.com
IPv6
Auth: None
Proxy: Blank
Port: Blank
MMS message center: http://mms.msg.eng.t-mobile.com/mms/wapenc

T-Mobile Data
epc.t-mobile.com
Dual
Auth: None

Works every time, just not when you're on WiFi exclusively, or on a VPN.

Edit: I also select "Prefer 4G" and set the network to T-Mobile manually in the settings.
That did it... For the most part... MMS still will not work when I'm connected to WiFi. Deactivating WiFi fixes the issue.

Last edited by one_with_linux; 2017-10-15 at 15:55.
 

The Following User Says Thank You to one_with_linux For This Useful Post:
Posts: 170 | Thanked: 386 times | Joined on Dec 2009
#17
Originally Posted by one_with_linux View Post
That did it... For the most part... MMS still will not work when I'm connected to WiFi. Deactivating WiFi fixes the issue.

I can dependably reproduce the MMS failure in sending and receiving at will when wifi is on. As soon as i disable wifi, MMS sends and receives successfully. My cellular internet data works successfully as well. As soon as i turn wifi back on MMS's start hanging in both directions. This is on the official Sailfish X for Xperia.

I'm on consumer cellular btw, Dual mode, preferring 4G. CC resell att and tmobile.

Found an old closed bug over at jolla where they say this operator-specific, but my APN works perfectly in all ways when wifi is off, so i'm not sure.

https://together.jolla.com/question/...-wifi-enabled/


This is the last issue i have to solve to be thrilled with the device, but at least i have a workaround of disabling wifi when i see an MMS come in.
 

The Following User Says Thank You to Drekkie For This Useful Post:
Posts: 218 | Thanked: 569 times | Joined on Jun 2010 @ USA
#18
Originally Posted by Drekkie View Post
I can dependably reproduce the MMS failure in sending and receiving at will when wifi is on. As soon as i disable wifi, MMS sends and receives successfully. My cellular internet data works successfully as well. As soon as i turn wifi back on MMS's start hanging in both directions. This is on the official Sailfish X for Xperia.

I'm on consumer cellular btw, Dual mode, preferring 4G. CC resell att and tmobile.

Found an old closed bug over at jolla where they say this operator-specific, but my APN works perfectly in all ways when wifi is off, so i'm not sure.

https://together.jolla.com/question/...-wifi-enabled/


This is the last issue i have to solve to be thrilled with the device, but at least i have a workaround of disabling wifi when i see an MMS come in.
I have this same issue. I'm not sure if it was present on the community build, as I remember being able to send test MMS'es with WiFi toggled on.

I'll flash the community build a little later tonight to test this... for science.
__________________
Sony Xperia X SFOS 2.1.2.3, Nokia N810
 

The Following 3 Users Say Thank You to deprecated For This Useful Post:
Posts: 8 | Thanked: 40 times | Joined on Oct 2017
#19
Originally Posted by deprecated View Post
I have this same issue. I'm not sure if it was present on the community build, as I remember being able to send test MMS'es with WiFi toggled on.

I'll flash the community build a little later tonight to test this... for science.
I just saw the latest posts and I'm not sure if you've had a chance to test yet....but I can confirm that I definitely had the "MMS fails if wifi is enabled" issue in the community port. When I reflashed to the official build, I checked it out of curiosity and found it had the same bug. Disabling wifi instantly resolved the problem in both builds.

With both the community port and official release, I also had the problem where MMS settings do not persist following a reboot of the phone. This complicated my MMS troubleshooting efforts until I realized what was happening. I had to run the following command and reboot the phone after entering the correct settings:

Code:
devel-su chown -R radio:radio /var/lib/ofono
I found that fix on a forum somewhere. It appears to be variant of your own solution, but without a backup, so I like yours better. Fortunately, it seems to have permanently resolved the problem, though I was a bit surprised to see that bug make it into the official release. My guess is that the majority of testers didn't have to change their MMS settings like we do for T-Mobile USA so perhaps it slipped through the cracks. If T-Mobile were assigning the correct values to the device in the first place, I'd never have noticed it.

In any case, both of these MMS issues have easy workarounds or fixes, but I thought I'd share my experience. I have seen no difference whatsoever between the official release and the community port in regards to these bugs. Hopefully they will both be addressed in the next update. I've been living with Sailfish MMS problems for YEARS before we solved them via this thread, though, so I'm really not complaining! It's so nice to be able to *reliably* send and receive MMS these days.
 

The Following 3 Users Say Thank You to paulwk For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 17:17.