Notices


Reply
Thread Tools
Posts: 393 | Thanked: 67 times | Joined on Feb 2010
#1
Just came across this article...

http://www.metasploit.com/redmine/pr...i/Install_N900

Here is what Metasploit is: http://en.wikipedia.org/wiki/Metasploit_Project

Has anyone tried to install Metasploit on the N900? I recently tried installing it following these instructions, and the console seemed to have worked:

http://www.knownokia.ca/2010/01/metasploit-on-n900.html

However different instructions are offered at the official site at, which did not seem to work for me (probably my fault):

http://www.metasploit.com/redmine/pr...i/Install_N900

In case the first listed website disappears, the text from it is below:

"Firstly, you’ll need to add the extras-testing and extras-devel repository. If you don’t know how to do that, I suggest you cup both hands and place your head inside the void – you lose at the game of life. Stop crying, the above links will tell you how to activate.

Once you’ve updated your package list to include the above repos, you’ll need to install libopenssl-ruby (libopenssl-ruby1.8 might work too). You’ll also need the following ruby packages, I’ve modified and optified them to save as much space as possible:

ruby_1.8.5_armel-optified.deb

rubygems_0.9.2_armel.deb

ruby-sqlite3_1.2.1_armel.deb

Install them using ‘dpkg’ and then you’ll need to sym/softlink the libcrypto and libssl shared objects, so that any packages compiled against 0.9.7 that don’t force fault on explicit versions, will still work.

ln –s /usr/lib/libcrypto.so.0.9.8 /usr/lib/libcrypto.so.0.9.7

ln –s /usr/lib/libssl.so.0.9.8 /usr/lib/libssl.so.0.9.7

Now, if you have subversion installed, you can checkout the metasploit daily source snapshot. If you don’t use SVN, well – I’ve trimmed down, streamlined and modified a few files from the most recent svn co; no aux, no externals, no docs, no msfweb data at all.

msf.tar.bz2

H.D Moore has advised me that the metasploit team will be looking into embedded functionality in the near future. He recently got an N900 of his own so - boom, there goes the neighborhood.

If you don’t want to use db functionality, skip installing ruby-sqlite3 and save yourself the 100KB of space. If you do checkout from svn, you’ll run into a lot of stdout’d errors due to version inconsistencies with rails, sqlite and ruby. Annoying, but merely warnings. Fix it yourself by patching out the deprecation stuff, or use my tarball.

Now, go do whatever it is you do with these awesome tools"

---------------

The link locations for the above mentioned files can be found here:

http://dl.dropbox.com/u/4175560/ruby...l-optified.deb

http://dl.dropbox.com/u/4175560/ruby....9.2_armel.deb

http://dl.dropbox.com/u/4175560/ruby....2.1_armel.deb

http://dl.dropbox.com/u/4175560/msf.tar.bz2
Attached Images
 

Last edited by mail_e36; 2010-05-11 at 17:49.
 

The Following 6 Users Say Thank You to mail_e36 For This Useful Post:
Posts: 10 | Thanked: 4 times | Joined on Jan 2010 @ Washington, DC
#2
This is exciting!
 
Posts: 393 | Thanked: 67 times | Joined on Feb 2010
#3
Has anyone tried to install Metasploit on the N900? I recently tried installing it following these instructions, and the console seemed to have worked:

http://www.knownokia.ca/2010/01/metasploit-on-n900.html

However different instructions are offered at the official site at, which did not seem to work for me (probably my fault):

http://www.metasploit.com/redmine/pr...i/Install_N900

In case the first listed website disappears, the text from it is below:

"Firstly, you’ll need to add the extras-testing and extras-devel repository. If you don’t know how to do that, I suggest you cup both hands and place your head inside the void – you lose at the game of life. Stop crying, the above links will tell you how to activate.

Once you’ve updated your package list to include the above repos, you’ll need to install libopenssl-ruby (libopenssl-ruby1.8 might work too). You’ll also need the following ruby packages, I’ve modified and optified them to save as much space as possible:

ruby_1.8.5_armel-optified.deb

rubygems_0.9.2_armel.deb

ruby-sqlite3_1.2.1_armel.deb

Install them using ‘dpkg’ and then you’ll need to sym/softlink the libcrypto and libssl shared objects, so that any packages compiled against 0.9.7 that don’t force fault on explicit versions, will still work.

ln –s /usr/lib/libcrypto.so.0.9.8 /usr/lib/libcrypto.so.0.9.7

ln –s /usr/lib/libssl.so.0.9.8 /usr/lib/libssl.so.0.9.7

Now, if you have subversion installed, you can checkout the metasploit daily source snapshot. If you don’t use SVN, well – I’ve trimmed down, streamlined and modified a few files from the most recent svn co; no aux, no externals, no docs, no msfweb data at all.

msf.tar.bz2

H.D Moore has advised me that the metasploit team will be looking into embedded functionality in the near future. He recently got an N900 of his own so - boom, there goes the neighborhood.

If you don’t want to use db functionality, skip installing ruby-sqlite3 and save yourself the 100KB of space. If you do checkout from svn, you’ll run into a lot of stdout’d errors due to version inconsistencies with rails, sqlite and ruby. Annoying, but merely warnings. Fix it yourself by patching out the deprecation stuff, or use my tarball.

Now, go do whatever it is you do with these awesome tools"

---------------

The link locations for the above mentioned files can be found here:

http://dl.dropbox.com/u/4175560/ruby...l-optified.deb

http://dl.dropbox.com/u/4175560/ruby....9.2_armel.deb

http://dl.dropbox.com/u/4175560/ruby....2.1_armel.deb

http://dl.dropbox.com/u/4175560/msf.tar.bz2

Last edited by mail_e36; 2010-05-11 at 17:48.
 
Posts: 34 | Thanked: 6 times | Joined on Jun 2010 @ Falls Church
#4
How do i install the msf.tar.bz2 file,,,, can some one break down the instructions a little more for me i an a little new.
 
Posts: 12 | Thanked: 3 times | Joined on Jul 2010 @ Europa Majora
#5
I had trouble with the n900 tar program, i just don't know the commands too well. I unzipped it on my linux machine, transferred it to my phone, and then moved the folder over to

WARNING: it did take a while 24min to move the folder with the mv command.

mv msf3 /home/user/

I did get it to run but it takes a while for Metasploit to get running.

Last edited by evilsquelch; 2010-07-25 at 08:18.
 
Posts: 10 | Thanked: 8 times | Joined on Jan 2011 @ Malaysia
#6
Originally Posted by mukati View Post
How do i install the msf.tar.bz2 file,,,, can some one break down the instructions a little more for me i an a little new.
hi mukati, im guessing you dint install the chroot program,
because in that chroot they included tar-gnu which refering to bzip2 this file basically need command like:

Code:
 tar -jxvf filename.tar.bz2
but here im offering simple method for you todo this.

copy the file to correct path and extract it like this.

Code:
 bunzip2 -c filename.tar.bz2 | tar -xvf -
done.
 
Posts: 105 | Thanked: 87 times | Joined on Jun 2011 @ Unknown
#7
hi, does anybody knows what this error is:

/home/user/msf3/lib/rex/parser/ini.rb:144: command not found: infocmp -C

/home/user/msf3/lib/rex/parser/ini.rb:144: command not found: infocmp -C -r

any help is appreciated, thank you
 
Posts: 529 | Thanked: 194 times | Joined on Aug 2010 @ UK
#8
i follow instructions to the letter but when i start metaploit i am faced with this error marked in red any ideas how to solve this or whats gone wrong ...

Code:
home/user/MyDocs # ruby1.8 /home/user/msf3/msfconsole -L
[-] ***
[-] * WARNING: No database support: LoadError no such file to load -- rubygems
[-] ***

 ____________ 
< metasploit >
 ------------ 
       \   ,__,
        \  (oo)____
           (__)    )\
              ||--|| *


       =[ metasploit v3.3.4-dev [core:3.3 api:1.0]
+ -- --=[ 492 exploits - 0 auxiliary
+ -- --=[ 192 payloads - 23 encoders - 8 nops

msf >
after reinstalling the ruby gems i am now faced with this error

Code:
 WARNING: No database support: LoadError no such file to load -- active_record
is this never ending now i have this error any one have any ideas at all ??

Code:
ARNING: No database support: RuntimeError ruby lib version (1.8.5) doesn't match executable version (1.8.7)
what am i missing ere


many thanks



As far as i know these errors are fixed
__________________
METASPLOIT INSTALL N900
Keep the forums clean
Dont forget to say thanks

Last edited by stevomanu; 2011-09-21 at 23:50. Reason: added more info
 
Posts: 529 | Thanked: 194 times | Joined on Aug 2010 @ UK
#9
Yes im back still having grief with this tryed all sorts , this is the error im getting an i dont know how to fix can anybody help please ...

Code:
] ***
[-] * WARNING: No database support: RuntimeError ruby lib version (1.8.5) doesn't match executable version (1.8.7)
[-] ***

                ##                          ###           ##    ##
 ##  ##  #### ###### ####  #####   #####    ##    ####        ######
####### ##  ##  ##  ##         ## ##  ##    ##   ##  ##   ###   ##
####### ######  ##  #####   ####  ##  ##    ##   ##  ##   ##    ##
## # ##     ##  ##  ##  ## ##      #####    ##   ##  ##   ##    ##
##   ##  #### ###   #####   #####     ##   ####   ####   #### ###
                                      ##


       =[ metasploit v3.3.4-dev [core:3.3 api:1.0]
+ -- --=[ 492 exploits - 0 auxiliary
+ -- --=[ 192 payloads - 23 encoders - 8 nops

msf >
__________________
METASPLOIT INSTALL N900
Keep the forums clean
Dont forget to say thanks
 
Guest | Posts: n/a | Thanked: 0 times | Joined on
#10
Originally Posted by g0r View Post
hi, does anybody knows what this error is:

/home/user/msf3/lib/rex/parser/ini.rb:144: command not found: infocmp -C

/home/user/msf3/lib/rex/parser/ini.rb:144: command not found: infocmp -C -r

any help is appreciated, thank you
Seems to be a busybox/ncurses issue with missing symlinks. I have this error also, so far didnt resolve. Let me know if you figured it out
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 00:23.