Notices


Reply
Thread Tools
Posts: 126 | Thanked: 204 times | Joined on Feb 2017 @ Tbilisi, Georgia (caucasus)
#261
Originally Posted by mautz View Post
Your persist partition is corrupted. This also causes your wifi issues.

Maybe this can help you to repair the partition:

https://forum.xda-developers.com/goo...ition-t2821576
This did not help but i tried to copy those files in the Sailfish OS in /persist folder and you no what? It worked Now i have the same mac address even if i reboot and the bonus is that i can always change it easily

I wanted to fix my corupted /persist partition found some guides but it's a nice "feature" to have. If i just rename that .macaddr file or change mac in it with hexeditor and reboot mac address changes

Do not have other files what you have on your phone in /persist but everything seems to work now. I am worried that there may be some GPS stuff, i did not test but now i'll try to update to 2.1.3.7 and check if GPS is working.

But all the sensors stopped working. All of them. Just checked i think it's related to that /persist partition. After all i will have to fix that issue.

Last edited by matemana; Yesterday at 18:25.
 

The Following 2 Users Say Thank You to matemana For This Useful Post:
Posts: 380 | Thanked: 1,028 times | Joined on Feb 2014 @ Germany
#262
Originally Posted by bomo View Post
So its safe for us to use OTA to get 2.1.3.7? I'm just asking because I couldn't find a hint in this regarding in the opening post.
I just did a fresh install of 2.1.2.3 and OTAed to 2.1.3.7 and everything is working as expected including GPS. On my old installation GPS was broken since the early 2.1.x builds, maybe i messed something up in the config files. I did not mention this in the opening post, since i didn't know if this problem did appear on all installations or if it was simply my phone which didn't work well.
So, if you update, give some feedback to the forum, so that others now if everything is working.

@matemana

Glad everything is working now Could you please report back after you OTA if everything works as expected?

Do you have the files in /persist/sensors?
What does 'devel-su systemctl status sensorfwd.service' say?

Last edited by mautz; Yesterday at 18:32.
 

The Following 2 Users Say Thank You to mautz For This Useful Post:
Posts: 126 | Thanked: 204 times | Joined on Feb 2017 @ Tbilisi, Georgia (caucasus)
#263
Originally Posted by mautz View Post
I just did a fresh install of 2.1.2.3 and OTAed to 2.1.3.7 and everything is working as expected including GPS. On my old installation GPS was broken since the early 2.1.x builds, maybe i messed something up in the config files. I did not mention this in the opening post, since i didn't know if this problem did appear on all installations or if it was simply my phone which didn't work well.
So, if you update, give some feedback to the forum, so that others now if everything is working.

@matemana

Glad everything is working now Could you please report back after you OTA if everything works as expected?

Do you have the files in /persist/sensors?
What does 'devel-su systemctl status sensorfwd.service' say?
I think my report will simply not be true for others. It's something with my phone being not normal. Since i checked GPS and it did not work too and that systemctl sensorsfd command gave that it did not find sensors. I found that some files related to sensors are on that /persist partition. I do not know how to fix that. Tried your link and found one other but it did not work. It simply removes all the files i put in /persist after reboot.

Now i installed the original android nexus 5 came with 4.4 and i have the same issue with mac address changing on every reboot. /persist is empty there are no files. Here is ls

Code:
~ # cd persist/
/persist # ls
/persist # ls -la
__bionic_open_tzdata: couldn't find any tzdata when looking for localtime!
__bionic_open_tzdata: couldn't find any tzdata when looking for GMT!
__bionic_open_tzdata: couldn't find any tzdata when looking for posixrules!
drwxrwxrwx    2 root     root             0 Jan  4  1970 .
drwxr-xr-x   24 root     root             0 Jan  4  1970 ..
But rotation does work and other sensors too! I do not know what to do else...

I did not have these issues on this phone when 2.0.4.13 was the latest version for it. I do not blame newer image i just said when i did not have these problems

P.S. boy android 4.4 is fast it boots in 17 seconds
 

The Following 2 Users Say Thank You to matemana For This Useful Post:
Posts: 380 | Thanked: 1,028 times | Joined on Feb 2014 @ Germany
#264
Have you tried reformatting the persist partition and recreatting all files and folders as described in the guide?
 

The Following 2 Users Say Thank You to mautz For This Useful Post:
Posts: 126 | Thanked: 204 times | Joined on Feb 2017 @ Tbilisi, Georgia (caucasus)
#265
Originally Posted by mautz View Post
Have you tried reformatting the persist partition and recreatting all files and folders as described in the guide?
Of course i ran

adb shell
e2fsck /dev/block/platform/msm_sdcc.1/by-name/persist
make_ext4fs /dev/block/platform/msm_sdcc.1/by-name/persist
and created those folders and files as in the guide but as i said everything is removed after reboot.

Also here https://yeri.be/nexus-5-boot-loop after running

e2fsck /dev/block/platform/msm_sdcc.1/by-name/persist

command he gets
Code:
e2fsck 1.42.9 (28-Dec-2013)
Superblock has an invalid journal (inode 8).
Clear<y>? y
yes
*** ext3 journal has been deleted - filesystem is now ext2 only ***
Superblock has_journal flag is clear, but a journal inode is present.
Clear<y>? yes
/dev/block/platform/msm_sdcc.1/by-name/persist was not cleanly unmounted, check forced.
Pass 1: Checking inodes, blocks, and sizes
Journal inode is not in use, but contains data. Clear<y>?
yes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
Block bitmap differences: -(75--1098)
Fix<y>?
yes
Free blocks count wrong for group #0 (2972, counted=3996).
Fix<y>?
yes
Free blocks count wrong (2972, counted=3996).
Fix<y>?
yes
Recreate journal<y>?
yes
Creating journal (1024 blocks): Done.
*** journal has been re-created - filesystem is now ext3 again ***
/dev/block/platform/msm_sdcc.1/by-name/persist: ***** FILE SYSTEM WAS MODIFIED *****
/dev/block/platform/msm_sdcc.1/by-name/persist: 30/1024 files (3.3% non-contiguous), 1124/4096 blocks
I only get line like this and that's it.

/dev/block/platform/msm_sdcc.1/by-name/persist: 30/1024 files (3.3% non-contiguous), 1124/4096 blocks

Seems my partition is not corupted but do not know where are all the files and why they do not exist even when i flashed factory image 4.4
 

The Following User Says Thank You to matemana For This Useful Post:
Posts: 380 | Thanked: 1,028 times | Joined on Feb 2014 @ Germany
#266
For sure e2fsck doesn't find any erors, if you have formatted the partition. Which files are now on this partition? I think the normal flashing process doesn't touch the persist partition. Have you treid this approach?

http://hacks-galore.org/aleix/archiv...-wifes-nexus-5
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 07:05.