Notices


Reply
Thread Tools
Posts: 32 | Thanked: 15 times | Joined on Apr 2016 @ Austria
#91
for telegram you may be able to find third party derivats. perhaps these function more to you liking. it's worth a shot, at least.
 
Posts: 101 | Thanked: 241 times | Joined on Jun 2014 @ Joensuu, Finland
#92
Originally Posted by gianko View Post
What about emojis? We can unpack these on ~/.purple/smileys or it will waste rootfs space?
Has somebody made a deb package of those emojis for Pidgin? Or has somebody got them working somehow? I tried to extract them to /opt and make symbolic link to ~/.purple/smileys as suggested, but they don't show up in Pidgin's smiley list.

Last edited by Koiruus; 2018-02-24 at 01:25. Reason: stupid me
 
Posts: 488 | Thanked: 1,321 times | Joined on Feb 2012 @ Germany
#93
Originally Posted by Koiruus View Post
Has somebody made a deb package of those emojis for Pidgin? Or has somebody got them working somehow? I tried to extract them to /opt and make symbolic link to ~/.purple/smileys as suggested, but they don't show up in Pidgin's smiley list.
I think there is no deb yet. With which user you made the symlink, do you see the emojis in /home/user/.purple/smileys ?
I would say just copy to this path, in home it should not eat up root.

Compiled latest version of the plugin. If it is working it goes to extras. So please test.

Last edited by Halftux; 2018-02-27 at 12:01. Reason: removed old version
 

The Following 4 Users Say Thank You to Halftux For This Useful Post:
Community Council | Posts: 564 | Thanked: 847 times | Joined on Sep 2010 @ Mbabane
#94
Originally Posted by Halftux View Post
Compiled latest version of the plugin. If it is working it goes to extras. So please test.
Thanks!
But it seems to be non-working, at least for me. `pidgin -dn` shows the following
Code:
plugins: probing /usr/lib/purple-2/telegram-purple.so
plugins: /usr/lib/purple-2/telegram-purple.so is not loadable: undefined symbol: g_format_size
prpl-telegram: tgprpl_init finished: This is 1.3.1+g065e0b7ac9 on libtgl 2.1.0
I have pidgin 2.10.11.
 

The Following 2 Users Say Thank You to sicelo For This Useful Post:
Posts: 488 | Thanked: 1,321 times | Joined on Feb 2012 @ Germany
#95
Originally Posted by sicelo View Post
Thanks!
But it seems to be non-working, at least for me. `pidgin -dn` shows the following
Code:
plugins: probing /usr/lib/purple-2/telegram-purple.so
plugins: /usr/lib/purple-2/telegram-purple.so is not loadable: undefined symbol: g_format_size
prpl-telegram: tgprpl_init finished: This is 1.3.1+g065e0b7ac9 on libtgl 2.1.0
I have pidgin 2.10.11.
Ok I will look into it. Thanks for trying.
 

The Following User Says Thank You to Halftux For This Useful Post:
Posts: 488 | Thanked: 1,321 times | Joined on Feb 2012 @ Germany
#96
So i fixed that glib error and did not see any further errors. So next try please.

Last edited by Halftux; 2018-03-08 at 17:03. Reason: in extras now
 

The Following 3 Users Say Thank You to Halftux For This Useful Post:
Community Council | Posts: 564 | Thanked: 847 times | Joined on Sep 2010 @ Mbabane
#97
@Halftux
Yes, the latest version works

Thank you very much!

Might suggest optifying it, if it's feasible.
 

The Following User Says Thank You to sicelo For This Useful Post:
Posts: 488 | Thanked: 1,321 times | Joined on Feb 2012 @ Germany
#98
Originally Posted by sicelo View Post
Might suggest optifying it, if it's feasible.
I think the automation optify process from autobuilder brakes that package (like the last one). Atm I am working on optify it manually, but it looks tricky. I could make an ugly postinstall hack but I dont want. Let's see.
 

The Following 2 Users Say Thank You to Halftux For This Useful Post:
Posts: 488 | Thanked: 1,321 times | Joined on Feb 2012 @ Germany
#99
I uploaded an optified version to maemo extras-devel

purple-protocol-telegram 1.3.1-4

purple-protocol-telegram: optified 14 entries, saving about 1469 kB.
So I think the package in extras is fixed and updated.
And hopefully it is working for you.
 

The Following 6 Users Say Thank You to Halftux For This Useful Post:
Posts: 17 | Thanked: 3 times | Joined on May 2014 @ Argentina
#100
i was having the problem where telegram was not showing up on pidgin´s drop down list, so i un-installed/purged pidgin and purple protocol telegram and tried to re install them but now neither are showing up in the application manager, tried doing it trough the terminal, but it just fails.

sorry if this come across as a very noob question, but its been like 3 years since i used my n900 and i honestly do not remember much
 
Reply

Tags
pidgin, telegram

Thread Tools

 
Forum Jump


All times are GMT. The time now is 12:57.