Thread Tools
Posts: 26 | Thanked: 7 times | Joined on Jan 2008
I got my new n810 this past Thursday and so for I am loving it! However, the touch screen doesn't seem to work properly. Sometimes it's right on the money, other times it's not. Trying to grab a scroll bar can be an exercise in frustration. If I try to hit the trashcan icon in the file manager it instead highlights the whole column of files (like doing a Ctrl + A on a PC) but doesn't offer to delete them. When scrolling thru the home menus I have to touch the screen well below the scroll arrows. Sometimes if I try to grab an applet from the bottom of the desktop to move it, it will instead cause one of the other applets to jump to where I touched the screen.

And yes, I have calibrated many times with the built in tool. Even then when I tap the center of the target it will sometimes tell me to move closer to the target.

I have also re flashed and updated everything. That did seem to help some as it's not a severe as before, but it's still annoying as hell.

Are there any other hidden calibration settings? Another tool I could download and use? Should I just send the unit back for an exchange?


Yes, I do make sure my palm or a finger is not touching the screen when I am using the stylus. Only it touches the screen.
Posts: 479 | Thanked: 58 times | Joined on Dec 2007 @ Dubai, UAE
Do you have a screen protector on? In some cases, an improperly applied screen protector will cause this problem. If not, perhaps you have a defective unit and should consider a return.
Posts: 26 | Thanked: 7 times | Joined on Jan 2008
I do not have a screen protector.
I've re-flashed it yet again and that seems to have helped. It's much better, but still not perfect. It seems to be worse when I tap something close to the bezel or links on a website.

Am I being to picky? I have an Archos 605 WiFi and I have no issues at all with that touchscreen.
Posts: 26 | Thanked: 7 times | Joined on Jan 2008
Just for future reference and for anyone who has this same problem; i re-flashed several times and re-calibrated half a dozen times and it seems to be working fine now.

i'm luvin my new n810!!

thanks for the responses...
GeneralAntilles's Avatar
Posts: 5,478 | Thanked: 5,215 times | Joined on Jan 2006 @ St. Petersburg, FL
Everybody does realize that you can recalibrate the touchscreen, right?
Posts: 11 | Thanked: 0 times | Joined on Feb 2007 @ Sydney
Same problem. I've had my N800 for almost a year, and love it. I use it at home many times per day, and have travelled domestically and internationally with it. It's the only piece of hardware which has enthused me for the last 10 years, and I would not be without it.

BUT, starting a couple of weeks ago, the screen has become more and more inaccurate. When navigating small menus, I have to touch almost one full menu line above the item I really want (for items closest to bottom left corner). With the small keyboard, the bottom row chars can only be selected by clicking in their absolute top right corners. Very tricky.

I've recalibrated half a dozen times, and now when I recal, for target 4 (bottom left corner), it rejects my tap, saying "tap closer to target 4". Hey, I'm right on it - but the OS obviously thinks I'm so far off-target that I've gotta be kidding. How do I make it see sense ?
Posts: 8 | Thanked: 0 times | Joined on Jan 2008
I am having this same N810 has been working wonderfully, and suddenly today the touchscreen is not working correctly. I have re-calibrated it three times, restarted it, taken the battery out twice, and still it is not working right. Sometimes it seems to think I'm tapping somewhere different from where I am, but other times it doesn't respond at all. I'm getting really concerned. How do I reflash, and do you think it's worth it? Or should I just keep recalibrating it over and over? When I recalibrate it, target 3 often doesn't sense that I'm tapping it.
PJE's Avatar
Posts: 58 | Thanked: 16 times | Joined on Oct 2007 @ Michigan, USA
Add me to the list of people experiencing sudden touch screen inaccuracies (N800 OS2008). The pen keyboard works about 90% of the time sensing the correct key, but a couple of regions are not accurate and the key below the one selected is pressed...

I've recalibrated (numerous times), and even attempted to compensate for the issue by pressing the four points with an intentional error, but the problem still exists.

I'm thinking a reflash is in my future
“Never trust a computer you can't throw out a window.” - Steve Wozniak.
Posts: 8 | Thanked: 0 times | Joined on Jan 2008
Ok, the weirdness continues.

While continuing the various restarts and calibrations, I got a memory error message - "operation temporarily discontinued due to low memory" or something to that effect. So, I took the memory card out and put it back in. (this memory card has never given me any trouble in the past, and I have not installed any new software in the past few days). When I restarted, my touch screen appears to work again! I opened Mahjong to test it (definitely a high- touchscreen game) and got the error message, "not enough memory in target location." However, when I hit "ok" the game did come up and worked fine. Now I get "not enough memory in target location" if I start a Mahjong game or if I close the program. And occasionally I get the "temporarily discontinued due to low memory" message.

If this were my Windows PC, I would think I had a virus. I will reflash when I get home tonight (found the link in another thread) but if you're having touch screen probs, it can't hurt to take out the memory card and put it back in. If you do that, please post whether it works or not and whether you get any error messages, if you don't mind.
Posts: 26 | Thanked: 7 times | Joined on Jan 2008
a reflash may be what you need. that is what i had to do, plus recalibrate it several times after that. it works great now. keeping my fingers crossed!

Thread Tools

Forum Jump

All times are GMT. The time now is 12:33.