Notices


Reply
Thread Tools
Posts: 16 | Thanked: 13 times | Joined on Aug 2010 @ Chicago, Illinois, USA
#1
I have been using my N900 for about six years with little problem. Recently I went camping in Giant City State Park in Illinois. Now I have a problem. It started when I was trying to charge the N900 in the lodge there. The N900 shut down. The battery drained, and I haven't been able to charge it with the normal power cord. I hadn't been able to get it to charge for weeks. I've been using an external battery charger. The USB connection hasn't fallen off, I can still stick the plug in. Too, I have an LG phone with a similar microusb charger. I stuck that one in last week, and it works to charge the N900. Unfortunately I can't get the N900 to connect to an external cpu for "mass storage" file transfers. I also noticed that while the N900's off it drains the battery; the keyboard stays lit. So what's wrong?
 
Community Council | Posts: 526 | Thanked: 714 times | Joined on Sep 2010 @ Mbabane
#2
your USB *is* very likely broken. sometimes, even though the port seems intact, the pads might already be loose. also, the protruding part inside the port can break on the inside.
 

The Following 4 Users Say Thank You to sicelo For This Useful Post:
Posts: 16 | Thanked: 13 times | Joined on Aug 2010 @ Chicago, Illinois, USA
#3
Yet a similar charger works.
 

The Following User Says Thank You to bradvesp For This Useful Post:
endsormeans's Avatar
Posts: 2,013 | Thanked: 4,642 times | Joined on Feb 2013 @ Supa Natural Vancouver Island
#4
I have noticed in the past that ..compared to the n8x0's chargers..
the usb chargers for the n900 can be more finicky ..
I have had some n900 chargers that worked fine forever and a day...
others that worked fine or seemed to ....and then after a few years started becoming problematic...
In the last 5 years I have found 2 n900 chargers (official nokia ones...at that...) that I labeled problematic and set aside..

If the battery is fine...
and the internal connection is fine..
and it works fine with another charger...
Then I suspect the charger is the culprit...or a leading cause at the least...
(based on what odd behaviour I have come to see.)
__________________
Lurker since 2007, Member since 2013, Certifiable since 1972
Owner of : 1-n770 (in retirement),
3-n800's,
3-n810's,
5-n900's
-3 flawless
-1 loose usb (i don't muck with it & stress it , considering selling it, another can fix the loose usb)
-1 no telephony (perfect for permanent set-up as mini-pc with one of my monitors)
half a neo900 pre- "bought"....due for production any day now.


PIMP MY N8X0
Everything you need tightly explained in layman's terms ..in an easy to understand format.. and a video walkthrough to boot.
http://talk.maemo.org/showthread.php?t=94294
THE LOST GRONMAYER CATALOGS
http://talk.maemo.org/showthread.php...ight=gronmayer
N8X0 VIDEO ENCODING THE EASY WAY
http://talk.maemo.org/showthread.php...ght=mediacoder
242gb ON N800
http://talk.maemo.org/showthread.php?t=90634

THE PAIN-FREE MAEMO DEVELOPMENT LIVE DISTRO-ISO FOR THE NOOB TO THE PRO
http://talk.maemo.org/showthread.php?t=95567

AFFORDABLE MASS PRODUCTION FOR MAEMO PARTS
http://talk.maemo.org/showthread.php?t=93325
 

The Following User Says Thank You to endsormeans For This Useful Post:
Community Council | Posts: 526 | Thanked: 714 times | Joined on Sep 2010 @ Mbabane
#5
simple test - does the N900 charger work on another phone? :-)
 

The Following User Says Thank You to sicelo For This Useful Post:
pichlo's Avatar
Posts: 4,930 | Thanked: 14,757 times | Joined on Sep 2012 @ UK
#6
Originally Posted by bradvesp View Post
Unfortunately I can't get the N900 to connect to an external cpu for "mass storage" file transfers.
That is a clear indication that your USB port is broken. The fact that another charger works may be because of a very slightly different shape of the connector, possibly the teeth, pushing the connector less off the PCB. That is also a good hint that the problem is fixable, you just need to open the phone and solder the connector back down.

I also noticed that while the N900's off it drains the battery; the keyboard stays lit.
I don't get that bit.
__________________
In particle accelerators atoms are indeed not only touching each others. But banging together in a massive explosive orgasm.
-- nieldk in a TMO post
 

The Following 3 Users Say Thank You to pichlo For This Useful Post:
Posts: 1,075 | Thanked: 1,533 times | Joined on Jan 2011 @ Touring
#7
Originally Posted by bradvesp View Post
the keyboard stays lit. So what's wrong?
Get the app healthcheck from the repos and see if your KB sensor is working.

In one case I had a N900 keyboard light logic stuck to ON, I eventually just desoldered it, the battery connection was wonky and I constantly had bad shutdowns which eventually lead to the stuck LED, it could have been one of my fake 'new' Chinese (new exterior) N900 refurbs. It persisted through several full reflashes and being left for several months without a battery.


I have done the microUSB fix before, if you can do SM soldering it is not so bad, see this thread
http://talk.maemo.org/showthread.php?t=37107
and there is another with more soldering tips, and less advice to get a warranty replacement.
http://talk.maemo.org/showthread.php?t=75920
Hot air and solder paste fix is ideal but I have always just used a soldering iron and regular 50/50 lead/tin rosin core solder. Be sure to solder wick away as much solder and IMHO increase the solder footprint by scraping more ground plane clean and tinning it a little. Just please be careful removing the port if you are replacing and not just re-soldering the broken connection as it is super easy to rip up the pads.

Last edited by biketool; 2017-09-14 at 08:32.
 

The Following 2 Users Say Thank You to biketool For This Useful Post:
Posts: 16 | Thanked: 13 times | Joined on Aug 2010 @ Chicago, Illinois, USA
#8
I have done never soldered a thing in my life, but I did lay soldering lead/tin in a channel in a wood table I built once, I just never melted it.
Maybe I'll try soldering this, but will have to practice.
Any chance I could tap it into place? I'm going to replace the N900 screen soon, so I'll have it in parts.
 
Posts: 1,075 | Thanked: 1,533 times | Joined on Jan 2011 @ Touring
#9
Originally Posted by bradvesp View Post
Maybe I'll try soldering this, but will have to practice.
Take some broken surface mount electronics and try to solder and unsolder parts from the printed circuit board. Or maybe there is a phone repair shop where they can do a hot air rework fix, which is actually preferred for surface mount components.
 

The Following User Says Thank You to biketool For This Useful Post:
Posts: 16 | Thanked: 13 times | Joined on Aug 2010 @ Chicago, Illinois, USA
#10
Yep, the shift, function and ctrl keys stay brightly lit while the things off. The Q, A, Z are lit but more dimly; as are each keys progressing to the right.

What are the risks to the device if I try soldering in that area and screw it up? What can get damaged around there?
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 03:17.