Notices


Reply
Thread Tools
Posts: 42 | Thanked: 39 times | Joined on Jan 2015 @ Italy
#11
i don't know, pcmanfm supports samba since 0.4.4
do you have /usr/lib/gvfs ?
search also for gvfsd-smb and gvfsd-smb-browse
Code:
 find /usr -type f | xargs grep -l gvfsd-smb
also, install 'fusesmb'

have you tried launching pcmanfm from the terminal?

thunar supports samba since 1.2, and relies on gvfs, but good luck with installing that in debian 6.0 without breaking A LOT of dependencies...

you can also try using 'smbc', if that works then it's pcmanfm fault for sure, and you should upgrade it
 

The Following 2 Users Say Thank You to u7knv9h For This Useful Post:
Posts: 56 | Thanked: 59 times | Joined on Jan 2015
#12
Although I'm not yet solving this problem, your troubleshooting has taught me a great deal, and thank you for it.

After updating to PCMANFM 0.9.7, I have /usr/lib/gvfs, gvfsd-smb, and gvfsd-smb-browse.

Running pcmanfm in chroot terminal, trying to access Go/Network Drives gives this error in terminal:

** (pcmanfm:3922): DEBUG: FmJob error: Operation not supported

Trying to install fusesmb and smbc gives me a ton of broken package errors and no installation:

"The following packages have unmet dependencies:
fusesmb: Depends: samba-common-bin but it is not going to be installed
initscripts: Breaks: rsyslog (< 5.8.2-2) but 4.4.2-1 is to be installed
libasound2: Breaks: libasound2-plugins (< 1.0.24) but 1.0.21-3 is to be installed
libglib2.0-0: Breaks: gvfs (< 1.8) but 1.6.4-3 is to be installed
libpolkit-backend-1-0: Breaks: policykit-1 (< 0.99) but 0.96-4+squeeze2 is to be installed
libpolkit-gobject-1-0: Breaks: policykit-1 (< 0.99) but 0.96-4+squeeze2 is to be installed


In sources.list, I have every repo un-commented, which is how I updated pcmanfm (through sid) to 0.9.7 in the first place. But it seems that these installations are wishing for older libs.

[root@chroot: /]sudo apt-get install smbc
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
initscripts: Breaks: rsyslog (< 5.8.2-2) but 4.4.2-1 is to be installed
libasound2: Breaks: libasound2-plugins (< 1.0.24) but 1.0.21-3 is to be installed
libglib2.0-0: Breaks: gvfs (< 1.8) but 1.6.4-3 is to be installed
libpolkit-backend-1-0: Breaks: policykit-1 (< 0.99) but 0.96-4+squeeze2 is to be installed
libpolkit-gobject-1-0: Breaks: policykit-1 (< 0.99) but 0.96-4+squeeze2 is to be installed
E: Broken packages
[root@chroot: /]

My goal is pretty simple: getting the hostname rather than the ip address to work in pcmanfm or thunar (nautilus will not install, no matter what the repo):

smb://c4/Documents

Thanks again for your very instructive help,
Jake

Last edited by jakfish; 2015-03-18 at 15:04.
 

The Following 2 Users Say Thank You to jakfish For This Useful Post:
Posts: 42 | Thanked: 39 times | Joined on Jan 2015 @ Italy
#13
no problem jakfish!
anyway this seems really like a bug, and i've found this

https://bugs.debian.org/cgi-bin/bugr...cgi?bug=699674

especially, #5 and #29 may be useful

in short, the current (or better, the one you're using) libfm is buggy, so you should upgrade it, along with pcmanfm. with debian armel, in sid, jessie, and wheezy-backports repos, there are new versions of 'libfm' and 'pcmanfm'

or you can try another file manager to use samba, like komba2, konqueror or jags
 

The Following 2 Users Say Thank You to u7knv9h For This Useful Post:
Posts: 56 | Thanked: 59 times | Joined on Jan 2015
#14
In sources.list, I've commented-out everything except:

deb http://http.debian.net/debian wheezy-backports main

from:

http://backports.debian.org/Instructions/#index2h2

apt-get update complains about a pubkey, which is fixed by:

gpg --keyserver pgpkeys.mit.edu --recv-key 8B48AD6246925553
gpg -a --export 8B48AD6246925553 | sudo apt-key add -

from:

http://raspberrypi.stackexchange.com...rts-debian-org

But when I try:

apt-get -t wheezy-backports install pcmanfm

I get a million complaints about dependencies that can't be upgraded to the new pcmanfm.

Konqueror, jags, and komba2 are not available. Have I hit a wall? Or is there another workaround?

Thanks,
Jake
 

The Following User Says Thank You to jakfish For This Useful Post:
Posts: 715 | Thanked: 2,116 times | Joined on Jan 2011 @ Germany
#15
Originally Posted by u7knv9h View Post
mh, i don't know exactly about thunar and pcmanfm (i don't use any file manager on my machines, always commandline tools) but maybe they require some packages, like 'gvfs' 'fuse-utils' 'gvfs-backends'
They do. But don't ask me for details! I never really understood this gvfs stuff and I don't use smb.

Originally Posted by jakfish View Post
(is squeeze armel incompatible with "easy debian"?).
The only incompatbility I'm aware of is in pulseaudio. (More precicely: It's not an incompatibility between ED and Debian but between Maemo and Debian which ED has to take care of. But that only affects the N900 afaik.)
On top of that there are some problems with some programs on the N900 which seem to be related to buggy armel features on Maemo's side. But I don't know if this applies to the N8x0 versions too.

What image are you using? The early "Squeeze" images were actually a mix of Lenny and Squeeze due to some problems qole had during the dist-upgrade process.

Originally Posted by jakfish View Post
"The following packages have unmet dependencies:
fusesmb: Depends: samba-common-bin but it is not going to be installed
initscripts: Breaks: rsyslog (< 5.8.2-2) but 4.4.2-1 is to be installed
libasound2: Breaks: libasound2-plugins (< 1.0.24) but 1.0.21-3 is to be installed
libglib2.0-0: Breaks: gvfs (< 1.8) but 1.6.4-3 is to be installed
libpolkit-backend-1-0: Breaks: policykit-1 (< 0.99) but 0.96-4+squeeze2 is to be installed
libpolkit-gobject-1-0: Breaks: policykit-1 (< 0.99) but 0.96-4+squeeze2 is to be installed


In sources.list, I have every repo un-commented, which is how I updated pcmanfm (through sid) to 0.9.7 in the first place. But it seems that these installations are wishing for older libs.
This is most likely a result of the aforementioned Lenny/Squezee mix. A proper dist-upgrade to Squeeze should help.

Originally Posted by jakfish View Post
In sources.list, I've commented-out everything except:

deb http://http.debian.net/debian wheezy-backports main

[..]

But when I try:

apt-get -t wheezy-backports install pcmanfm

I get a million complaints about dependencies that can't be upgraded to the new pcmanfm.

Konqueror, jags, and komba2 are not available. Have I hit a wall? Or is there another workaround?
1. You're trying to mix three releases. That almost certainly causes trouble. Even mixing two is delicate at best.
2. With only backports enabled most of the packages won't be available. So whatever package you want from the backports will likely miss some dependencies.

I'd suggest you try a more recent image, based on Wheezy.
 

The Following User Says Thank You to sulu For This Useful Post:
Posts: 42 | Thanked: 39 times | Joined on Jan 2015 @ Italy
#16
Originally Posted by jakfish View Post
In sources.list, I've commented-out everything except:

deb http://http.debian.net/debian wheezy-backports main

from:

http://backports.debian.org/Instructions/#index2h2
mh, try using official mirrors in the sources, like

Code:
 deb http://ftp.debian.org/debian wheezy main
(note the .org domain)
after you've replaced all the wrong mirrors (try accessing them, you'll get a 404, they don't exist), run

Code:
 apt-get update
and that should fix some stuff

(read https://wiki.debian.org/Backports )

Originally Posted by jakfish View Post

But when I try:

apt-get -t wheezy-backports install pcmanfm

I get a million complaints about dependencies that can't be upgraded to the new pcmanfm.

Konqueror, jags, and komba2 are not available. Have I hit a wall? Or is there another workaround?

Thanks,
Jake
same as before, fix the repos
also, as sulu said, some problems are a result of mixing packages from different sources, but imo they shouldn't be this kind of problems, since apt takes care of a lot of things for you

same for the missing konqueror, jags, and komba2, fixing the repos should do it
don't forget to update the package list!
Code:
 apt-get update
 

The Following User Says Thank You to u7knv9h For This Useful Post:
Posts: 56 | Thanked: 59 times | Joined on Jan 2015
#17
Many thanks once more for everybody's patience and thorough help. However, the project seems to have failed.

After clearing just enough room for the wheezy dist-upgrade, the process crashes when it complained for an upgrade lenny kernel (why dist-upgrade couldn't take care of that is beyond me).

After installing a lenny repo, I have a huge choice of kernels, none of which seemed connected to "easy debian." The whole thing is so cumbersome and I find myself lost.

Failure can be just as instructive as success, and again, I very much appreciate everybody's assistance. You taught me many things.

Jake
 

The Following User Says Thank You to jakfish For This Useful Post:
endsormeans's Avatar
Posts: 2,013 | Thanked: 4,642 times | Joined on Feb 2013 @ Supa Natural Vancouver Island
#18
I vaguely recall qole mentioning something a long time ago about being careful about "how" you update lenny.
that could be issue 1 you are having.
easy deb (lenny) for the n8x0 is pretty old...I'm sure that given enough fiddling you could get it where you want it though.
If you have had enough for now ..just set it aside for a bit aaaannnddd...
Play with Inferno os instead!
__________________
Lurker since 2007, Member since 2013, Certifiable since 1972
Owner of : 1-n770 (in retirement),
3-n800's,
3-n810's,
5-n900's
-3 flawless
-1 loose usb (i don't muck with it & stress it , considering selling it, another can fix the loose usb)
-1 no telephony (perfect for permanent set-up as mini-pc with one of my monitors)
half a neo900 pre- "bought"....due for production any day now.


PIMP MY N8X0
Everything you need tightly explained in layman's terms ..in an easy to understand format.. and a video walkthrough to boot.
http://talk.maemo.org/showthread.php?t=94294
THE LOST GRONMAYER CATALOGS
http://talk.maemo.org/showthread.php...ight=gronmayer
N8X0 VIDEO ENCODING THE EASY WAY
http://talk.maemo.org/showthread.php...ght=mediacoder
242gb ON N800
http://talk.maemo.org/showthread.php?t=90634

THE PAIN-FREE MAEMO DEVELOPMENT LIVE DISTRO-ISO FOR THE NOOB TO THE PRO
http://talk.maemo.org/showthread.php?t=95567

AFFORDABLE MASS PRODUCTION FOR MAEMO PARTS
http://talk.maemo.org/showthread.php?t=93325
 

The Following 2 Users Say Thank You to endsormeans For This Useful Post:
Posts: 56 | Thanked: 59 times | Joined on Jan 2015
#19
Inferno...hmmmm, good idea

http://forums.debian.net/viewtopic.php?f=5&t=108327

This user is having the same error messages that I'm getting--though he's working with an etch kernel--and it doesn't appear solvable.

Jake
 
endsormeans's Avatar
Posts: 2,013 | Thanked: 4,642 times | Joined on Feb 2013 @ Supa Natural Vancouver Island
#20
hm...
yea...
installing easy deb is ..well...easy
running it is easy too...
installing some stuff is just as easy...
the hard part is really "altering" it's structure ... once you are inside.

as far as inferno goes...I added a few more reference urls..
check out ...

http://talk.maemo.org/showthread.php...22#post1461422
__________________
Lurker since 2007, Member since 2013, Certifiable since 1972
Owner of : 1-n770 (in retirement),
3-n800's,
3-n810's,
5-n900's
-3 flawless
-1 loose usb (i don't muck with it & stress it , considering selling it, another can fix the loose usb)
-1 no telephony (perfect for permanent set-up as mini-pc with one of my monitors)
half a neo900 pre- "bought"....due for production any day now.


PIMP MY N8X0
Everything you need tightly explained in layman's terms ..in an easy to understand format.. and a video walkthrough to boot.
http://talk.maemo.org/showthread.php?t=94294
THE LOST GRONMAYER CATALOGS
http://talk.maemo.org/showthread.php...ight=gronmayer
N8X0 VIDEO ENCODING THE EASY WAY
http://talk.maemo.org/showthread.php...ght=mediacoder
242gb ON N800
http://talk.maemo.org/showthread.php?t=90634

THE PAIN-FREE MAEMO DEVELOPMENT LIVE DISTRO-ISO FOR THE NOOB TO THE PRO
http://talk.maemo.org/showthread.php?t=95567

AFFORDABLE MASS PRODUCTION FOR MAEMO PARTS
http://talk.maemo.org/showthread.php?t=93325
 

The Following User Says Thank You to endsormeans For This Useful Post:
Reply

Tags
easy debian, nokia n8x0

Thread Tools

 
Forum Jump


All times are GMT. The time now is 18:30.