Thread Tools
Posts: 813 | Thanked: 1,132 times | Joined on Jul 2010 @ Brittany, France
Nope, no window opening. It did work well when I untared the rootfs as nemo and then fixed the uid 0 issues, but that certainly caused a lot of other issues that maybe did not prevent opening xwayland, but surely would have caused a lot of other permission issues. I just did not play much with it when it worked so I had no chances to see any bugs. That time, the rootfs was unpacked in /opt according to Preflex's instructions and not on the SD, and I have not tried this again because apparently unpacking as nemo is not the way to go, and the untar process is very long so I could not do many experiments.

I would love to try with Debian or the Android runtime, or anything that could work really, but I have no idea where to start with and I have no skills to tweak things around to make it work. My only experience with chroot are EasyDebian on N900 or Preflex's instructions here, and there is no way I could do it myself without some pre-configured scripts and instructions. :/

It's sad that Preflex suddenly disappeared while his app was almost ready according to his posts. He has not replied to my PM a few days ago, hope nothing bad happened to him and that it's just a loss of interest in this project.

The Following 3 Users Say Thank You to Kabouik For This Useful Post:
Posts: 6 | Thanked: 12 times | Joined on Feb 2013
I plan on making/helping create the GUI once my Sony Xperia X stops sharing all my personal data and becomes more sailfish.

If you have sfdroid (community port) or an official Jolla device you should be able to install xserver xsdl (Android app)

That would take the place of the command "kwin_wayland --xwayland"
(Simply open the android app instead)

Then you can continue exporting the display var and run a X11 app.

The Following 3 Users Say Thank You to one_with_linux For This Useful Post:

Thread Tools

Forum Jump

All times are GMT. The time now is 13:44.