Active Topics

 



Notices


Reply
Thread Tools
Posts: 544 | Thanked: 2,800 times | Joined on Oct 2009
#21
Documenting the steps I am taking to set up the build environment that I will be using to compile Firefox 24 source code. I am doing this on the Maemo Fremantle Ubuntu dev VM, if you have a different setup the commands to run may be different:
Items in <> are things you need to type in or do, other lines are commands to be run in the shell.

sudo su
<input password for user maemo>
cd /scratchbox/compilers
wget http://maemo.merlin1991.at/cssu/deve...armv7a.tar.bz2
tar xvf linaro-4.7-2012.07-fremantle-armv7a.tar.bz2
rm linaro-4.7-2012.07-fremantle-armv7a.tar.bz2
exit
/scratchbox/login
sb-conf st FREMANTLE_ARMEL_GCC472 -c linaro-4.7-2012.07-fremantle-armv7a -d qemuerl:debian-etch:doctools:svn:git -t qemu-arm-sb
sb-conf se FREMANTLE_ARMEL_GCC472
wget http://repository.maemo.org/stable/f...36-2_armel.tgz
sb-conf rs maemo-sdk-rootstrap_5.0_20.2010.36-2_armel.tgz
sb-conf in -edL
rm maemo-sdk-rootstrap_5.0_20.2010.36-2_armel.tgz
dpkg -i /scratchbox/compilers/linaro-4.7-2012.07-fremantle-armv7a/packages/libfakeroot_1.14.4-0+sb1_armel.deb
apt-get update
fakeroot apt-get install maemo-sdk-debug
<add deb http://repository.maemo.org/ fremantle/******************************** nokia-binaries line to /etc/apt/sources.list>
apt-get update
fakeroot apt-get install nokia-binaries nokia-apps
rm -rf /targets/FREMANTLE_ARMEL_GCC472/opt
mkdir /targets/FREMANTLE_ARMEL_GCC472/opt
apt-get install dbus-glib-1-dev
apt-get install autoconf2.13
apt-get install libidl-dev
apt-get install automake1.7
apt-get install python2.5
apt-get install quilt
apt-get install bc
apt-get install sharutils
<add deb http://repository.maemo.org/extras-devel/ fremantle free line to /etc/apt/sources.list>
apt-get update
apt-get install python2.7
apt-get install libogg-dev
apt-get install libvorbis-dev
apt-get install libtheora-dev
<remove deb http://repository.maemo.org/extras-devel/ fremantle free line from /etc/apt/sources.list>
<add deb http://maemo.merlin1991.at/cssu/community-thumb/ fremantle free non-free to /etc/apt/sources.list>
apt-get update
apt-get install gcc-4.7-base
apt-get install libgcc1
apt-get install libstdc++6-dev
apt-get install libstdc++6-dbg
<remove deb http://maemo.merlin1991.at/cssu/community-thumb/ fremantle free non-free from /etc/apt/sources.list>
<add deb http://repository.maemo.org/community-testing/ fremantle free line to /etc/apt/sources.list>
apt-get update
apt-get install libpixman-1-dev
<clone git repository git@github.com:jonwil/microb-engine-ff24.git into your scratchbox home folder>
cd microb-engine-ff24
dpkg-buildpackage -rfakeroot -b

Last edited by jonwil; 2018-05-28 at 23:53.
 

The Following 11 Users Say Thank You to jonwil For This Useful Post:
Posts: 544 | Thanked: 2,800 times | Joined on Oct 2009
#22
Updated the build instructions for installing the libs needed for GCC 4.7.2 and updated the code to switch to using the in-tree version of Cairo 1.10 (the one local patch to Cairo 1.8.8 that matters is already in Cairo 1.10 upstream so we are good there)
 

The Following 6 Users Say Thank You to jonwil For This Useful Post:
Posts: 544 | Thanked: 2,800 times | Joined on Oct 2009
#23
Also had to add --disable-elf-hack to the mozconfig since it didn't seem to work right on Fremantle.
 

The Following 6 Users Say Thank You to jonwil For This Useful Post:
Posts: 544 | Thanked: 2,800 times | Joined on Oct 2009
#24
Updated the build instructions again (we dont need to install libjpeg but we do need to install libogg, libvorbis and libtheora)
 

The Following 6 Users Say Thank You to jonwil For This Useful Post:
Posts: 544 | Thanked: 2,800 times | Joined on Oct 2009
#25
I think this beast might actually build(!)
 

The Following 11 Users Say Thank You to jonwil For This Useful Post:
Posts: 544 | Thanked: 2,800 times | Joined on Oct 2009
#26
Fixed a piece of bit-rotting in some Maemo specific code.
Fixed some typos in moz.build that were causing the OpenGL code to not compile properly (it was trying to build some GLX code even though Maemo needs EGL not GLX)
 

The Following 5 Users Say Thank You to jonwil For This Useful Post:
Posts: 544 | Thanked: 2,800 times | Joined on Oct 2009
#27
Now I am stuck because I need GStreamer 0.10.26 and we only have GStreamer 0.10.25.
 

The Following 5 Users Say Thank You to jonwil For This Useful Post:
Posts: 544 | Thanked: 2,800 times | Joined on Oct 2009
#28
Have disabled gstreamer in the mozconfig for now and will worry about any resulting bustage later once I actually get this thing to build...
 

The Following 5 Users Say Thank You to jonwil For This Useful Post:
Posts: 544 | Thanked: 2,800 times | Joined on Oct 2009
#29
Have now disabled some other media stuff in the hope that it will no longer be giving me libogg issues.
 

The Following 6 Users Say Thank You to jonwil For This Useful Post:
Posts: 544 | Thanked: 2,800 times | Joined on Oct 2009
#30
Had to back-port part of the fix from mozilla bug 928547 and remove the --enable-necko-protocols line from the mozconfig (the default settings in FF24 are fine for our needs and the settings in the mozconfig were disabling some protocols that we actually need enabled including websocket and wyciwyg). Also had to give my vmware VM 3.5GB of ram (the maximum vmware will let me give it on my 8GB system) along with 6GB of swap.

But with those things done, hopefully libxul will now finally link and then the build process can continue (and hopefully give me a set of deb files at the end of it all)
 

The Following 4 Users Say Thank You to jonwil For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 08:21.