Notices


Reply
Thread Tools
Posts: 7 | Thanked: 3 times | Joined on Oct 2011
#1
Hi there,

I was wondering if anyone can help me. I have recently purchased a nokia n900 running Maemo 5, version 10.2010.19-1.203.1 and am experiencing problems installing Easy Debian v0.9.56-1fremantle1. I have also experienced problems installing easy-deb-chroot. Each time I try to install either one of these apps I get the following error
Unable to install 'easy-deb-chroot'
Application packages missing: libxmu6 (>=1.0.4-1)
Any help would be greatly appreciated, thank you!

Last edited by saco721; 2011-10-10 at 17:32.
 
Posts: 458 | Thanked: 274 times | Joined on Mar 2010 @ Finland
#2
Hmm, that package sould be pre-installed. Make sure you have the nokia repositories enabled. If they are try running
Code:
apt-get update
and then
Code:
apt-get install libxmu6
as root in xterminal. If it gives some errors paste them here.
 
Posts: 7 | Thanked: 3 times | Joined on Oct 2011
#3
Are application catalogues the same as repositories?, if so I can see that Nokia Applications is there. If not how do I check that the repositories are enabled?. - many thanks!
 
Posts: 458 | Thanked: 274 times | Joined on Mar 2010 @ Finland
#4
Yes, application catalogues are repositories. If the Nokia ones are enabled, try runnig the commands I wrote above. For more info about running commands as root see this page: wiki.maemo.org/Root.
 
Posts: 7 | Thanked: 3 times | Joined on Oct 2011
#5
Hi I ran apt-get update, and it processed fine, however if I run apt-get install libxmu6, I get the following messages :
Package libxmu6 is not available, but is referred to by another package
This may mean that the package is missing, has been obsoleted, or is only available from another source
E: Package luibxmu6 has no installation candidate.
Thank you for your time.
 
Posts: 458 | Thanked: 274 times | Joined on Mar 2010 @ Finland
#6
The the only thing I can think of is to install the package manually. Install this package by downloading it to your MyDocs folder and then running
Code:
cd /home/user/MyDocs
dpkg -i libxmu6_1.0.4-1_armel.deb
as root.
 
Posts: 49 | Thanked: 16 times | Joined on Feb 2011
#7
help me to install easy deb in reflashed n900

aplication manager tell me easy-deb-chroot has broken dependencies, i check log and dependencies is wmctrl

i download it from openrepos, but xterminal tell me it have dependencies.

libc6 i go to install libc6 from xterminal, but it tell me libc6 is already in the newest version

the following packages have unmet dependencies:
wmctrl: Depends: libc6 (>= 2.7) but 2.5.1-leglibc27+0m5 is to be installed




where to download or how to install 2.5.1-leglibc27+0m5

i search in google and talk maemo but i do not find nothing. help me!!! is the first time this error happens to me. the other time i install it it goes fine
 

The Following User Says Thank You to EL_CID_CAMPEADOR For This Useful Post:
Posts: 271 | Thanked: 622 times | Joined on Aug 2011 @ suncity
#8
Originally Posted by EL_CID_CAMPEADOR View Post

the following packages have unmet dependencies:
wmctrl: Depends: libc6 (>= 2.7) but 2.5.1-leglibc27+0m5 is to be installed
No... this tells you that wmctrl depends on libc6 greater than 2.7... Let's say that is not possible on n900 (not true but for now let's assume this). Btw. my wmctrl install depends on libc6 >=2.5.0-1 so I do not know where you want to install wmctrl from but you should check that...
 

The Following 2 Users Say Thank You to justmemory For This Useful Post:
Posts: 49 | Thanked: 16 times | Joined on Feb 2011
#9
Originally Posted by justmemory
No... this tells you that wmctrl depends on libc6 greater than 2.7... Let's say that is not possible on n900 (not true but for now let's assume this). Btw. my wmctrl install depends on libc6 >=2.5.0-1 so I do not know where you want to install wmctrl from but you should check that...
check picture man. help me. how to install easy deb chroot on my nokia n900
Attached Images
 
 
peterleinchen's Avatar
Posts: 3,303 | Thanked: 6,142 times | Joined on Aug 2010 @ Ruhrgebiet, Germany
#10
Originally Posted by EL_CID_CAMPEADOR View Post
help me to install easy deb in reflashed n900

aplication manager tell me easy-deb-chroot has broken dependencies, i check log and dependencies is wmctrl

i download it from openrepos
libc6 i go to install libc6 from xterminal, but it tell me libc6 is already in the newest version

the following packages have unmet dependencies:
wmctrl: Depends: libc6 (>= 2.7) but 2.5.1-leglibc27+0m5 is to be installed


where to download or how to install 2.5.1-leglibc27+0m5

i search in google and talk maemo but i do not find nothing. help me!!!
Proper information the key to successful helping is.

Why manual download? Why from openrepos (it is a N9 platform)?
What is the command used? What the full output?

Why try to install libc via apt (using standard repo mechanism)?
What are your configured repositories.
And and and ....

What would be the output of
apt-get install wmctrl -s
or
apt-get install --reinstall wmctrl -s
My wmctrl is 1.07-5 and libc6 is 2.5.1-1 on N900.
__________________
SIM-Switcher, automated SIM switching with a Double (Dual) SIM adapter
--
Thank you all for voting me into the Community Council 2014-2016!

Please consider your membership / supporting Maemo e.V. and help to spread this by following/copying this link to your TMO signature:
[MC eV] Maemo Community eV membership application, http://talk.maemo.org/showthread.php?t=94257

editsignature, http://talk.maemo.org/profile.php?do=editsignature

Last edited by peterleinchen; 2018-05-21 at 10:08.
 

The Following 2 Users Say Thank You to peterleinchen For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 22:24.