Active Topics

 



Notices


Reply
Thread Tools
Posts: 155 | Thanked: 700 times | Joined on Aug 2016 @ Estonia
#251
Originally Posted by jdrescher View Post
Thanks for the infos.
I have a lot of features to implement so I can wait a little longer.

All in all for developers it's still a sad situation after so many years with SFOS. You can't even release a bluetooth app into the harbour.
I think Jolla should make it as easy as possible for developers. Instead they are doing it the other way around
While its good to release in the Harbour, its rules should not be on our way and the releases in OpenRepos are very much appreciated as well.

In this case, as you see from the discussion above, it could be just manpower limitation on Jolla's part (in terms of not working on QtLocation). We could try to chip in as a community, if there is someone around who has knowledge and/or time to look into QtLocation 5.6 adaptation
 

The Following 2 Users Say Thank You to rinigus For This Useful Post:
Posts: 7 | Thanked: 21 times | Joined on Apr 2017
#252
Originally Posted by rinigus View Post
While its good to release in the Harbour, its rules should not be on our way and the releases in OpenRepos are very much appreciated as well.
Ok, that was a very good hint. Of course OpenRepos are fine with me. I already have an app which is released to openrepos only because of Jolla store restrictrions.
So I in my yaml file I had:
Code:
Requires:
- qt5-plugin-geoservices-osm >= 5.1.0
- qt5-qtlocation >= 5.1.0
- qt5-qtdeclarative-import-location >= 5.1.0
- qt5-qtdeclarative-import-positioning >= 5.1.0
And changed it to:
Code:
Requires:
- sailfishsilica-qt5 >= 0.10.9
- qt5-plugin-geoservices-osm >= 5.2.0
- qt5-qtlocation >= 5.6.0
- qt5-qtdeclarative-import-location >= 5.2.0
- qt5-qtdeclarative-import-positioning >= 5.2.0
But now there is an error while compiling:
Code:
Error: nothing provides qt5-qtlocation >= 5.6.0 needed by harbour-laufhelden-0.0.1-1.armv7hl
Do I need to install this lib on the phone first?
 

The Following 2 Users Say Thank You to jdrescher For This Useful Post:
Posts: 155 | Thanked: 700 times | Joined on Aug 2016 @ Estonia
#253
Originally Posted by jdrescher View Post
Ok, that was a very good hint. Of course OpenRepos are fine with me. I already have an app which is released to openrepos only because of Jolla store restrictrions.
So I in my yaml file I had:
Code:
Requires:
- qt5-plugin-geoservices-osm >= 5.1.0
- qt5-qtlocation >= 5.1.0
- qt5-qtdeclarative-import-location >= 5.1.0
- qt5-qtdeclarative-import-positioning >= 5.1.0
And changed it to:
Code:
Requires:
- sailfishsilica-qt5 >= 0.10.9
- qt5-plugin-geoservices-osm >= 5.2.0
- qt5-qtlocation >= 5.6.0
- qt5-qtdeclarative-import-location >= 5.2.0
- qt5-qtdeclarative-import-positioning >= 5.2.0
But now there is an error while compiling:
Code:
Error: nothing provides qt5-qtlocation >= 5.6.0 needed by harbour-laufhelden-0.0.1-1.armv7hl
Do I need to install this lib on the phone first?
Your requirements are correct. Unfortunately, as we discussed above, qt5-qtlocation >= 5.6.0 is not available yet on Sailfish. To my knowledge, no-one has compiled and (if needed) patched it. All we can do is either try to get it running ourselves or wait till Jolla gets developers on it.
 

The Following 2 Users Say Thank You to rinigus For This Useful Post:
Posts: 155 | Thanked: 700 times | Joined on Aug 2016 @ Estonia
#254
I have just released a module for the OSM Scout Server via Harbour. It looks that through such modules I would be able to split the server package into parts and supply multiple executables when needed. Users would still have to run only the main executable to get full functionality of the server - OSM Scout Server.

Right now, the fonts module is released. It was done early to ensure its released before future upgrades. I am working on getting one more module out which would contain Valhalla's routing engine. At present, only these two modules are planned.

The modules will be released via Harbour and OpenRepos. Since the timing of OpenRepos is under my control, I don't have to rush them out early on that channel.

For users, that would mean installation of additional programs/apps via Harbour or OpenRepos. On server's start, the availability of the modules is checked and, if missing, installation is suggested.

I am planning to update the modules separately, as needed. I hope that this split will not create further confusion, at least not in long term.
 

The Following 3 Users Say Thank You to rinigus For This Useful Post:
Reply

Tags
offline maps, sailfish os

Thread Tools

 
Forum Jump


All times are GMT. The time now is 23:14.