Notices


Reply
Thread Tools
Posts: 72 | Thanked: 5 times | Joined on Sep 2007
#1
Today ,I suddenly find I can't play any mp3 audio file with the default Media Player.When I run the player and select a mp3 file,
It show "Unable to play",But Canola and MPlayer are OK,
why?
__________________
http://www.myhtpc.com.cn
--DIY your best HTPC.
 
Posts: 20 | Thanked: 10 times | Joined on Sep 2013
#2
Back to the future... I had 3 n900 (somehow now dead or unchargeable) having this issue for reasons I still can't identify.
I reflashed a new second hand n900 a few days ago and I re-enjoyed mediaplayer working for all my files again. But since yesterday, it is broken, again, and I can't figure out why.
The most frustrating thing is that I know I did nothing by myself to make this issue happen simply because I was sleeping between the moment it was working and the moment it was broken.

As far as I can tell, the problem is really similar to this *closed* bug:
https://bugs.maemo.org/show_bug.cgi?id=6823

I've tried a lot of things (restarting trackerd, killing mafw-*, reboots, run it with strace, etc.) without success. When trying to play any audio/video file, it still shows this error message (translated from french) "impossible to process operation", even trying to change the mediaplayer volume triggers this error.

If anybody here is still using his n900 and its mediaplayer, please give some feedback!

Note: openmediaplayer suffers of the same problems, an was working good when mediaplayer was working too.

--
PS: my firmware is 20.2010.36-2

Last edited by NicoLarve; 2016-01-15 at 09:42.
 
Posts: 21 | Thanked: 62 times | Joined on Nov 2014
#3
Originally Posted by NicoLarve View Post
As far as I can tell, the problem is really similar to this *closed* bug:
https://bugs.maemo.org/show_bug.cgi?id=6823
Do you get the DSP MMU fault in dmesg as well?

Originally Posted by NicoLarve View Post
I've tried a lot of things (restarting trackerd, killing mafw-*, reboots, run it with strace, etc.) without success. When trying to play any audio/video file, it still shows this error message (translated from french) "impossible to process operation", even trying to change the mediaplayer volume triggers this error.
(...)
Note: openmediaplayer suffers of the same problems, an was working good when mediaplayer was working too.
What happens if you try playing it with gst-launch (see http://linux.die.net/man/1/gst-launch-0.10 and look for playbin or playbin2)?
 

The Following User Says Thank You to bencoh For This Useful Post:
Posts: 20 | Thanked: 10 times | Joined on Sep 2013
#4
Originally Posted by bencoh View Post
Do you get the DSP MMU fault in dmesg as well?
No, I don't have any thing related to (grep -i) "dsp", "dspmmu" nor "fault" in dmesg.

Originally Posted by bencoh View Post
What happens if you try playing it with gst-launch (see http://linux.die.net/man/1/gst-launch-0.10 and look for playbin or playbin2)?
I don't have this command and apt-cache | aptitude search doesn't help to locate its package. (And unfortunately, I don't have apt-file at hands on my n900!).
Which package is it from?

Edit: I have to mention that mplayer works "well" (it can be interrupted at times, when receiving sms , etc. but is almost OK).

Thank you by the way!
 
Posts: 20 | Thanked: 10 times | Joined on Sep 2013
#5
OK, I've located gst-launch asking apt-file on my Debian laptop. It is in gstreamer-tools package.

My intuition is that this mediaplayer issue is related to something stupid like an orphan lock file or an erroneous communication with the underneath decoding libraries. Is this latest guess the track you want me to explore, i.e., trying gstreamer as a stand alone player?
 
endsormeans's Avatar
Posts: 1,892 | Thanked: 4,302 times | Joined on Feb 2013 @ Supa Natural Vancouver Island
#6
You do realize that you posted your n900 media player problem in the n800 subforum right?
I am just illuminating this so that it doesn't confuse n800 owners...
and to let you know you will get more n900 users looking at the problem in the n900 subforum than here...
__________________
Lurker since 2007, Member since 2013, Certifiable since 1972
Owner of : 1-n770 (in retirement),
3-n800's,
3-n810's,
5-n900's
-3 flawless
-1 loose usb (i don't muck with it & stress it , considering selling it, another can fix the loose usb)
-1 no telephony (perfect for permanent set-up as mini-pc with one of my monitors)
half a neo900 pre- "bought"....due for production any day now.


PIMP MY N8X0
Everything you need tightly explained in layman's terms ..in an easy to understand format.. and a video walkthrough to boot.
http://talk.maemo.org/showthread.php?t=94294
THE LOST GRONMAYER CATALOGS
http://talk.maemo.org/showthread.php...ight=gronmayer
N8X0 VIDEO ENCODING THE EASY WAY
http://talk.maemo.org/showthread.php...ght=mediacoder
242gb ON N800
http://talk.maemo.org/showthread.php?t=90634

THE PAIN-FREE MAEMO DEVELOPMENT LIVE DISTRO-ISO FOR THE NOOB TO THE PRO
http://talk.maemo.org/showthread.php?t=95567

AFFORDABLE MASS PRODUCTION FOR MAEMO PARTS
http://talk.maemo.org/showthread.php?t=93325
 

The Following User Says Thank You to endsormeans For This Useful Post:
Posts: 20 | Thanked: 10 times | Joined on Sep 2013
#7
Originally Posted by endsormeans View Post
You do realize that you posted your n900 media player problem in the n800 subforum right?
I am just illuminating this so that it doesn't confuse n800 owners...
and to let you know you will get more n900 users looking at the problem in the n900 subforum than here...
Oh! thank you, I didn't realize!
 
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 20:47.