Notices


Reply
Thread Tools
Posts: 134 | Thanked: 602 times | Joined on Aug 2016 @ Estonia
#211
Originally Posted by carmenluci View Post
Yeah, I installed on i486 device. If I open the app via Terminal, it shows this message: 'Instrucción ilegal' (in English 'Illegal instruction').
0.7.5 version works fine, but I can't download maps because they aren't compatible and I must update the app.
Yes, its kind of a limbo with the change in the map versions. You could use 0.7.5 without geocoder-nlp, but let's try to fix it for 0.8.0.

I don't know what could be the cause for Illegal instruction (broken build, wrong SFOS version, bug). So, I just recompiled the server and uploaded a debug build at

http://osmscoutserver-test.e24files....8.0-1.i486.rpm

Would you mind to test if this one works? I don't have a tablet and, obviously, all works in the emulator, as far as I can tell.
 

The Following 4 Users Say Thank You to rinigus For This Useful Post:
Posts: 71 | Thanked: 61 times | Joined on Feb 2014 @ Spain
#212
Originally Posted by rinigus View Post
Yes, its kind of a limbo with the change in the map versions. You could use 0.7.5 without geocoder-nlp, but let's try to fix it for 0.8.0.

I don't know what could be the cause for Illegal instruction (broken build, wrong SFOS version, bug). So, I just recompiled the server and uploaded a debug build at

http://osmscoutserver-test.e24files....8.0-1.i486.rpm

Would you mind to test if this one works? I don't have a tablet and, obviously, all works in the emulator, as far as I can tell.
Thanks again!! I've installed the new rpm file, but this bug is not solved.

If I try open the app via Terminal I get the same message:

[nemo@Sailfish Downloads]$ harbour-osmscout-server
[D] unknown:0 - QML debugging is enabled. Only use this in a safe environment.
Instrucción ilegal
 

The Following 2 Users Say Thank You to carmenluci For This Useful Post:
Posts: 134 | Thanked: 602 times | Joined on Aug 2016 @ Estonia
#213
Originally Posted by carmenluci View Post
Thanks again!! I've installed the new rpm file, but this bug is not solved.

If I try open the app via Terminal I get the same message:

[nemo@Sailfish Downloads]$ harbour-osmscout-server
[D] unknown:0 - QML debugging is enabled. Only use this in a safe environment.
Instrucción ilegal
If you know how to debug, you could use

gdb /usr/bin/harbour-osmscout-server

issue "run" in gdb and see what happens. It will probably give lots of messages regarding missing symbols, but maybe we can pull something out of it. When it crashes, see what "backtrace" command would give.

Since the server passed Harbour checks, I presume that this bug does not show up on clean installation. You could also try to move away configuration file (please move, don't delete, so we could examine it later!):

mv .config/harbour-osmscout-server/harbour-osmscout-server.conf ~/harbour-osmscout-server-send-for-repair.conf

then move away Maps.OSM (if the folder was as proposed by default) and try to start server again. If that doesn't help, try to reboot (maybe something is wrong with the tablet state?).

Would be good to know if there are other tablet users around and if they see the same error...
 

The Following 3 Users Say Thank You to rinigus For This Useful Post:
Posts: 71 | Thanked: 61 times | Joined on Feb 2014 @ Spain
#214
Originally Posted by rinigus View Post
If you know how to debug, you could use

gdb /usr/bin/harbour-osmscout-server

issue "run" in gdb and see what happens. It will probably give lots of messages regarding missing symbols, but maybe we can pull something out of it. When it crashes, see what "backtrace" command would give.

Since the server passed Harbour checks, I presume that this bug does not show up on clean installation. You could also try to move away configuration file (please move, don't delete, so we could examine it later!):

mv .config/harbour-osmscout-server/harbour-osmscout-server.conf ~/harbour-osmscout-server-send-for-repair.conf

then move away Maps.OSM (if the folder was as proposed by default) and try to start server again. If that doesn't help, try to reboot (maybe something is wrong with the tablet state?).

Would be good to know if there are other tablet users around and if they see the same error...
I've made a clean install, but it doesn't work, I reboot my tablet and doesn't work.
I've tried to use 'gdb' in my tablet, but I get 'command not found', If I've tried to install it I get error (file doesn't found).

I use SailfishOS 2.1.0.10, could it be the problem?

Well, maybe someone here who has a tablet can help us with this bug.

Thank you so much for your attention
 

The Following 2 Users Say Thank You to carmenluci For This Useful Post:
Posts: 134 | Thanked: 602 times | Joined on Aug 2016 @ Estonia
#215
Originally Posted by carmenluci View Post
I've made a clean install, but it doesn't work, I reboot my tablet and doesn't work.
I've tried to use 'gdb' in my tablet, but I get 'command not found', If I've tried to install it I get error (file doesn't found).

I use SailfishOS 2.1.0.10, could it be the problem?

Well, maybe someone here who has a tablet can help us with this bug.

Thank you so much for your attention
@carmenluci, sorry that I don't know exactly how to help you.

I presume we have two differences already: use of i486 and 2.1.0.10. I am using only ported devices (OnePlus X and Nexus 4), with the both of them ARM and 2.0.5.6. Since these are ported devices, we'll move t 2.1.x series only after EA period is finished and there is a proper release. While there might be some builds for these devices around, or its possible to build myself, I would prefer not to jump over yet until its released.

So, would be good to know from other users of i486 (any SFOS version) or 2.1.0.10 (any CPU) how things are working for them. It would be helpful to know with the respect to this bug.

@carmenluci, when you reinstalled the server, did you move away the configuration file as well? Uninstall does not remove them, you have to move them away yourself.

Probably that wouldn't be of great help, but maybe you could run :

harbour-osmscout-server --help

It should just give you a list of command line options and stop the program. I wonder whether your crash occurs before or after the command line options processing.
 

The Following User Says Thank You to rinigus For This Useful Post:
Posts: 1,322 | Thanked: 5,929 times | Joined on Apr 2010 @ Czech Republic
#216
The crash with 0.8 seems to be x86/i486 wide (or at least Tablet wide) - it also happens on my tablet. This is the output from Journal when I click on the OSM scout Server icon (not very informative):

Code:
Mar 30 00:40:17 Sailfish erver[14491]: [D] unknown:0 - QML debugging is enabled. Only use this in a safe environment.
Mar 30 00:40:17 Sailfish mapplauncherd[880]: Boosted process (pid=14491) was terminated due to signal 4
Mar 30 00:40:17 Sailfish kernel: Double click to light up the screen!
Mar 30 00:40:17 Sailfish kernel: traps: harbour-osmscou[14491] trap invalid opcode ip:ef91952c sp:ffe75210 error:0
Mar 30 00:40:17 Sailfish kernel:  in harbour-osmscout-server[ef87a000+635000]
Mar 30 00:40:18 Sailfish booster-silica-qt5[15334]: [D] unknown:0 - Using Wayland-EGL
Mar 30 00:40:19 Sailfish mapplauncherd[15334]: SilicaBooster: Initiate asynchronous preload.
Mar 30 00:40:32 Sailfish lipstick[749]: [W] unknown:0 - Queued images being saved: 6
Running the binary directly is similarly uninformative:
Code:
$ /usr/bin/harbour-osmscout-server
[D] unknown:0 - QML debugging is enabled. Only use this in a safe environment.
Illegal instruction
BTW, gdb can be installed by (as root):

Code:
pkcon install gdb
Running the binary with gdb:

Code:
[nemo@Sailfish ~]$ /usr/bin/harbour-osmscout-server
[D] unknown:0 - QML debugging is enabled. Only use this in a safe environment.
Illegal instruction
[nemo@Sailfish ~]$ gdb /usr/bin/harbour-osmscout-server
GNU gdb (GDB) Mer (7.6.2+git2)
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i486-meego-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/bin/harbour-osmscout-server...Missing separate debuginfo for /usr/bin/harbour-osmscout-server
Try: zypper install -C "debuginfo(build-id)=f7ebd8791602e8215bb0e635727ebe3b190401ae"
(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/bin/harbour-osmscout-server 
Missing separate debuginfo for /lib/ld-linux.so.2
Try: zypper install -C "debuginfo(build-id)=e5ca5fea8505c81c292f076bc390c65270d07e89"
Missing separate debuginfo for /usr/lib/libz.so.1
Try: zypper install -C "debuginfo(build-id)=af6a51baa1f07eaa8c9bd73fb017241d3ffb5173"
Missing separate debuginfo for /lib/libdl.so.2
Try: zypper install -C "debuginfo(build-id)=9775c1ca2d3c07fa4cb9f2b59e1fd9f85a08c260"
Missing separate debuginfo for /usr/lib/libsailfishapp.so.1
Try: zypper install -C "debuginfo(build-id)=59aad9e537769043ccf7fa8a0fe0d6499f487c74"
Missing separate debuginfo for /usr/lib/libmdeclarativecache5.so.0
Try: zypper install -C "debuginfo(build-id)=99bba885a24a98da3e94a613be79b20a1c342c02"
Missing separate debuginfo for /usr/lib/libQt5Quick.so.5
Try: zypper install -C "debuginfo(build-id)=8364094fc05636916fe6ff9282e11aa150d0fa5d"
Missing separate debuginfo for /usr/lib/libQt5Gui.so.5
Try: zypper install -C "debuginfo(build-id)=db6991c180e7e5f2d5c4978f60eb0fe30fa4352f"
Missing separate debuginfo for /usr/lib/libQt5Qml.so.5
Try: zypper install -C "debuginfo(build-id)=f84345868f1fa7daacf4515c5c47ebe4e0ccea85"
Missing separate debuginfo for /usr/lib/libQt5Network.so.5
Try: zypper install -C "debuginfo(build-id)=0f06ef7212148f40fd36151deb3fa80b07db4c9f"
Missing separate debuginfo for /usr/lib/libQt5Sql.so.5
Try: zypper install -C "debuginfo(build-id)=bd81360ce77a2ea5219a9f5d3ecb040623a2944c"
Missing separate debuginfo for /usr/lib/libQt5Core.so.5
Try: zypper install -C "debuginfo(build-id)=30e2b9010e918aaf632daa4bd6062a3dd74e6204"
Missing separate debuginfo for /usr/lib/libGLESv2.so.2
Try: zypper install -C "debuginfo(build-id)=206956d019f68d899185b6b96978cb7739e808c2"
Missing separate debuginfo for /lib/libpthread.so.0
Try: zypper install -C "debuginfo(build-id)=804779ddd4720ef9414c8d55cb0337b0ca7a3276"
warning: File "/lib/libthread_db-1.0.so" auto-loading has been declined by your `auto-load safe-path' set to "$debugdir:$datadir/auto-load".
To enable execution of this file add
	add-auto-load-safe-path /lib/libthread_db-1.0.so
line to your configuration file "/home/nemo/.gdbinit".
To completely disable this security protection add
	set auto-load safe-path /
line to your configuration file "/home/nemo/.gdbinit".
For more information about this security protection see the
"Auto-loading safe path" section in the GDB manual.  E.g., run from the shell:
	info "(gdb)Auto-loading safe path"
warning: Unable to find libthread_db matching inferior's thread library, thread debugging will not be available.
Missing separate debuginfo for /usr/lib/libstdc++.so.6
Try: zypper install -C "debuginfo(build-id)=20af1c910af264fd002286a3dcede24883ca3461"
Missing separate debuginfo for /lib/libm.so.6
Try: zypper install -C "debuginfo(build-id)=d7e2c0a8d5d62aaa787a760e3923de7265b521c9"
Missing separate debuginfo for /lib/libgcc_s.so.1
Try: zypper install -C "debuginfo(build-id)=796db85b4c1b956aaba10424526efcba4f2fe7bf"
Missing separate debuginfo for /lib/libc.so.6
Try: zypper install -C "debuginfo(build-id)=470a95eae97feabde51f8756ebec221f06f6ff1c"
Missing separate debuginfo for /usr/lib/libmlite5.so.0
Try: zypper install -C "debuginfo(build-id)=ff0e97f1d45e51946256451033664745aa6387bd"
Missing separate debuginfo for /usr/lib/libQt5DBus.so.5
Try: zypper install -C "debuginfo(build-id)=224668e47ce9721f9e4953bc204ea14aa68d32d7"
Missing separate debuginfo for /usr/lib/libfontconfig.so.1
Try: zypper install -C "debuginfo(build-id)=8e5a192901cb8404fa802b780b4c65cc5d965955"
Missing separate debuginfo for /usr/lib/libpng16.so.16
Try: zypper install -C "debuginfo(build-id)=55cb5e8531078f7faae0a2fccfe8cdaf0b22f3d7"
Missing separate debuginfo for /lib/librt.so.1
Try: zypper install -C "debuginfo(build-id)=d7ecff8acc2f101c820ae3181da9482d7da7055d"
Missing separate debuginfo for /usr/lib/libicui18n.so.52
Try: zypper install -C "debuginfo(build-id)=c2605a12dc5d5982bcf98321d0af1876f58c6460"
Missing separate debuginfo for /usr/lib/libicuuc.so.52
Try: zypper install -C "debuginfo(build-id)=b8657a0e42eac864f494976a9eb790a51d5e49c3"
Missing separate debuginfo for /usr/lib/libpcre16.so.0
Try: zypper install -C "debuginfo(build-id)=f852001cbaed44bb4979dae66033df457aa1c15d"
Missing separate debuginfo for /usr/lib/libgthread-2.0.so.0
Try: zypper install -C "debuginfo(build-id)=95763db723fcaf3e11cb6b85aa455e885c7a823a"
Missing separate debuginfo for /usr/lib/libglib-2.0.so.0
Try: zypper install -C "debuginfo(build-id)=d9774fdedef98b9695a963c306ec13f0d8528b33"
Missing separate debuginfo for /usr/lib/libsystemd-journal.so.0
Try: zypper install -C "debuginfo(build-id)=c0920ac4c6c7b44121597f6b706cd1cb04174f17"
Missing separate debuginfo for /usr/lib/libsystemd-id128.so.0
Try: zypper install -C "debuginfo(build-id)=23c9454e0d6cc6f3405698e3b09c75ccdb74595c"
Missing separate debuginfo for /usr/lib/libhybris-common.so.1
Try: zypper install -C "debuginfo(build-id)=4ffe924f33c060e11933b1a796dc5cf090b7436d"
Missing separate debuginfo for /usr/lib/libandroid-properties.so.1
Try: zypper install -C "debuginfo(build-id)=35821f6a3a6c5600575bb5d6e3f94c98ee3a05ae"
Missing separate debuginfo for /usr/lib/libdconf.so.1
Try: zypper install -C "debuginfo(build-id)=75654a5bce5432214731346e94a80cce6eea0227"
Missing separate debuginfo for /usr/lib/libgio-2.0.so.0
Try: zypper install -C "debuginfo(build-id)=5a364998350fff6e2db9d14288dad4442a52f218"
Missing separate debuginfo for /usr/lib/libgobject-2.0.so.0
Try: zypper install -C "debuginfo(build-id)=a552acbaf20b128bebedf5cdca07f4a11d78de73"
Missing separate debuginfo for /usr/lib/libdbus-1.so.3
Try: zypper install -C "debuginfo(build-id)=71174827d73ce8bcbb48764bc1dfa1fce261d86f"
Missing separate debuginfo for /usr/lib/libfreetype.so.6
Try: zypper install -C "debuginfo(build-id)=831db487e57a707cfe987211fef0cd1fe86ea63c"
Missing separate debuginfo for /usr/lib/libexpat.so.1
Try: zypper install -C "debuginfo(build-id)=0761e9ef1803296e0c9330f145b427282d21431b"
Missing separate debuginfo for /usr/lib/libpcre.so.1
Try: zypper install -C "debuginfo(build-id)=861bae228ba27dd8739f0f8151872a34d814128f"
Missing separate debuginfo for /usr/lib/liblzma.so.5
Try: zypper install -C "debuginfo(build-id)=b988754a7e2658cae8a6d7317b6d1bdb412de5d2"
Missing separate debuginfo for /usr/lib/libgcrypt.so.11
Try: zypper install -C "debuginfo(build-id)=deca1ceee3c1b9f924c4190cb80b3190ed25645f"
Missing separate debuginfo for /usr/lib/libgpg-error.so.0
Try: zypper install -C "debuginfo(build-id)=75eb21064733ea12f78a2c97f11f05c89187eb1b"
Missing separate debuginfo for /usr/lib/libffi.so.5
Try: zypper install -C "debuginfo(build-id)=e969b8dfecd7369ca329f41c969d4c35e4baf7fc"
Missing separate debuginfo for /usr/lib/libgmodule-2.0.so.0
Try: zypper install -C "debuginfo(build-id)=954c5d94fef1d85eec71cd2ef9451ed21adf40c7"
Missing separate debuginfo for /lib/libresolv.so.2
Try: zypper install -C "debuginfo(build-id)=86a89364d3cd6826fcf9325f9d379d132061452a"
Missing separate debuginfo for /usr/lib/libsystemd-login.so.0
Try: zypper install -C "debuginfo(build-id)=23af8b68d045cbe6ecfe625321f781b6759d773a"
Missing separate debuginfo for /usr/lib/libsystemd-daemon.so.0
Try: zypper install -C "debuginfo(build-id)=e034f754d11b02a959fd00a965924026f5f91c21"
[D] unknown:0 - QML debugging is enabled. Only use this in a safe environment.

Program received signal SIGILL, Illegal instruction.
0x565f452c in ?? ()
(gdb) backtrace
#0  0x565f452c in ?? ()
#1  0x56a49c27 in __libc_csu_init ()
#2  0xf695cd3a in __libc_start_main () from /lib/libc.so.6
#3  0x565f4aa6 in _start ()
(gdb)
Let me know if there is something else I should run to get you mere information.

Also IIRC the Sailfish OS emulator which should be part of the SDK is also i486 & the SDK runs i486 binaries in it (citing the docs):

Code:
Click on the emulator_icon icon to launch the emulator. NOTE: This icon is only available if the MerSDK-SailfishOS-i486 kit is active. You can activate the MerSDK-SailfishOS-i486 kit from menu Build → Open Build and Run Kit Selector….
So it might be worth trying if the crash could be reproduced in the emulator, as that should make debugging it quite a bit easier.
__________________
modRana: a flexible GPS navigation system
Mieru: a flexible manga and comic book reader

Thanks to everyone who voted for modRana & Mieru in the Maemo.org coding competition !
 

The Following 5 Users Say Thank You to MartinK For This Useful Post:
Posts: 134 | Thanked: 602 times | Joined on Aug 2016 @ Estonia
#217
Originally Posted by MartinK View Post
The crash with 0.8 seems to be x86/i486 wide (or at least Tablet wide) - it also happens on my tablet. This is the output from Journal when I click on the OSM scout Server icon (not very informative):

Code:
Mar 30 00:40:17 Sailfish erver[14491]: [D] unknown:0 - QML debugging is enabled. Only use this in a safe environment.
Mar 30 00:40:17 Sailfish mapplauncherd[880]: Boosted process (pid=14491) was terminated due to signal 4
Mar 30 00:40:17 Sailfish kernel: Double click to light up the screen!
Mar 30 00:40:17 Sailfish kernel: traps: harbour-osmscou[14491] trap invalid opcode ip:ef91952c sp:ffe75210 error:0
Mar 30 00:40:17 Sailfish kernel:  in harbour-osmscout-server[ef87a000+635000]
Mar 30 00:40:18 Sailfish booster-silica-qt5[15334]: [D] unknown:0 - Using Wayland-EGL
Mar 30 00:40:19 Sailfish mapplauncherd[15334]: SilicaBooster: Initiate asynchronous preload.
Mar 30 00:40:32 Sailfish lipstick[749]: [W] unknown:0 - Queued images being saved: 6
Running the binary directly is similarly uninformative:
Code:
$ /usr/bin/harbour-osmscout-server
[D] unknown:0 - QML debugging is enabled. Only use this in a safe environment.
Illegal instruction
BTW, gdb can be installed by (as root):

Code:
pkcon install gdb
Running the binary with gdb:

Code:
[nemo@Sailfish ~]$ /usr/bin/harbour-osmscout-server
[D] unknown:0 - QML debugging is enabled. Only use this in a safe environment.
Illegal instruction
[nemo@Sailfish ~]$ gdb /usr/bin/harbour-osmscout-server
GNU gdb (GDB) Mer (7.6.2+git2)
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i486-meego-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/bin/harbour-osmscout-server...Missing separate debuginfo for /usr/bin/harbour-osmscout-server
Try: zypper install -C "debuginfo(build-id)=f7ebd8791602e8215bb0e635727ebe3b190401ae"
(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/bin/harbour-osmscout-server 
Missing separate debuginfo for /lib/ld-linux.so.2
Try: zypper install -C "debuginfo(build-id)=e5ca5fea8505c81c292f076bc390c65270d07e89"
Missing separate debuginfo for /usr/lib/libz.so.1
Try: zypper install -C "debuginfo(build-id)=af6a51baa1f07eaa8c9bd73fb017241d3ffb5173"
Missing separate debuginfo for /lib/libdl.so.2
Try: zypper install -C "debuginfo(build-id)=9775c1ca2d3c07fa4cb9f2b59e1fd9f85a08c260"
Missing separate debuginfo for /usr/lib/libsailfishapp.so.1
Try: zypper install -C "debuginfo(build-id)=59aad9e537769043ccf7fa8a0fe0d6499f487c74"
Missing separate debuginfo for /usr/lib/libmdeclarativecache5.so.0
Try: zypper install -C "debuginfo(build-id)=99bba885a24a98da3e94a613be79b20a1c342c02"
Missing separate debuginfo for /usr/lib/libQt5Quick.so.5
Try: zypper install -C "debuginfo(build-id)=8364094fc05636916fe6ff9282e11aa150d0fa5d"
Missing separate debuginfo for /usr/lib/libQt5Gui.so.5
Try: zypper install -C "debuginfo(build-id)=db6991c180e7e5f2d5c4978f60eb0fe30fa4352f"
Missing separate debuginfo for /usr/lib/libQt5Qml.so.5
Try: zypper install -C "debuginfo(build-id)=f84345868f1fa7daacf4515c5c47ebe4e0ccea85"
Missing separate debuginfo for /usr/lib/libQt5Network.so.5
Try: zypper install -C "debuginfo(build-id)=0f06ef7212148f40fd36151deb3fa80b07db4c9f"
Missing separate debuginfo for /usr/lib/libQt5Sql.so.5
Try: zypper install -C "debuginfo(build-id)=bd81360ce77a2ea5219a9f5d3ecb040623a2944c"
Missing separate debuginfo for /usr/lib/libQt5Core.so.5
Try: zypper install -C "debuginfo(build-id)=30e2b9010e918aaf632daa4bd6062a3dd74e6204"
Missing separate debuginfo for /usr/lib/libGLESv2.so.2
Try: zypper install -C "debuginfo(build-id)=206956d019f68d899185b6b96978cb7739e808c2"
Missing separate debuginfo for /lib/libpthread.so.0
Try: zypper install -C "debuginfo(build-id)=804779ddd4720ef9414c8d55cb0337b0ca7a3276"
warning: File "/lib/libthread_db-1.0.so" auto-loading has been declined by your `auto-load safe-path' set to "$debugdir:$datadir/auto-load".
To enable execution of this file add
	add-auto-load-safe-path /lib/libthread_db-1.0.so
line to your configuration file "/home/nemo/.gdbinit".
To completely disable this security protection add
	set auto-load safe-path /
line to your configuration file "/home/nemo/.gdbinit".
For more information about this security protection see the
"Auto-loading safe path" section in the GDB manual.  E.g., run from the shell:
	info "(gdb)Auto-loading safe path"
warning: Unable to find libthread_db matching inferior's thread library, thread debugging will not be available.
Missing separate debuginfo for /usr/lib/libstdc++.so.6
Try: zypper install -C "debuginfo(build-id)=20af1c910af264fd002286a3dcede24883ca3461"
Missing separate debuginfo for /lib/libm.so.6
Try: zypper install -C "debuginfo(build-id)=d7e2c0a8d5d62aaa787a760e3923de7265b521c9"
Missing separate debuginfo for /lib/libgcc_s.so.1
Try: zypper install -C "debuginfo(build-id)=796db85b4c1b956aaba10424526efcba4f2fe7bf"
Missing separate debuginfo for /lib/libc.so.6
Try: zypper install -C "debuginfo(build-id)=470a95eae97feabde51f8756ebec221f06f6ff1c"
Missing separate debuginfo for /usr/lib/libmlite5.so.0
Try: zypper install -C "debuginfo(build-id)=ff0e97f1d45e51946256451033664745aa6387bd"
Missing separate debuginfo for /usr/lib/libQt5DBus.so.5
Try: zypper install -C "debuginfo(build-id)=224668e47ce9721f9e4953bc204ea14aa68d32d7"
Missing separate debuginfo for /usr/lib/libfontconfig.so.1
Try: zypper install -C "debuginfo(build-id)=8e5a192901cb8404fa802b780b4c65cc5d965955"
Missing separate debuginfo for /usr/lib/libpng16.so.16
Try: zypper install -C "debuginfo(build-id)=55cb5e8531078f7faae0a2fccfe8cdaf0b22f3d7"
Missing separate debuginfo for /lib/librt.so.1
Try: zypper install -C "debuginfo(build-id)=d7ecff8acc2f101c820ae3181da9482d7da7055d"
Missing separate debuginfo for /usr/lib/libicui18n.so.52
Try: zypper install -C "debuginfo(build-id)=c2605a12dc5d5982bcf98321d0af1876f58c6460"
Missing separate debuginfo for /usr/lib/libicuuc.so.52
Try: zypper install -C "debuginfo(build-id)=b8657a0e42eac864f494976a9eb790a51d5e49c3"
Missing separate debuginfo for /usr/lib/libpcre16.so.0
Try: zypper install -C "debuginfo(build-id)=f852001cbaed44bb4979dae66033df457aa1c15d"
Missing separate debuginfo for /usr/lib/libgthread-2.0.so.0
Try: zypper install -C "debuginfo(build-id)=95763db723fcaf3e11cb6b85aa455e885c7a823a"
Missing separate debuginfo for /usr/lib/libglib-2.0.so.0
Try: zypper install -C "debuginfo(build-id)=d9774fdedef98b9695a963c306ec13f0d8528b33"
Missing separate debuginfo for /usr/lib/libsystemd-journal.so.0
Try: zypper install -C "debuginfo(build-id)=c0920ac4c6c7b44121597f6b706cd1cb04174f17"
Missing separate debuginfo for /usr/lib/libsystemd-id128.so.0
Try: zypper install -C "debuginfo(build-id)=23c9454e0d6cc6f3405698e3b09c75ccdb74595c"
Missing separate debuginfo for /usr/lib/libhybris-common.so.1
Try: zypper install -C "debuginfo(build-id)=4ffe924f33c060e11933b1a796dc5cf090b7436d"
Missing separate debuginfo for /usr/lib/libandroid-properties.so.1
Try: zypper install -C "debuginfo(build-id)=35821f6a3a6c5600575bb5d6e3f94c98ee3a05ae"
Missing separate debuginfo for /usr/lib/libdconf.so.1
Try: zypper install -C "debuginfo(build-id)=75654a5bce5432214731346e94a80cce6eea0227"
Missing separate debuginfo for /usr/lib/libgio-2.0.so.0
Try: zypper install -C "debuginfo(build-id)=5a364998350fff6e2db9d14288dad4442a52f218"
Missing separate debuginfo for /usr/lib/libgobject-2.0.so.0
Try: zypper install -C "debuginfo(build-id)=a552acbaf20b128bebedf5cdca07f4a11d78de73"
Missing separate debuginfo for /usr/lib/libdbus-1.so.3
Try: zypper install -C "debuginfo(build-id)=71174827d73ce8bcbb48764bc1dfa1fce261d86f"
Missing separate debuginfo for /usr/lib/libfreetype.so.6
Try: zypper install -C "debuginfo(build-id)=831db487e57a707cfe987211fef0cd1fe86ea63c"
Missing separate debuginfo for /usr/lib/libexpat.so.1
Try: zypper install -C "debuginfo(build-id)=0761e9ef1803296e0c9330f145b427282d21431b"
Missing separate debuginfo for /usr/lib/libpcre.so.1
Try: zypper install -C "debuginfo(build-id)=861bae228ba27dd8739f0f8151872a34d814128f"
Missing separate debuginfo for /usr/lib/liblzma.so.5
Try: zypper install -C "debuginfo(build-id)=b988754a7e2658cae8a6d7317b6d1bdb412de5d2"
Missing separate debuginfo for /usr/lib/libgcrypt.so.11
Try: zypper install -C "debuginfo(build-id)=deca1ceee3c1b9f924c4190cb80b3190ed25645f"
Missing separate debuginfo for /usr/lib/libgpg-error.so.0
Try: zypper install -C "debuginfo(build-id)=75eb21064733ea12f78a2c97f11f05c89187eb1b"
Missing separate debuginfo for /usr/lib/libffi.so.5
Try: zypper install -C "debuginfo(build-id)=e969b8dfecd7369ca329f41c969d4c35e4baf7fc"
Missing separate debuginfo for /usr/lib/libgmodule-2.0.so.0
Try: zypper install -C "debuginfo(build-id)=954c5d94fef1d85eec71cd2ef9451ed21adf40c7"
Missing separate debuginfo for /lib/libresolv.so.2
Try: zypper install -C "debuginfo(build-id)=86a89364d3cd6826fcf9325f9d379d132061452a"
Missing separate debuginfo for /usr/lib/libsystemd-login.so.0
Try: zypper install -C "debuginfo(build-id)=23af8b68d045cbe6ecfe625321f781b6759d773a"
Missing separate debuginfo for /usr/lib/libsystemd-daemon.so.0
Try: zypper install -C "debuginfo(build-id)=e034f754d11b02a959fd00a965924026f5f91c21"
[D] unknown:0 - QML debugging is enabled. Only use this in a safe environment.

Program received signal SIGILL, Illegal instruction.
0x565f452c in ?? ()
(gdb) backtrace
#0  0x565f452c in ?? ()
#1  0x56a49c27 in __libc_csu_init ()
#2  0xf695cd3a in __libc_start_main () from /lib/libc.so.6
#3  0x565f4aa6 in _start ()
(gdb)
Let me know if there is something else I should run to get you mere information.

Also IIRC the Sailfish OS emulator which should be part of the SDK is also i486 & the SDK runs i486 binaries in it (citing the docs):

Code:
Click on the emulator_icon icon to launch the emulator. NOTE: This icon is only available if the MerSDK-SailfishOS-i486 kit is active. You can activate the MerSDK-SailfishOS-i486 kit from menu Build → Open Build and Run Kit Selector….
So it might be worth trying if the crash could be reproduced in the emulator, as that should make debugging it quite a bit easier.
Martin, thanks for analysis and feedback! @a-dekker has also opened a bug on GitHub, so we could move technical discussion over there: https://github.com/rinigus/osmscout-server/issues/107 (thank you @a-dekker!). I'll be following the both channels, but would try to reply to the questions via the same channel as the question.

SFOS emulator runs 0.8.0 fine for me, but I use stable SDK, not EA version. Since I develop for the stable SFOS, I would prefer to use that. Unfortunately, just compiling "for fun" by others is rather complicated - you have to install a large amount of support libraries that provide "brains" of the server (libosmscout, marisa, libpostal, ...)

To isolate the issue, tablet users out there, which version of SFOS do you run? Martin, do you have 2.1.x on the tablet or 2.0.x?

Do we have anyone running 2.0.x on the tablet that could test if OSM Scout Server starts?

For those who are stuck with this situation: you could use 0.7.5 and in Map Manager and Settings disable geocoder-nlp. That should allow you to use new maps (its only that component that changed), but would limit you to searches via libosmscout.

I did not work on making these transitions between map formats smoother. At present, I am trying to get the whole functionality of the served maps polished and hope that these bumps would be smaller in future.

Update: I tested OSM Scout Server 0.8.0 on 2.1.x SDK emulator - that worked fine. Note that if there is some illegal instruction for i486, it could be still fine for emulator if the instruction is propagated through VM to the host machine.

Last edited by rinigus; Today at 08:17. Reason: Test on 2.1.x SDK emulator: worked fine
 

The Following 3 Users Say Thank You to rinigus For This Useful Post:
Reply

Tags
offline maps, sailfish os

Thread Tools

 
Forum Jump


All times are GMT. The time now is 14:35.