Thread Tools
Posts: 133 | Thanked: 108 times | Joined on Mar 2012
Originally Posted by aditya_darma View Post
I have too instal on OPX now, cant Start, but automaticly back to Stop
I managed to get it running on OPX but can't install any apk

Last edited by bnwg; 2018-05-10 at 14:33.
Posts: 20 | Thanked: 12 times | Joined on Oct 2016
I am happy for all members & user who testing alien dalvik in one plus one device but it need many tweaks and find solution to fix bugs or glitch I try to install this from "alien dalvik nexus 4 " that post before I find that when I install something the screen closed or minimize that let me to restart device to be clear it is complex , I hope there some fix , I prefer to use Firefox and whatapp but that not happen for me when I using alien dalvik before maybe if I have time I try .
also bugs and glitch make me stop to using it.I love" sfdroid" that let me using many android app but the project is end for many reason and " anbox" is in early stage as alternative and it is coming to Ubuntu toutch also as I know some member of sfdroid team now working together with anbox team to bring anbox to sfos ,
.I hope opo device work will with alien dalvik without any problem

finally I have image backup with google play ready to use I try the new config for platform and see what happen than ...

Many thanks

Good lucks ....
Posts: 20 | Thanked: 12 times | Joined on Oct 2016
I testing AD with the last sfos version
It seems that alien dalvik work better than before but I wait for AD update to testing performance if someone can share it I appreciate that.

The great news , oneplus one device was not overheating when I using AD .

To be clear I thing there problem in SAILFISH keyboard with alien dalvik maybe related to this "Focus handling after gesture-based closing of the keyboard" .

Also I am not yet install google play , Why we need this steps?
because some apps need to work with 21 SDK I thing without that we have android sdk 19 so that big reason many app not installed or not working .

The Following User Says Thank You to baddea For This Useful Post:
Posts: 320 | Thanked: 564 times | Joined on May 2015 @ Italy
Can you share what you did to run it on the lastest SFOS? I also would like to have it on the latest version on my Nexus 5.
Posts: 20 | Thanked: 12 times | Joined on Oct 2016
Originally Posted by GalaxyNinja66 View Post
So after plenty of tinkering I have finally gotten google play store installed and a tester confirmed Google maps working. Please be warned: This has a history of crashing everything, forcing you to hard reboot, along with this, it has been shown to sometimes break sfos and require reinstalling - You should be fine after you finish though, that last one was just something that can happen mid-install.

Make sure you are using the up to date files!!! (I didn't make any of the files in this thread)
SFOS bacon:
PROPER CM12.1 sf base:
^^this specific base fixes the broken camera and flashlight and video with the other base^^

Anyway, without further ado, the instructions:

Instructions for Alien Dalvik on the OPO on sailfish os (make sure you are using the sfos special cm12.1 build!!!)
Download the aliendalvik rpm file from this link:

now run the following commands:
zypper in /home/nemo/Downloads/aliendalvik-1.0.46-1.armv7hl.rpm
pkcon install-local /home/nemo/Downloads/aliendalvik-1.0.46-1.armv7hl.rpm
systemctl stop aliendalvik
vim /opt/alien/system/script/
Erase everything and replace it with this:

# Copyright 2013-2016 Myriad Group AG. All Rights Reserved.
####### 3D needs #########
####### CAMERA needs #########
####### HW CODECS needs #########
####### LINKING LOOP #########
for x in $NEEDED_EXTRA_FILES; do
  ln -sf $target $link
ln -sf /system_jolla/lib/hw/ /system/lib/hw/
# For camera socket
mkdir -p /data/misc
ln -s /data_jolla/misc/camera /data/misc/camera

Now write the file and exit vim ("esc",":w", then ":q")
Now for some more commands:
chmod +x /opt/alien/system/script/
restart your device a couple times

now that you have everything ALMOST set up, lets do one last thing, install google play (because for some reason, installing google play makes it crash much less). This is the biggest pain the ***, since it will crash often while you try this. if a command doesn't work or glitches out, try again. Still doesn't work? reboot and try again. Due to the inconsistency of the crashes I don't really know what to do, so its mostly trial and error at this point.

Follow the instructions on this site:

Reboot, and set up your google account (prepare for constant crashing)
once you have it set up, go ahead and reboot, and bam everything should (kind of) work. I was able to install discord and google chrome without installing Gapps, but they crashed in a loop 4/5 times (however, that other 1/5 times was very nice). For some reason the keyboard is funky in some apps. fully use-able but funky.

If this works for you, AWESOME YAY! if not, sorry, I tried.

EDIT: Maybe this will work on OPX, since, if I remember correctly, they use the exact same SoC, but to get working camera you would obviously have to replace "lib/hw/camera.vendor.bacon" with the lib on the OPX.
i can explain that because i am in my work place i just following above instruction but after i apply restart it is not working so i try to remove the alien dalvik using command( i try to share it soon) after that i return to alien dalvik nexus 4 threads: first post and following instrcution but i did not replace what i do is to editing the script file using terminal form above and save it you have option to using text editor like vim or nano in the terminal and (make sure how to using those command for save and write and exit command) and save that file , finally i complete from thread "Alien dalvik nexus4 " and start alien dalvik services notice this very important no need to restart for oneplus one device just try to install any local apk you have and done try something like "notepad apk" and it working good and great after you be sure that you see setup screen you can restart and move to next setup to install google play and other thing.

sorry to make it long

Thread Tools

Forum Jump

All times are GMT. The time now is 21:17.