Notices


Reply
Thread Tools
Posts: 142 | Thanked: 296 times | Joined on Nov 2014
#81
If a person was planning to get a v820w Onda tablet would there be a way to make sure it actually is V3 (based on the assumption that V3 is the most compatible version regarding Sailfish... or Linux installations in general)? I suppose looking for Win8 + Android 4 instead of Win10 + Android 5 is a start but anything else?
 

The Following 3 Users Say Thank You to tmi For This Useful Post:
Posts: 137 | Thanked: 749 times | Joined on May 2016
#82
Originally Posted by smatkovi View Post
for you v3 users, does multitouch work for you?
You need to upgrade to 2.0.5.6. I ported touchscreen vendor's driver from a different tablet which supports multitouch. Please do backup in case something goes wrong, then follow the instructions below:

Code:
ssu re 2.0.5.6
ssu dr adaptation0            
ssu dr adaptation1
ssu ar http://sfos.scanf.su/onda-v820w-v3/ adaptation-onda
ssu ur

version --dup

ssu dr adaptation0
ssu dr adaptation1
# Check if you still have adaptation-onda, if not - readd
ssu lr

# Remove old modules and reinstall device-specific packages:
rm /lib/modules/3.10.20/*.ko

zypper install -f droid-bin-tbj-onda-v820w-v3 droid-config-tbj-onda-v820w-v3 droid-config-tbj-onda-v820w-v3-flashing droid-config-tbj-onda-v820w-v3-kickstart-configuration droid-config-tbj-onda-v820w-v3-patterns droid-config-tbj-onda-v820w-v3-policy-settings droid-config-tbj-onda-v820w-v3-preinit-plugin droid-config-tbj-onda-v820w-v3-pulseaudio-settings droid-config-tbj-onda-v820w-v3-sailfish droid-config-tbj-onda-v820w-v3-ssu-kickstarts droid-hal-tbj-onda-v820w-v3 droid-hal-tbj-onda-v820w-v3-detritus droid-hal-tbj-onda-v820w-v3-kernel  droid-hal-tbj-onda-v820w-v3-kernel-modules droid-hal-tbj-onda-v820w-v3-tools

depmod -a

# Check if you have graphics group and nemo is a member of it
cat /etc/group | grep graphics

# Should output "graphics:x:1003:nemo". If it's wrong for some reason, reinstall droid-hal-tbj-onda-v820w-v3 again
Originally Posted by tmi View Post
If a person was planning to get a v820w Onda tablet would there be a way to make sure it actually is V3 (based on the assumption that V3 is the most compatible version regarding Sailfish... or Linux installations in general)? I suppose looking for Win8 + Android 4 instead of Win10 + Android 5 is a start but anything else?
You could try to ask the seller for device serial number located at the back side. For example, see this photo. It's P820DBF4V3...

Last edited by TheKit; 2016-12-20 at 05:13.
 

The Following 13 Users Say Thank You to TheKit For This Useful Post:
Posts: 3 | Thanked: 11 times | Joined on Dec 2016
#83
@TheKit You're awesome for helping move the reality of a working SalifishOS tablet closer to being realised!

Does anyone recommend a source for the v3 Onda? I've found it offered on multiple sites (geekbuying.com, everbuying.net, etc.) but am not certain as to their reputation. Is it best to try and buy off eBay?

Thanks!
 

The Following 3 Users Say Thank You to sunburnedpenguin For This Useful Post:
Posts: 137 | Thanked: 749 times | Joined on May 2016
#84
Originally Posted by sunburnedpenguin View Post
Does anyone recommend a source for the v3 Onda? I've found it offered on multiple sites (geekbuying.com, everbuying.net, etc.) but am not certain as to their reputation. Is it best to try and buy off eBay?
Thanks!
I think it doesn't matter much as long as you can get right model. eBay and sites like jd.com, gearbest.com, geekbuying.com should be safe enough, but better pay with PayPal just in case. Local stock is preferred probably.
 

The Following 2 Users Say Thank You to TheKit For This Useful Post:
Posts: 527 | Thanked: 978 times | Joined on Mar 2015
#85
i strongly suggest to avoid gearbest. bad experiences with them, poor customer assistance, i had to really fight to have my rights respected
 

The Following 3 Users Say Thank You to itdoesntmatt For This Useful Post:
Posts: 148 | Thanked: 182 times | Joined on Apr 2012 @ Austria
#86
great, i could update my v5 and multitouch is working as well now, great job, thanks
Originally Posted by TheKit View Post
You need to upgrade to 2.0.5.6. I ported touchscreen vendor's driver from a different tablet which supports multitouch. Please do backup in case something goes wrong, then follow the instructions below:

Code:
ssu re 2.0.5.6
ssu dr adaptation0            
ssu dr adaptation1
ssu ar http://sfos.scanf.su/onda-v820w-v3/ adaptation-onda
ssu ur

version --dup

ssu dr adaptation0
ssu dr adaptation1
# Check if you still have adaptation-onda, if not - readd
ssu lr

# Remove old modules and reinstall device-specific packages:
rm /lib/modules/3.10.20/*.ko

zypper install -f droid-bin-tbj-onda-v820w-v3 droid-config-tbj-onda-v820w-v3 droid-config-tbj-onda-v820w-v3-flashing droid-config-tbj-onda-v820w-v3-kickstart-configuration droid-config-tbj-onda-v820w-v3-patterns droid-config-tbj-onda-v820w-v3-policy-settings droid-config-tbj-onda-v820w-v3-preinit-plugin droid-config-tbj-onda-v820w-v3-pulseaudio-settings droid-config-tbj-onda-v820w-v3-sailfish droid-config-tbj-onda-v820w-v3-ssu-kickstarts droid-hal-tbj-onda-v820w-v3 droid-hal-tbj-onda-v820w-v3-detritus droid-hal-tbj-onda-v820w-v3-kernel  droid-hal-tbj-onda-v820w-v3-kernel-modules droid-hal-tbj-onda-v820w-v3-tools

depmod -a

# Check if you have graphics group and nemo is a member of it
cat /etc/group | grep graphics

# Should output "graphics:x:1003:nemo". If it's wrong for some reason, reinstall droid-hal-tbj-onda-v820w-v3 again


You could try to ask the seller for device serial number located at the back side. For example, see this photo. It's P820DBF4V3...
 

The Following 2 Users Say Thank You to smatkovi For This Useful Post:
Posts: 148 | Thanked: 182 times | Joined on Apr 2012 @ Austria
#87
okay, the camera stopped working, but i don't care because i don't use it anyway, just fyi
Originally Posted by smatkovi View Post
great, i could update my v5 and multitouch is working as well now, great job, thanks
 

The Following 3 Users Say Thank You to smatkovi For This Useful Post:
Posts: 148 | Thanked: 182 times | Joined on Apr 2012 @ Austria
#88
here is the dmesg output of the updated v5 in case you're interested
Attached Files
File Type: deb dmesgOndaV5Output.deb (118.2 KB, 43 views)
 

The Following User Says Thank You to smatkovi For This Useful Post:
Posts: 142 | Thanked: 296 times | Joined on Nov 2014
#89
Originally Posted by TheKit View Post
You could try to ask the seller for device serial number located at the back side. For example, see this photo. It's P820DBF4V3...
Thanks, I did... with mixed results. Not everyone answered, some were sold out and one seller claimed he could not give me this information since the S/N changes on every tablet (even though I only asked to check if the 9th & 10th digits were V3 or V5)

I ended up ordering from here (EDIT: was sold out, after all). ATM it was the only Win 8.1 version I could find available and I figured the chances for V3 would be higher there, but let's see what I end up actually getting.)

EDIT: Seems like V3 are non-existent for now and even V5 are getting scarcer as many sellers reported having sold-out. Ordered one V5 (according to the seller) from eBay. We'll see...

Last edited by tmi; 2017-01-04 at 17:03.
 

The Following 4 Users Say Thank You to tmi For This Useful Post:
Posts: 58 | Thanked: 131 times | Joined on Dec 2016
#90
Originally Posted by TheKit View Post
I think it doesn't matter much as long as you can get right model. eBay and sites like jd.com, gearbest.com, geekbuying.com should be safe enough, but better pay with PayPal just in case. Local stock is preferred probably.
As also tmi said that V3 is currently very hard to find, I want to ask you directly: Is the only problem of V5 and (V6? or V7?) that you are not sure whether your port works there or are you sure that further adaptions are needed due to hardware changes in these revisions?
 

The Following 2 Users Say Thank You to bomo For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 20:44.