Notices


Reply
Thread Tools
RevdKathy's Avatar
Posts: 2,173 | Thanked: 2,671 times | Joined on Oct 2009 @ Cornwall, UK
#21
I'm watching.. with a bloody big grin on my face at the first genuine instance of the good people of t.m.o. helping out a n900 n00b. I'd go through the thread and thank every useful post if I weren't sneaking in here in my work lunch hour.
__________________
Hi! I'm Kathy and I'm a Maemo Greeter! Welcome.
Useful links for newcomers: New members say hello , New users start here, Community subforum, Beginners' wiki page, Maemo5 101, Frequently Asked Questions (FAQ)
Did you know Meego.com has forums too?
 

The Following 3 Users Say Thank You to RevdKathy For This Useful Post:
Posts: 9 | Thanked: 3 times | Joined on Oct 2009
#22
Originally Posted by felbutss View Post
im now trying it on a 32bit windows XP. still not working. keeps saying Suitable USB device not found, waiting
try using other than windows xp... i try to flash it on seven and it works after several try using xp ended with same problems like yours.

and please remember to enter flashing mode (hold "U" key while plug usb cable to your computer until it shows usb logo) before entering the command. Don't forget to run as administrator too...
 

The Following 2 Users Say Thank You to great_uq For This Useful Post:
daperl's Avatar
Posts: 2,427 | Thanked: 2,986 times | Joined on Dec 2007
#23
I'm sure this is getting resolved, but if not, maybe you should burn a i386 Ubuntu Live CD. Fire it up, then download the flasher program and firmware image to /tmp.
__________________
N9: Go white or go home
 

The Following 2 Users Say Thank You to daperl For This Useful Post:
ossipena's Avatar
Posts: 3,159 | Thanked: 2,023 times | Joined on Feb 2008 @ Finland
#24
i didn't manage to do it with win7 (64bit) but when booted ubuntu from usb stick, all went fine (except i forgot to flash the emmc )

i bricked my device this mornign and it has acted strange since after I got UI booted again, im now reflashing for third time a row.

see https://bugs.maemo.org/show_bug.cgi?id=6307
(my very first bug report )
__________________
Want to know something?
K.I.S.S. approach:
wiki category:beginners. Browse it through and you'll be much wiser!
If the link doesn't help, just use
Google Custom Search
 
Andre Klapper's Avatar
Posts: 1,665 | Thanked: 1,649 times | Joined on Jun 2008 @ Praha, Czech Republic
#25
"Suitable USB device not found, waiting" happened to me very often with my old machine under (both Windows and Linux) that has a broken USB. Hope that's not your case...
__________________
maemo.org Bugmaster
 

The Following 2 Users Say Thank You to Andre Klapper For This Useful Post:
Posts: 45 | Thanked: 1 time | Joined on Nov 2009 @ Australia
#26
When I've had similar problems with Symbian updates and found what worked for me was to reboot my PC, disable all anti-virus, anti-spyware and firewall software and that solved the problem.
 

The Following User Says Thank You to Darrylp For This Useful Post:
felbutss's Avatar
Posts: 579 | Thanked: 286 times | Joined on Oct 2009 @ Australia
#27
hey guys. just got back from the nokia care centre in australia. they had a funny reaction as they have never seen a n900 before. i told them its from Nokia head office. the bad news is they dont have any idea on what to do.

im going to try a few more things as im at work now on all different machines. the issue i still have is the flasher cant detect the device. i have done all of the above IE: hold 'U', take battery out, dont use the USB hub arrarara.......

this iss ssoo stressfull as i have only had the device for a week. i hope nokia do reply to my email soon as this is killing me.

Last edited by felbutss; 2009-11-25 at 00:56.
 
Posts: 1,208 | Thanked: 1,028 times | Joined on Oct 2007
#28
I have flashed N900 this way:

1. remove battery
2. connect USB cable
3. start flasher-3.5 from command line
4. insert battery
5. flashing starts

I haven't been able to flash in my Windows machine, because USB seems to be totally powered down when nothing is connected and flasher programs thinks that USB port doesn't exist.
 

The Following 2 Users Say Thank You to mikkov For This Useful Post:
felbutss's Avatar
Posts: 579 | Thanked: 286 times | Joined on Oct 2009 @ Australia
#29
ok guys. none of your idea worked . im now going to try and download a USB bootable copy of Ubuntu and try it through that.

im downloading all the files now and will try this soon but are there any points i need to know???

i will follow the instructions bellow but do i need to mount the USB drives or anything?????????

im following this tut on putting Ubuntu on a USB stick

http://www.pendrivelinux.com/create-...sb-in-windows/

LINUX

Once you have downloaded the flasher and the fiasco-image, follow these steps:


Now turn off your device (make sure you unplug the charger or else the device wont power down completely, you can plug the device back into power once it starts flashing) and plug in the USB cable to a port on the computer and the port on your device.
Now, open up a terminal and run:
It will ask you for an administrator password, enter it.

sudo ./flasher-3.5 -F <FIASCO image> -f -RIt

will say:
Suitable USB device not found, waitingFirst, unplug the power cord from the device, as this will prevent it from updating. Then take your device, and hold down the Home/Swap button (looks like a little house on the N800 and 770, and two overlapping rectangles on the N810, N900 users will not have to hold down anything), and while holding down the Home/Swap button press the power button to turn it on.
If it doesn't doesn't boot and start flashing, make sure the USB cable is plugged in.
It should start flashing and then reboot.
You can remove the USB cable after it has booted to a normal desktop (just make sure to eject any cards that may have mounted on your computer).
 
felbutss's Avatar
Posts: 579 | Thanked: 286 times | Joined on Oct 2009 @ Australia
#30
hey guys. im trying it right now on another XP machine untill the linux machine is ready and i noticed somthing. when i plug the device in it trys to install drivers or somthing for a second then keeps restarting. maybe i need a cold flash or somthing??????? what would be the commands???? or do i need to specify the accutal USB port in the command?????? soo confused
 
Reply

Tags
lack of quality control

Thread Tools

 
Forum Jump


All times are GMT. The time now is 15:22.